State of New Jersey
Department of Transportation

AASHTOWare Project
Cost Estimation System (CES) Manual
2017
**Formerly Construction Cost Estimation Guide (CCEG)**

The Trns*port Software Suite has been rebranded to **AASHTOWare Project**. It has been reflected in this manual in the rebranded name, however, CES will still be used for familiarity until the next software/manual update.
Table of Contents

1. Introduction .......................................................................................................................... 1
   1.1 Support ............................................................................................................................ 1
   1.2 Submittal .......................................................................................................................... 1
   1.3 PD Preparation ................................................................................................................. 1
   1.4 Documents Generated ..................................................................................................... 1
   1.5 Security ............................................................................................................................ 2
   Table 1-1. Project/Job/Proposal Construction Classifications ............................................. 2

2. AASHTOWare Project Cost Estimation (CES) Basics ......................................................... 1
   2.1 Logging On to the NJDOT Network .................................................................................. 1
       2.1.1 System Requirements ............................................................................................. 1
       2.1.2 Login Procedure .................................................................................................... 1
   2.2 Logging On to AASHTOWare Project Cost Estimation (CES) ....................................... 2
   2.3 Changing Your Password ............................................................................................... 3
   2.4 Using Buttons, Menus, and Shortcut Keys to Invoke Commands .................................... 4
       2.4.1 Title Bar .................................................................................................................. 6
       2.4.2 Menu Bar and Toolbar ............................................................................................ 6
       2.4.3 Understanding How Menus and Buttons Are Related ............................................ 6
       2.4.4 Using Shortcut Keys ............................................................................................... 7
   2.5 Adding, Changing, Deleting, and Viewing Information ................................................. 7
       2.5.1 Adding Information ................................................................................................. 8
       2.5.2 Changing Information ............................................................................................ 9
       2.5.3 Deleting Information ............................................................................................. 9
   2.6 Filtering Information ....................................................................................................... 12
       2.6.1 Using the Advanced Filter ..................................................................................... 13
   2.7 Sorting Information ........................................................................................................ 14
   2.8 Using Online Help .......................................................................................................... 15
   2.9 Closing Windows ............................................................................................................. 15
   2.10 Exiting CES ................................................................................................................... 16
   2.11 Logging Off the NJDOT Network ................................................................................... 16

3. Creating a New Job Estimate ............................................................................................... 1
   Table 3-1. NJDOT Project and Contract Work Types .......................................................... 2
   Table 3-2. NJDOT Highway Types ...................................................................................... 5
   3.1 Creating a New Job Estimate .......................................................................................... 5
       3.1.1 Adding a Job via the Add Command ........................................................................ 6
       3.1.2 Adding a Job via the Copy Special Option ............................................................. 11

4. Building a Long-Range (Preliminary) Estimate .................................................................. 1
   4.1 Long-Range (Preliminary) Estimation Methodology ...................................................... 1
   4.2 Cost Groups .................................................................................................................... 1
       4.2.1 Calculation Rules ...................................................................................................... 2
   Table 4-1. NJDOT Standard Cost Groups ........................................................................... 2
       4.2.2 Example ................................................................................................................... 7
   4.3 Select a Job for Long-Range (Preliminary) Estimation ................................................... 8
   4.4 Adding and Changing Cost Group Information ............................................................... 15
       4.4.1 Using Variables in Your Cost Group ....................................................................... 18
       4.4.2 Computing Price for Quantity ............................................................................... 19
       4.4.3 View Bid-Based Information .................................................................................. 20
5. Adding Job Estimate Details for Detailed (Final) Estimation ........................................ 1

5.1 Adding Job Estimate Details for Detailed (Final) Estimation ........................................ 1
5.2 Adding Variables to a Job .................................................................................................. 6
   5.2.1 Adding Groups ........................................................................................................... 6
   5.2.2 Adding Variables in a Group ...................................................................................... 7
5.3 Adding Categories ............................................................................................................. 8
   5.3.1 Categories – NJDOT Policy ...................................................................................... 10
   Table 5-1. Categories for Projects ..................................................................................... 10
5.4 Deleting a Job .................................................................................................................. 13
5.5 Viewing a Job .................................................................................................................. 15
5.6 Changing the Spec Year for a Job .................................................................................. 15
5.7 Splitting a Job ................................................................................................................ 16

6. Adding and Pricing Items for Detailed (Final) Estimation .............................................. 1

6.1 NJDOT Policies and Procedures ...................................................................................... 1
   6.1.1 Line Item Numbering ............................................................................................... 2
   6.1.2 ‘No Item’ Item .......................................................................................................... 2
   6.1.3 Alternate Items ......................................................................................................... 2
   6.1.4 Fixed Price Items ..................................................................................................... 2
   6.1.5 Newly Assigned Standard Items ............................................................................. 2
   6.1.6 Lump Sum/DOLL Items .......................................................................................... 3
   Table 6-1. Performance and Payment Bond - 151003M .................................................. 3
   Table 6-2. Final Cleanup - 161003P ................................................................................ 4
   Table 6-3. Owner’s & Contractor’s Protective Liability Insurance - 152003P ................. 4
   6.1.7 Maintenance and Operations Only Items ................................................................. 5
6.2 Adding Items ................................................................................................................... 5
   6.2.1 Adding Items Using the Grid View .......................................................................... 5
   6.2.2 Adding Items Using the Tree View ......................................................................... 8
6.3 Adding Item Variables .................................................................................................... 10
6.4 Adding Item Tasks .......................................................................................................... 11
   6.4.1 Adding and Changing Bid-based Prices ................................................................ 11
   6.4.2 View Bid-Based Information .................................................................................. 13
   6.4.3 Adding and Changing Cost Sheets ....................................................................... 15
   6.4.4 Copying Cost Sheets .............................................................................................. 25
   6.4.5 Cost Sheet List and Labor, Equipment, Materials, and Crews Lists ..................... 26
   6.4.6 Adding and Changing Reference Prices ................................................................ 26
   6.4.7 Adding Task Groups .............................................................................................. 28
6.5 Deleting Item Tasks ........................................................................................................ 29
   6.5.1 Deleting Bid-based Prices ..................................................................................... 29
   6.5.2 Deleting Cost Sheets .............................................................................................. 29
   6.5.3 Deleting Reference Prices ..................................................................................... 29
   6.5.4 Deleting Task Groups ............................................................................................ 29
6.6 Identifying Item Tasks as Active or Inactive ................................................................. 30
10.2.2 Labor List................................................................................................. 14
10.2.3 Equipment List.......................................................................................... 17
10.2.4 Crew List.................................................................................................. 20

11. Formulas and Formula Libraries .................................................................... 1
   11.1 Creating Formulas in a Job ....................................................................... 1
       11.1.1 Formula Example ........................................................................... 2
   11.2 Using Formulas.......................................................................................... 3
       11.2.1 Formula Library List ........................................................................ 3

12. Passing Final CES Estimate to AASHTOWare Project Preconstruction ............ 1
   12.1 Export Final CES Estimate to AASHTOWare Project Preconstruction ....... 1
   12.2 Verify That All Necessary Data Fields Have Been Filled In....................... 1

Appendix A: Procedures for Sub-Contracting an Estimate ................................. 1
Appendix B: Federal Non-Participating Construction Cost Estimation Work Sheet.... 1
Appendix C: NJDOT New Item Number Request Form ....................................... 1
1. Introduction

The AASHTOWare Project Cost Estimation System (CES) is part of AASHTO’s AASHTOWare Project software suite of applications and is NJDOT’s primary tool for construction cost estimation. CES provides a full range of cost estimating capabilities at any given engineering phase from conceptual estimation to the final engineer's estimate required for award approval. It may be used to produce long-range and detailed estimates, using cost-based and bid-based pricing methods.

The long-range estimate includes the estimate prepared for Scoping, as well as the Preliminary Design Submission. The detailed estimate begins at the point where item level information is added to the estimate. It is also referred to as the Engineer's Estimate or the Final Design Submission. Use of CES is part of an agency initiative to produce more accurate and consistent cost estimates earlier in the engineering phase.

For Use by the Designer’s Cost Estimators in developing Construction Cost Estimates for NJDOT Capital Program Projects at Preliminary Engineering (PD). PD estimates are based on the project’s type, length, pavement type, and types of bridges, and are used for the 5-year Program which involve the Metropolitan Planning Organizations, and the Transportation Improvement Program. The Cost Estimating Unit has been placed outside of the rest of the production units in order to provide independent estimates used in the financial programming.

This guide details the functionality of CES and how to use the application for the creation of long-range estimates and detailed estimates according to NJDOT policy. This manual is not intended to provide estimating guidance but rather software guidance. For the methodology to develop, document and review construction cost estimates throughout the project delivery process refer to the Cost Estimating Guideline by Program Management Office (PMO) (http://www.state.nj.us/transportation/capital/pd/process_cost.shtm).

1.1 Support

For issues or questions related to CES, please call NJDOT’s AASHTOWare Project helpdesk at 609-530-3582 or email aashtoware.support@dot.nj.gov.

1.2 Submittal

The PD submission shall include preliminary plans, a preliminary design cost estimate, and a transmittal letter with a date for review completion.

1.3 PD Preparation

A. Determine which of the thirteen classifications from Table 1-1, Project/Job/Proposal Construction Classifications, most nearly represents the type of work to be performed.

B. Refer to Sections 2, 3, 4 and 5 of the Cost Estimating Guideline by PMO to estimate construction costs associated with the preliminary preferred alternative.

C. For projects that do not fit into any of the seven classifications, the best results are usually obtained by searching out a previously completed project of a similar nature and adjusting its cost to reflect scope difference and price escalation.

1.4 Documents Generated

- Preliminary Design Engineer’s Estimate
- Non-Standard Item List and Calculations
1.5 Security
The Engineer’s Estimate is a confidential document and is only to be given out to Department personnel on a need to know basis. The file drawers containing the Engineer’s Estimates are locked.

Table 1-1. Project/Job/Proposal Construction Classifications

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. New Construction</td>
<td>New construction or major reconstruction of divided or undivided highways. Includes all major phases of construction site preparation, earthwork, drainage, structures, paving, etc. whether contracted separately or as a complete project. Minor items such as signing, landscaping and guiderail are included unless they are in separate specialty contracts. If Maintenance of Traffic will include two or more stages or if extensive Maintenance of Traffic equipment is needed, use Class 2.</td>
</tr>
<tr>
<td>2. Reconstruction, Widening and Dualization</td>
<td>The removal and replacement, rebuilding or upgrading of an existing facility, including intersections. There may be grade changes but normally the changes will not be significant. Includes all phases of construction. May include short utility relocations, placement and/or relocations of Intelligent Transportation Systems (ITS) facilities. Includes widening equivalent to one lane width or wider. Includes structures when decks are replaced on existing substructures or decks are widened and substructures extended. Includes intersection improvements when roadway area is also rebuilt.</td>
</tr>
<tr>
<td>3. Widening and Resurfacing</td>
<td>Widening and resurfacing of existing highway facilities when the total added width is equivalent to less than one lane width in each direction and grades are not changed. Includes minor grading, extending culverts, curb and gutter, etc. Includes bridge deck widening possibly without substructure changes. May require relocations of ITS facilities.</td>
</tr>
<tr>
<td>Type</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>4. Resurfacing</td>
<td>Overlaying existing highways, and surfacing or overlays existing shoulders with asphaltic material. Includes joint repair, minor widening with asphaltic materials, some base corrections or asphaltic base, curb and gutter replacement, and adjustments at structures, drives and street returns. Does not include extensive reconstruction, pavement replacement or construction of new pavements, excavation, utility or sewer work. Projects with milling operations may involve reconstruction of ITS device pavement sensors.</td>
</tr>
<tr>
<td>5. Bridge Repair</td>
<td>Repair of bridges, includes repairs to decks, curbs, rails, beams and structures. If total deck removal and replacement is required, the contract should be classified as reconstruction. Bridge Repair also includes bridge painting, which consists of the removal of lead based paint and the application of a high performance coating system.</td>
</tr>
<tr>
<td>6. Intersection Improvements</td>
<td>Minor construction or reconstruction of street or highway intersections. Normally includes some removal, grading, drainage and paving. May include curb and sidewalk along with traffic signals installed at the intersection. If intersection pavement is to be rebuilt, the contract should be classified as reconstruction.</td>
</tr>
<tr>
<td>7. Electrical, Safety, and Traffic Control</td>
<td>Placement, replacement and betterment of guiderail, signs, striping, traffic signals, highway lighting, sign lighting, electrical signs, movable bridge electrical systems and other safety and traffic control devices, along streets and highways, when let on a specialty contract basis. If electrical, safety and traffic control devices are included as part of a major contract type, they should be included under the miscellaneous activities for that type.</td>
</tr>
<tr>
<td>8. Miscellaneous</td>
<td>Construction activities, let on a specialty contract basis, not assignable to other work classes. Includes demolition of buildings, removal of asbestos, and railroad pavement painting.</td>
</tr>
</tbody>
</table>

Introduction
AASHTOWare Project Cost Estimation System (CES) Manual
<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>9. Unique</td>
<td>Construction activities of a distinctive nature, which is let on a specialty contract basis. Includes wetland replacement and restoration.</td>
</tr>
<tr>
<td>10. Intelligent Transportation Systems (ITS)</td>
<td>Construction of ITS devices and communication networks. Systems include computerized traffic signal control, dynamic message signs, closed circuit television, highway advisory radio, fiber optics and wireless technologies, traffic detection, weather station and data development traffic monitoring. Includes the integration of proposed devices with Traffic Operation Centers central control systems and interagency resource sharing through the regional and statewide ITS Architectures. If ITS systems are included as part of a major contract type, they should be included under the miscellaneous activities for that type.</td>
</tr>
<tr>
<td>11. Landscape</td>
<td>Design and installation of landscape architectural elements to enhance transportation facilities or to mitigate environmental and negative effects caused by transportation facility improvements. Work includes functional, aesthetic and safety plantings, reforestation, wetland mitigation, urban streetscapes, bicycle and pedestrian improvements, and structures aesthetics. This work may be part of other contracts or as independent contracts.</td>
</tr>
<tr>
<td>12. Demolition</td>
<td>Advanced Demolition of Buildings - the demolition and removal of buildings and appurtenances within acquired ROW, in advance of the main construction contract. Clearing Site, Underground Storage Tank Removal, Sealing of Abandoned Wells, and Asbestos Remediation could be included in this type of project.</td>
</tr>
<tr>
<td>13. Drainage</td>
<td>Includes cleaning, inspecting, capacity restoration and in-kind repairs to highway drainage facilities.</td>
</tr>
</tbody>
</table>
2. AASHTOWare Project Cost Estimation (CES) Basics

This chapter describes basic functionality of CES including basic navigation and how to access and log on to the application.

2.1 Logging On to the NJDOT Network

The CES application may be accessed by logging on to NJDOT’s network via the internet. Access to the CES application will be via a Citrix server. This section outlines the hardware requirements and procedures for accessing the NJDOT network.

2.1.1 System Requirements

The minimum system requirements that a user will need to use AASHTOWare Project through Citrix are:

- Pentium 3, 1GHz Processor
- 256 Mb RAM
- 10 Mb hard disk space
- Microsoft Windows 2000 or XP
- Internet Explorer 8.0, Service Pack 1 or Netscape 6.2 through 7.1 (Mozilla’s Firefox browser is not currently supported for use with Citrix)
- High-speed connection to the internet (DSL, Broadband, T1, etc.)

2.1.2 Login Procedure

In order to access the NJDOT network, a user needs a Citrix account and a CES account. These will be provided to you by NJDOT. For further assistance with obtaining the necessary user accounts, please contact the AASHTOWare Project helpdesk at 609-530-3582 or email trnsport.support@dot.nj.gov.

The steps for logging in are:

1. Access the Citrix Connection.
   - NJDOT staff accessing the network via an internal connection should use the link [http://trnsport.njes.state.nj.us/Citrix/trnsport/auth/login.aspx](http://trnsport.njes.state.nj.us/Citrix/trnsport/auth/login.aspx).
   - Consultants and other parties external to the DOT should use the link [https://oitmsac.state.nj.us/LogonAgent/Login.asp](https://oitmsac.state.nj.us/LogonAgent/Login.asp).
2. Login to Citrix.
3. The Citrix login window will open as shown in Figure 2-1. Enter the username and password that was provided for you by NJDOT. The domain is “NJDOT.LAN.” Note: The username field is not case-sensitive but the password field is.
**Note:** the first time you log in to Citrix from any PC you will be prompted to install the Metaframe Presentation Web Client. You must install this in order to use Citrix and access the NJDOT network.

![Citrix Login Window](image)

**Figure 2-1. Citrix Login Window**

Once logged in you should be able to see the Citrix desktop as shown in Figure 2-2.

![Citrix Desktop](image)

**Figure 2-2. Citrix Desktop**

### 2.2 Logging On to AASHTOWare Project Cost Estimation (CES)

Once connected to the NJDOT network through Citrix you may open the CES application by double-clicking on the CES icon. After a few moments, CES will display the Enter User Information window (see Figure 2-3).
Enter the User ID and the initial Password provided for you by NJDOT. The User ID and Password fields are not case-sensitive as the application will automatically force the values you enter to upper-case. Once you enter your user ID and password correctly, CES runs.

2.3 Changing Your Password

NJDOT will provide you with your initial password to access CES. You should change it the first time you login to the application. To change your password, choose Change Password from the Utilities menu (see Figure 2-4).
As shown in Figure 2-5, CES displays the Change Password window.

![Change Password Window](image)

**Figure 2-5. Change Password Window**

Enter your old password, press TAB, enter your new password, press TAB, and enter your new password again for verification. Your password must be between 6 and 13 characters. Click OK to change your password or CANCEL to close the window without changing your password.

If you click OK, your password changes. If you exit the software and attempt to log on using your old password, you receive an error message.

If you forget your password or exceed the maximum number of login attempts allowed, please contact NJDOT CES Support at transport.support@dot.nj.gov to reset your password.

**2.4 Using Buttons, Menus, and Shortcut Keys to Invoke Commands**

CES windows have title bars, menu bars, and toolbars so you can easily activate commands (see Figure 2-6).

![Typical AASHTOWare Project CES Title, Menu, and Button Bars](image)

**Figure 2-6. Typical AASHTOWare Project CES Title, Menu, and Button Bars**
To display text that identifies the CES button bar functions, rest the mouse pointer on the button bar and click the right mouse button. This displays a *right mouse button menu*, a feature of CES you will use frequently to complete your work (see Figure 2-7).

![Figure 2-7. Right Mouse Button Menu](image1)

Select **Show Text** from the menu to display identifying text on the button bar.

![Figure 2-8. Icons With Text](image2)

To move the button bar to a different location in the window, right click on the button bar and select one of the options listed: left, right, bottom, or floating.
2.4.1 Title Bar
The title bar contains the name of the application or window and buttons you can click to size, move, and close the window. In Windows, you can access the Control menu by clicking an icon in the upper-left corner of the window that represents the application in which you are working. In CES this icon looks like a small crane on top of the three-letter acronym for the CES module.

An easier way to manipulate the window is to use the three buttons in the upper-right corner of the window. The ‘X’ button closes the application completely, the middle button either reduces the size of the window to its intermediate size or maximizes the window from its intermediate size, and the ‘_’ button minimizes the application and displays it on the Windows taskbar.

2.4.2 Menu Bar and Toolbar
The menu bar (which includes the File, Edit, View, Utilities, Window, and Help menus) contains the names of menus of commands. Dimmed (grayed) menus are not available for the active window. You can click on a menu name to display all available commands for that menu and then click on the command to activate it.

Below the menu bar is the toolbar, which contains buttons for some of the most useful commands from the menus. The buttons available on the toolbar depend on the window that is open. In other words, the toolbar is context specific.

Select CES commands in one of these ways:
- Click on the menu name to display the menu items available from that menu. From there, select the command you want to run. For example, you could select Open Job List from the File menu.
- Click on one of the buttons on the toolbar to begin working with one of the major groups of data. For example, you could click on the JOBS button and CES would display the Jobs list window.

2.4.3 Understanding How Menus and Buttons Are Related
CES can often invoke a function in multiple ways. For example, the right mouse button menu offers many of the same commands as the menu bar and button bar buttons. List window right mouse button menus usually have three groups of commands (see Figure 2-9). The top group contains Add, Change, and Delete commands that are identical to those commands found on the Edit menu. The middle group of commands lists functions that are available only for the active window. These commands correspond to button bar buttons that also change depending on the active window. The last group usually contains only the Run Process command, which is the same as the Run Process command on the File menu.
2.4.4 Using Shortcut Keys

Many users find it helpful to access some of CES’s commands via the keyboard. For instance, you can access the menus available from the menu bar and the button bar buttons through the keyboard. The proper combination of keys held down at the same time, called shortcut keys, allows this access.

To access the menu bar options with the keyboard, press and hold down the ALT key, and at the same time, press the underlined letter in the name of the menu you wish to activate. For example, you can open the Jobs list window (select Open Job List from the File menu), then access the Utilities menu by pressing and holding down the ALT key and typing the letter U (for Utilities).

To select a command from an activated menu, simply type the letter underlined in that command. For example, to choose the Job command from the View menu, press and hold down the ALT key and type the letter J (for Job).

The button bar button commands appear as menu bar options and can be accessed in the same way as described above. Some menu item and button bar button commands can be accessed by a sequence of keys without going through a menu. For example, to sort information from a table, you would simply press CTRL+S to display the Sort window.

Within the Edit menu is a listing of some additional shortcut keys. There are several other shortcut keys within the different menus, and with practice you can become quite facile at maneuvering around in CES.

2.5 Adding, Changing, Deleting, and Viewing Information

There are different ways to access the commands to add, change, and delete records, as well as to perform other tasks. The right mouse button menu (Figure 2-10) is often the quickest way to access these functions. The right mouse button menu is context specific, meaning its menu items change as the information in the list window changes.
The Add command opens a window in which you can add information to create a new record. Unlike the other commands, you can invoke the Add command anywhere within the list window because you do not need to access information for a specified record. The Change command opens a window for the selected record, which you can modify. The Delete command deletes the selected record or records, but first warns you what other tables will be affected by the deletion. The View command opens a window for a record in a mode in which you can view but not modify information.

### 2.5.1 Adding Information

You can add information to list windows by choosing Add from the Edit menu, pressing the INSERT key, or selecting Add from the right mouse button menu. CES displays a tabbed folder window in which you add information to create a record.

**Note:** If you are adding a new job, CES displays a window in which to select a spec year for the new job before displaying the tabbed folder window.

You can type information directly in any field that displays a text box. Each field name that is italicized is a required field and must have data entered. Each field with a down
arrow next to it has a list of reference or code table values from which to select an entry for that field. This type of field only accepts valid values. If you know the exact entry, you can type it in.

**Note:** If you add or change information incorrectly in a field, you can press `ESC` while still in the field to erase the incorrect value and automatically replace it with the original value, if any.

To move from field to field, use the `TAB` key or click the mouse in the desired field. To move among tabs of a tabbed folder window, click on the appropriate tab name.

When you finish adding information in a tabbed folder window, be sure to choose **Save** from the **File** menu to save your work.

### 2.5.2 Changing Information

To change the information for a record that already exists, select that record from the appropriate list window, and choose **Change** from the **Edit** or right mouse button menu. CES displays a Change tabbed folder window.

![Figure 2-12. Typical CES Change Window](image)

The window contains any information entered previously for the record. You can change the information in any field that has a text box. Fields with a background color that matches the window’s background cannot be modified.

### 2.5.3 Deleting Information

Deleting CES information could have serious consequences. Make sure you know what you are deleting and what records you will affect before deleting anything. Your ability to delete records is based on how your security is defined within the application. In some instances, you will not be able to delete certain records like standard formulas and cost groups from the reference lists since these records are shared by all users.

You can delete information in list windows in one of several ways:
• By selecting a record in the list window and then choosing **Delete** from the **Edit** menu.
• By selecting a record and choosing **Delete** from the right mouse button menu.
• By selecting a record and pressing **SHIFT+DELETE**.

You can choose to delete more than one record at a time by holding down the **CTRL** key as you select the records. If the records you want to delete are adjacent to one another, you can select the first one, press and hold down the **SHIFT** key and select the last one. All the records in between are selected for deletion.

CES displays a series of Delete Warning windows depending on how much data you are deleting at one time.

If you are deleting an entire job from the Jobs list window, a special Delete window will display in advance of the regular warning windows (see Figure 2-13).

![Figure 2-13. Job Delete Window](image)

If you select **DELETE**, CES erases the job, but retains any **snapshots** taken of the job, including an automatic snapshot taken during the deletion process. **POWER DELETE** is a more thorough deletion option that not only erases a job, but also deletes any traces of that job’s existence including snapshots and other job information.

Depending on your security privileges, you may not have to option for Power Delete.

Figure 2-14 shows an example of the first Delete Warning window that might appear if you attempted to delete a record. In this example, there are several tables of data that would be affected by the deletion. This means you would have to confirm the deletion several times before CES would delete the data from the database. The window title bar lists the number of deletes required.
Notice that the Delete Warning window lists all the affected tables. If you click **YES**, CES displays a second Delete Warning window, unless the information you are deleting only affects one or two tables. In that case, there is only one Delete Warning window.

If you click **YES** in the second Delete Warning window, CES displays a final Delete Warning window.

If you click **YES**, CES displays one more deletion window to confirm the delete.
If you click YES, CES completes the deletion for a single record. If you are deleting more than one record, clicking YES TO ALL would also be an option, and it would allow you to delete all the selected records at once. If multiple records are selected and you click NO, the record currently listed will not be deleted, and you will move on to the Confirm Delete window for the next record. CANCEL returns you to the list window without altering any more records, but the ones for which you have already clicked YES are still deleted.

2.6 Filtering Information

You can use CES’s filter to find all the records that meet certain criteria. You can filter data in a list window or in a reference table window for a tabbed folder window field. You can also save a filter to use again later.

There are three ways to display a Filter window: clicking the FILTER button, choosing Filter from the Edit menu, or pressing CTRL+F.

Enter information in the Column, Operator, and Value fields to define a simple filter.

- **Column**: Click on the down arrow beside this field to display a list of columns. From this list, you can select the column on which to base your filter.

- **Operator**: Click on the down arrow beside this field to display the options from which to choose to narrow your filter: equal to (=), greater than (>), less than (<), greater than or equal to (>=), less than or equal to (<=), not equal to (<>), Contains, Does not Contain, Like, and Not Like, which are for pattern matching, and Null and Not Null (mostly used for numeric fields).

- **Value**: Type information in this field to specify the filter criterion you are trying to match. You can use % (percent) as a wildcard to represent any number of characters, or _ (underscore) to represent a single character with the
Contains, Does not Contain, Like, and Not Like operators. The CES filter is case sensitive, so be sure to type in exactly what you are trying to match.

Once you have entered a filter’s information, click OK to apply the filter to the active window, or CANCEL to cancel the filter.

To return a window to its original unfiltered state, access the Filter window and click the SHOW ALL button.

2.6.1 Using the Advanced Filter

To filter information using a more complex set of criteria, while in the Filter window, click the ADVANCED button and CES displays the Advanced Filter window.

Use the Advanced Filter window to build a set of conditions you want CES to use in filtering information by entering values in these fields:

**Name**
You can assign the filter a name and save it so it can be used again later. If you want to use a filter you created previously and saved, click on the down arrow to display a list of saved filter names. Click on the one you want to use. The filtering information loads automatically in the Advanced Filter window fields. To remove a saved filter from the list, select it and click DELETE.

**Build Where Condition**
In this box, you set the values for the Column, Operator, and Value fields just as you do for a simple filter (see Section 2.6). Click ACCEPT to accept the conditions of the filter. CES displays the values you entered as a row in the Select Where box.
Select Where

To add additional rows of filter information, click the INSERT ROW button at the bottom of the window. Highlight the row you just inserted, enter values in the Build Where Condition box and click ACCEPT. Each time you click the INSERT ROW button, CES inserts a row above the currently selected row in the Select Where box. To insert a row at the bottom of the list, click the ADD ROW button. To delete a row, select the row and click the DELETE ROW button.

Once you have several rows to work with, you may want to organize them so that the filter finds information that contains all or only some of the filter criteria. To do this, include an AND or OR operator between rows. AND finds records that meet both criteria and OR finds records that meet one or the other criteria. You can select AND or OR from a drop-down list attached to the field. To delete an AND or OR operator, click on the blank area at the bottom of the drop-down list.

There may also be times when you want to combine rows of criteria. You can use parentheses marks to group rows in a filter. To group two rows of criteria, highlight the first row of criteria and click on the (+ button to insert a parenthesis before the criteria. On the same row, select the AND or OR operator that associates the two rows of criteria. Then, select the second row and click the )+ button to close the parenthesis. To remove a parenthesis, select the row where the parenthesis is and click the (- or )- buttons.

Once you have entered all the filter information, click SAVE to save the filter, DELETE to delete an existing filter, CLOSE to close the filter without applying it to the window, or APPLY to apply the filter to the window.

2.7 Sorting Information

To sort information in a list window, choose Sort from the Edit menu, press CTRL+S, or click the SORT button. CES displays the Sort window.
The Column field contains the names of all the columns in the list window. When you click on the down arrow in the Column field, the list of columns to choose from appears.

Click ASC or DESC to select an ascending (A-Z) or descending (Z-A) sort order for the selected column. When values containing both numbers and letters are listed in ascending order, numbers precede letters, and vice-versa for descending order.

If you want to sort by additional fields, click ADD and CES adds another row for sort criteria. If you want an additional row inserted before the currently selected row, click INSERT. To delete the currently selected row of sort criteria, click DELETE. Click APPLY to sort the list window or CANCEL to return to the list window without sorting the list window. If you click HELP, CES displays a help window with information about sorting a list window.

2.8 Using Online Help

To get online Help for CES commands, tasks, or options, you can use the Help menu.

![Figure 2-21. Help Menu](image)

If you choose Help Index from the Help menu or press F1, you see an index of available topics. You can double-click on any of the topics to get more information.

If you choose Getting Started from the Help menu, you see introductory information about CES.

If you choose Search, CES displays a Search window in which to search for a specific CES topic.

If you choose About AASHTOWare Project CES, a window appears with general information about the application, including the version number.

2.9 Closing Windows

You can close CES windows in one of these ways:

- Select Close from the File menu.
• Click the x button in the upper-right corner of the active window.
• Press CTRL+F4.

2.10 Exiting CES

You can exit CES in one of these ways:
• Choose Exit from the File menu.
• Click the x button in the upper-right corner of the CES application window.
• Click on the icon in the upper-left corner of the window and select Close from the menu.
• Press ALT+F4.

CES displays the Close dialog box.

![Close Dialog Box](image)

Figure 2-22. Close Dialog Box

Click OK or press ENTER

2.11 Logging Off the NJDOT Network

To log off of the NJDOT network press the LOG OUT button in the upper right-hand corner of the browser window as shown in Figure 2-23.

![Citrix Desktop Log Out Button](image)

Figure 2-23. Citrix Desktop Log Out Button
3. Creating a New Job Estimate

In AASHTOWare Project CES, a job is the combination of all the factors that comprise the work to be estimated. The cost of a job equals the sum of the costs for the active cost groups plus the cost of the items separately included in the job, plus inflation factor and contingency percent. CES can use various means to arrive at estimates including cost-based estimation, bid-based estimation, user-defined formulas, and reference prices.

In some cases the initial information needed to create a new job estimate will be entered by the NJDOT lead engineer assigned to the project before it is assigned to a consulting firm for estimation. If the estimate has already been created, you should refer to Chapter 4 – Building a Long Range Estimate or Chapter 5 – Adding Job Estimate Details for Detailed Estimates.

Frequently, highway construction projects and contracts are classified into general classifications such as new construction, rehabilitation, widening, preventative maintenance, etc. While these improvement type classifications are important for program budgeting and reporting purposes, they are limited for the purpose of classifying contracts based on task functionality. For example, some widening jobs are heavy on asphalt items while others are heavy on earthwork, drainage and/or concrete items. Better functional classification of contracts allows more accurate market determination, which will improve the State’s ability to examine competition and bidding issues using the BAMS/DSS system. From an estimating perspective, work type (and major item) classifications can be used effectively to improve project cost estimation using CES and/or AASHTOWare Project Estimator®.

A recommended list of contract work types is provided in the following table. Using these functional work types allows for better identification and grouping of like contracts for the purpose of determining and analyzing the markets where like contractors interact for various contracting functions (e.g. asphalt, earthwork, structures). Also, since AASHTOWare Project BAMS/DSS® is the source for historical bid prices, consistent use of work type and item classifications across all AASHTOWare Project modules facilitates enhanced bid-based pricing for cost estimating.

The Job Work Type variable (JOB.jobworktype) in CES, which corresponds to the Contract Work Type variable (DPROPOS.L.cnrpwrk) in BAMS/DSS, can be used to store the functional classification.

The general construction classifications (new construction, widening and resurfacing, etc.) should also be entered for each project. For example, the Job Type variable (JOB.jobtype) in CES can be used to store these improvement type classifications.

To a large extent, the functional classification of contracts is a subjective process that requires the exercise of judgment. Generally, we can classify the contracts according to what functions are likely to control the award of the job as measured by the major item dollar percentages. Absent special circumstances, such as a high degree of specialty work or lump sum items, a major item concentration of 35 percent or greater is usually considered as determinative of work type classification. Many contracts will not fall neatly into any particular category, with the dollars evenly divided across more than one major item. In such cases, a General Construction work type code may be appropriate.

In practice, contract work types initially assigned in CES can be reviewed and revised later when the detailed line items have been fully specified for the project. For example, when the data is finally passed to BAMS/DSS, work type coding can be re-evaluated for...
data analysis purposes using the Contract Profile AdHoc program that summarizes the contract dollar percentages by item classification.

### Table 3-1. NJDOT Project and Contract Work Types

<table>
<thead>
<tr>
<th>Work Type Code</th>
<th>Work Type Classification Description</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASPH</td>
<td>Primarily asphalt work. Typically over 35 percent asphalt item dollars.</td>
<td>NEW CONSTRUCTION RESURFACING RECONSTRUCTION BITUMINOUS PAVEMENT</td>
</tr>
<tr>
<td>BRPT</td>
<td>Bridge painting and cleaning</td>
<td>BRIDGE PAINTING BRIDGE CLEANING</td>
</tr>
<tr>
<td>CONC</td>
<td>Primarily Portland cement concrete work</td>
<td>CONCRETE PAVEMENT</td>
</tr>
<tr>
<td>CURB</td>
<td>Curbs, sidewalks, and gutters</td>
<td>CURB &amp; GUTTER</td>
</tr>
<tr>
<td>DRNG</td>
<td>Drainage work and Erosion control Drainage projects are those involving primarily the non-incidental improvement to drainage or erosion control. Drainage projects may include the installation/rebuilding of box culverts, ditches, inlets, gutters, and/or piping structures. Erosion control may include the installation of rip rap, wire mesh netting, construction of sediment ponds, slope stabilization, retaining walls, etc.</td>
<td>CULVERTSDITCHES DRAINAGE EROSION CONTROL</td>
</tr>
<tr>
<td>ERTH</td>
<td>Earthwork</td>
<td>EARTHWORK EXCAVATION GRADING</td>
</tr>
<tr>
<td>FENC</td>
<td>Fencing</td>
<td>FENCES GATES</td>
</tr>
<tr>
<td>GDRL</td>
<td>Guiderail Guiderail refers to the non-incidental installation of guiderail/guardrail upon an existing facility. Installation of guiderail/guardrail should be the primary activity related to contracts of this classification.</td>
<td>GUIDERAIL/GUARDRAIL MEDIAN CROSSOVER PROTECTION</td>
</tr>
<tr>
<td>Code</td>
<td>Description</td>
<td>Notes</td>
</tr>
<tr>
<td>------</td>
<td>-----------------------------------------------------------------------------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td>GENC</td>
<td>General construction</td>
<td>Typically 20 percent or more individually allocated to paving (asphalt or concrete), earthwork (and/or drainage), and structures.</td>
</tr>
<tr>
<td>INTC</td>
<td>Interchange</td>
<td>Interchange work includes new interchange construction and the reconstruction or widening of an existing interchange. New interchange projects involve the construction of a new facility or structure that allows the junction of highways, usually on different levels – thereby permitting traffic to move from one to another without crossing traffic streams. The facility construction includes the connected entrance and exit ramps. Interchange projects will be of varying complexity and widely varying cost depending on the nature and location of the conjoining roadways and the nature of the improvement. Typical interchange projects include improvements made to “diamond” and “at-grade” interchanges, while complex interchange projects include improvements made to cloverleaf interchanges and interchanges at the junction of two interstate highways, and the like.</td>
</tr>
<tr>
<td>ITS</td>
<td>Intelligent Transportation Systems</td>
<td>ITS FACILITIES</td>
</tr>
<tr>
<td></td>
<td></td>
<td>CCTV TRAFFIC MONITORING</td>
</tr>
<tr>
<td>JNTS</td>
<td>Joints</td>
<td>PAVEMENT CRACK SEAL JOINT REPAIR</td>
</tr>
<tr>
<td>LAND</td>
<td>Landscaping</td>
<td>LANDSCAPING MOWING</td>
</tr>
<tr>
<td>LTNG</td>
<td>Lighting</td>
<td>LIGHTING, RELAMPING</td>
</tr>
<tr>
<td>MISC</td>
<td>Miscellaneous</td>
<td>EMERGENCY STANDBY MACHINE SWEEPING</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NOISE BARRIERS</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PAVEMENT CLEANING</td>
</tr>
<tr>
<td></td>
<td></td>
<td>REST AREAS</td>
</tr>
<tr>
<td>PVMK</td>
<td>Pavement marking</td>
<td>PAVEMENT MARKING</td>
</tr>
<tr>
<td>RMVL</td>
<td>Removal of buildings</td>
<td>DEMOLITION OF BUILDINGS</td>
</tr>
<tr>
<td>SGNL</td>
<td>Signals</td>
<td>Non-incidental improvements to signalization at intersections.</td>
</tr>
<tr>
<td>------</td>
<td>---------</td>
<td>-------------------------------------------------------------</td>
</tr>
<tr>
<td>SIGN</td>
<td>Signs</td>
<td>Non-incidental improvements to signing.</td>
</tr>
<tr>
<td>SRFP</td>
<td>Surface prep</td>
<td></td>
</tr>
<tr>
<td>STRL</td>
<td>Structures – large</td>
<td>Typically over $500,000, but more importantly bid on by large structures contractors.</td>
</tr>
<tr>
<td>STRS</td>
<td>Structures – small</td>
<td>Typically under $500,000, but more importantly bid on by small structures contractors.</td>
</tr>
<tr>
<td>UTIL</td>
<td>Utility work</td>
<td>Includes potable water, gas mains, telephone and electric utility work.</td>
</tr>
</tbody>
</table>

A highway type should be specified on every job estimate. Highway types may be any combination of the values defined in the table below by combing a value from Column A with a value from Column B.

Exceptions to this are: **Various**, which should be specified when a project encompasses multiple highway types; **Planning and Statewide Projects, Enhance**, which should be used for Maintenance jobs; and **Not Applicable**, which should only be used when the work does not fall into one of the pre-defined highway types.
Table 3-2. NJDOT Highway Types

<table>
<thead>
<tr>
<th>Column A</th>
<th>Column B</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Expressway</strong></td>
<td><strong>Principal Arterial</strong></td>
</tr>
<tr>
<td>A divided multi-lane arterial highway for through traffic with full or partial control of access and generally with grade separations at major intersections. On rare occasions expressways may also include two lane roadways.</td>
<td>Forms an interconnected network of continuous routes serving corridor movements having the highest traffic volumes and the longest trip lengths including substantial statewide or interstate travel.</td>
</tr>
<tr>
<td><strong>Freeway</strong></td>
<td><strong>Minor Arterial</strong></td>
</tr>
<tr>
<td>An expressway with full control of access and grade separations at all intersections.</td>
<td>Interconnect with and augment the principal highway system. Service trips of moderate length at somewhat lower level of travel mobility. Provide relatively high overall travel speeds with minimum interference to through movements.</td>
</tr>
<tr>
<td><strong>Divided</strong></td>
<td><strong>Major Collector</strong></td>
</tr>
<tr>
<td>A highway, street or road with opposing directions of traffic separated by a median.</td>
<td>Serve important intra-county traffic corridors and provide service to major county traffic generators.</td>
</tr>
<tr>
<td><strong>Undivided</strong></td>
<td><strong>Minor Collector</strong></td>
</tr>
<tr>
<td>A highway, street or road with opposing directions of traffic.</td>
<td>Serve smaller places and towns and connect locally important traffic generators.</td>
</tr>
<tr>
<td></td>
<td><strong>Local</strong></td>
</tr>
<tr>
<td></td>
<td>All roads not included in the higher classifications. These streets and roads provide direct access to abutting land and permit access to the roads of higher classification. They offer the lowest mobility.</td>
</tr>
</tbody>
</table>

This chapter details how to create a new job estimate.

### 3.1 Creating a New Job Estimate

Most of the work you perform in AASHTOWare Project CES will probably be initiated via the Jobs list window. This window lists all the existing jobs in CES that match your user ID’s control group (i.e. security access), and through it you can change, delete, and view those jobs as well as add new ones. You can also view and create new job snapshots from the Jobs list window.

To access the Jobs list window, click the Jobs button on the toolbar, or select **Open Job List** from the **File** menu. The Jobs list window will display.
There are two ways to add a job from the Jobs list window.

1. Open the Add Job tabbed folder window and enter all the necessary job header information, or
2. Use one of CES’s Copy Special options. Both of these options are discussed in detail below.

### 3.1.1 Adding a Job via the Add Command

To add a job “from scratch” using the Add command, select **Add** from the **Edit** drop-down menu or the right mouse button menu, or press the INSERT key on the keyboard. A window will display in which to select the spec year for the new job (see Figure 3-2).
Select the appropriate spec year for the job and click OK, or click CANCEL to cancel the action. The list of spec years represents all valid spec years contained in the master list of items.

If you click OK, CES displays Page 1 of the GENERAL tab of the Add Job tabbed folder window.

![Figure 3-3. Add Job Tabbed Folder Window](image)

To create a new job estimate, the fields outlined in the table below are required to be entered in order to initiate the project and save the record. In the Job window the labels for fields required by the system are in *italics*. The other fields in the window will be addressed in a later chapter as details are added to the estimate.

<table>
<thead>
<tr>
<th>Add Job - Page 1</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>UPC/DP#</strong></td>
</tr>
<tr>
<td>The primary identifier for the estimate. For CPM jobs enter the UPC#. For Operations jobs enter the DP#.</td>
</tr>
</tbody>
</table>

Most long range estimates will have several alternatives. The initial alternative projects will be named using the UPC with an alternate # appended, for example:

- 048061ALT1
- 048061ALT2
- Etc.

When the decision has been made on which alternative to use, make a copy of that Job (Edit menu | Copy Special | All),
assigning the UPC number alone as the Job/Project number, for example, 048061.

As a time-saving resource, users may wish to create template jobs from which to copy or import information. In this case, name the job 'TEMPLXXXX##,' where 'XXXX' is the code for your consulting firm, as used in the 'CONSULTANT Firm' field on Page 2, and '##' is a unique identifying number. (NJDOT users creating a template should use the code for their name in the "Reviewed by" field on page 1 for 'XXXX'.)

Observing this naming convention will make the job recognizable as a template by NJDOT reviewers and System Managers.

| **Unit System** | All NJDOT jobs unless otherwise noted should use English as the Unit System. The value for this field should default to 'E' for English. If not, the value may be populated or changed by selecting the down arrow beside the field to display a drop-down list from which to select a unit system. |
| **Project Name** | The name of the project. |
| **Route** | The primary route of the project. |
| **Description 1** | The primary description for the job. This should be a complete name, not a continuation of the Project Name. |
| **Description 2** | A continuation of the description, if needed. |
| **Classifications** |  |
| **Work Type** | The primary type of work being performed for the job. A complete list of Work Types with descriptions may be found on pages 3-2 thru 3-4 of this guide. The Work Type code may be populated by selecting the down arrow beside the field to display a drop-down list from which to select a work type. |
| **Highway Type** | The primary type of highway for the job. Enter the highway code by selecting the down arrow beside the field to display a drop-down list from which to select a highway type. A complete description of each Highway Type may be found on page 3-5 of this guide. |
| **Job Type** | The type of job being estimated. Enter the job type code by selecting the down arrow beside the field to display a drop-down list from which to select a job type. A complete description of each Job Type may be found on pages 1-2 thru 1-5 of this guide. |
| **Location** |  |
| **County** | The county in which the **majority** of job work will be performed. Enter a county code by selecting the down arrow beside the field |
Creating a New Job Estimate

AASHTOWare Project Cost Estimation System (CES) Manual

AASHTOWare Project Cost Estimation System (CES) Manual

to display a drop-down list from which to select a county. Entering a primary county also fills in the District field, which is the region where the work will be performed.

For jobs that are region-wide the county of the regional office should be designated (i.e. Morris for North, Monmouth for Central and Camden for South). For jobs that are statewide, use Mercer county.

**Urban/Rural**
The primary type of worksite for the job. Enter the urban/rural code by selecting the down arrow beside the field to display a drop-down list from which to select an urban/rural code.

**District**
The New Jersey regional office in charge of the job. This field is automatically filled in when you enter a county code. Alternatively, enter a district code by selecting the down arrow beside the field to display a drop-down list showing the District Offices. For Statewide jobs, use the code for Headquarters.

**Begin Termini**
The termini at which the job begins (milepost).

**End Termini**
The termini at which the job ends (milepost).

**Metrics**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Depth (in/mm)</td>
<td>The depth of the job being estimated. The value entered must be numeric.</td>
</tr>
<tr>
<td>Length (Mi/km)</td>
<td>The length of the job being estimated. The value entered must be numeric.</td>
</tr>
<tr>
<td>Width (ft/m)</td>
<td>The width of the job being estimated. The value entered must be numeric.</td>
</tr>
<tr>
<td>Lane (Mi/km)</td>
<td>The total number of lane miles or kilometers involved in the job being estimated. This field is required unless not relevant to the type of work being performed. The metrics are not necessarily exact numbers but rather averages to be used for conceptual areas.</td>
</tr>
</tbody>
</table>

**Inflation**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inflation (%)</td>
<td>The anticipated percentage of inflation per year until work begins on the job. If this number is not known, use the <em>model inflation</em> for bid-based Inflation (defined in the Bid Histories section). If using <em>model inflation</em>, set this to zero.</td>
</tr>
</tbody>
</table>
**Years Until Work**  
The total number of years prior to the start of the project. This number is used with the Inflation % to annually inflate the total job estimate, before applying the contingency percent.

**Base Date**  
The date from which inflation is calculated for bid-based item tasks or cost groups assessed using regression analysis. The entry should be the date construction is expected to start. This field defaults to the current date.

### Bid Histories

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Cost Group History</strong></td>
<td>The cost group library from which CES will draw when calculating bid-based prices for cost groups. Enter a library name by selecting the down arrow beside the field to display the Cost Group Bid History Libraries window and select a cost group library. It is used for long range bid-based estimation only. This field is not required for the detailed estimate.</td>
</tr>
<tr>
<td><strong>Item History</strong></td>
<td>The bid history library from which CES will draw when calculating bid-based prices for items. Enter a library name by selecting the down arrow beside the field to display the Item Bid History Libraries window and select an item library. It is used for detailed bid-based estimation only. This field is not required for long-range estimation.</td>
</tr>
<tr>
<td><strong>Bid-based Inflation</strong></td>
<td>The method of inflation calculation CES uses when determining the costs for bid-based items or cost groups assessed using regression analysis: model inflation or job inflation. Select USE MODEL if you want CES to use the inflation rate determined by the bid history model. Select USE JOB if you want to use the job inflation percentage assigned via the Inflation % field.</td>
</tr>
<tr>
<td><strong>Season</strong></td>
<td>The season in which the majority of job work will be performed. NJDOT jobs should use the value ‘ALL’ to indicate all seasons. The field value should already default to ‘ALL.’ If not, the value may be changed by selecting the down arrow beside the field to display a drop-down list from which to select it.</td>
</tr>
</tbody>
</table>

### Other Fields

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Date Created</strong></td>
<td>The date the estimate is created. This field defaults to the current date, but may be altered.</td>
</tr>
<tr>
<td><strong>Last Updated</strong></td>
<td>The date the estimate was last updated. When first entering a job, this field defaults to the current date. Once a job has been saved, this field automatically displays the date that information for the job was last updated.</td>
</tr>
</tbody>
</table>
### Conceptual Estimate
The speculated total cost for the job. Enter an amount in this field or double click in the field to use a formula that derives an amount.

### Contingency Percent
The percentage of the job cost being set aside to cover expenses for unforeseen occurrences. For project initiation this field should default to “0.00”. Typically this field is not filled in at this time but if the Designer sees the need, it may be populated.

<table>
<thead>
<tr>
<th>Page 2</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Latitude</strong></td>
</tr>
<tr>
<td>The project’s midpoint latitude, entered in the form of degrees, minutes, and seconds (DDMMSS). This midpoint must fall within the county that is specified on Page 1.</td>
</tr>
<tr>
<td><strong>Longitude</strong></td>
</tr>
<tr>
<td>The project’s midpoint longitude, entered in the form of degrees, minutes, and seconds (DDDMMS). This midpoint must fall within the county that is specified on Page 1.</td>
</tr>
<tr>
<td><strong>Control Group</strong></td>
</tr>
<tr>
<td>The access control value for the job estimate. This is a required field used for security purposes. Each user is assigned to a control group and can only access job estimates with matching control group values. The value defaults to the control group assigned to the user. Changing the control group value is used to pass responsibility for the job estimate to a user in a different control group.</td>
</tr>
<tr>
<td><strong>CONSULTANT Firm</strong></td>
</tr>
<tr>
<td>The code for the name of the firm responsible for producing the long-range estimate, once it is assigned. Enter the name by selecting the drop down menu to display the list of firms from which to select a name.</td>
</tr>
<tr>
<td><strong>CONSULTANT Consultant/PM</strong></td>
</tr>
<tr>
<td>The individual who is responsible for producing the long range estimate once it is assigned. Enter the full name.</td>
</tr>
</tbody>
</table>

To save the job header information, close the Add Job tabbed folder window or select **Save** from the **File** menu or the Button Bar. Make sure you save your work frequently. You can only save your work after required information is entered.

### 3.1.2 Adding a Job via the Copy Special Option
With CES’s Copy Special option, you can choose to copy the job header information, the header and cost group information, or all the information from an existing job to a newly created job. Copying is helpful when creating multiple estimates for the same project in order to evaluate different scenarios, or when a new job is very similar to an existing job.

**Copying the Job Header Only**
In CES, job header information is found on the **GENERAL** tab of the Job tabbed folder window. To add a job by copying the **GENERAL** tab information from another job, begin by selecting the job from which to copy information while in the Jobs list window. Next,
select **Copy Special** from the **Edit** menu, and then choose **Header**. A Copy Job Header Information window displays.

![Copy Job Header Information](image)

**Figure 3-4. Copy Job Header Information Window**

Enter information in these fields to complete the window:

- **New Job Number**
  
  The NJDOT UPC or DP number. This field defaults to the existing job estimate number; however, since CES requires that all job numbers be unique, it should be overwritten. If you are creating multiple estimate scenarios for the same project, use the naming convention of “NJDOT UPC # + ALT1” for the first estimate scenario, “NJDOT UPC# + ALT2” for the second estimate scenario and so on, e.g. 048061ALT1, 048061ALT2, etc.

  As a time-saving resource, users may wish to create template jobs to copy or import information from. In this case, name the job ‘TEMPLXXX##,’ where ‘XXXX’ is the code for your consulting firm, as used in the ‘CONSULTANT Firm’ field on Page 2, and ‘##’ is a unique identifying number. (NJDOT users creating a template should use the code for their name in the “Reviewed by” field on page 1 for ‘XXXX’.)

  Observing this naming convention will make the job recognizable as a template by NJDOT reviewers and System Managers.

- **New Job Description**
  
  The description for the new job. Changing the information listed in this field is optional.

Click the **OK** button to confirm your entries, or click **CANCEL** to cancel the action.

If you click **OK**, CES will list the new job just created in the Jobs list window. This job will contain the same header information as the original job, with the exception of the job number and possibly the job description.

To add or edit the information for the new job, select the job in the Jobs list window and choose **Change** from the **Edit** or right mouse button menu. The Job tabbed folder window will display in a mode in which to change the information shown. Complete the tabs in this window to create the job estimate. For more information about completing...
the tabs, see Chapter 4 – Adding Job Estimate Details for Long Range Estimates or Chapter 5 – Adding Job Estimate Details for Detailed Estimates.

**Copying the Job Header and Cost Groups**

To add a job by copying all the header and cost group information from an existing job, begin by selecting the job from which to copy information while in the Jobs list window. Next, select **Copy Special** from the **Edit** menu, and then choose **Copy Header and Cost Groups**. A Copy Job Header Information and Cost Groups window displays.

![Copy Job Header and Cost Groups Window](image)

**Figure 3-5. Copy Job Header Information and Cost Groups Window**

Enter information in these fields to complete the window:

- **New Job Number**
  
  The NJDOT UPC or DP number. This field defaults to the existing job estimate number; however, since CES requires that all job numbers be unique, it should be overwritten. If you are creating multiple estimate scenarios for the same project, use the naming convention of “NJDOT UPC # + ALT1” for the first estimate scenario, “NJDOT UPC# + ALT2” for the second estimate scenario and so on, e.g. 048061ALT1, 048061ALT2, etc.

  As a time-saving resource, users may wish to create template jobs from which to copy or import information. In this case, name the job ’TEMPLXXXX##,’ where ‘XXXX’ is the code for your consulting firm, as used in the ’CONSULTANT Firm’ field on Page 2, and ‘##’ is a unique identifying number. (NJDOT users creating a template should use the code for their name in the “Reviewed by” field on Page 1 for ’XXXX.’)

  Observing this naming convention will make the job recognizable as a template by NJDOT reviewers and System Managers.

- **New Job Description**

  The description for the new job. Changing the information listed in this field is optional.

Click the **OK** button to confirm your entries, or click **CANCEL** to cancel the action.
If you click OK, CES will list the new job just created in the Jobs list window. This job will contain all the original job’s header and cost group information with the exception of the job number and possibly the job description.

To add or edit the information for the new job, select the job in the Jobs list window and choose Change from the Edit or right mouse button menu. The Job tabbed folder window will display in a mode in which to change the information shown. Complete the tabs in this window to create the job estimate. For more information about completing the tabs, see Chapter 4 – Adding Job Estimate Details for Long Range Estimates or Chapter 5 – Adding Job Estimate Details for Detailed Estimates.

**Copying All Job Information**

To add a job by copying all header, cost group, and item information from an existing job, begin by selecting the job from which to copy information while in the Jobs list window. Next, select Copy Special from the Edit menu, and then choose All. A Copy Job Information window displays.

![Copy Job Information Window](Figure 3-6. Copy Job Information Window)

Enter information in these fields to complete the window:

- **New Job Number**
  - The NJDOT UPC or DP number. This field defaults to the existing job estimate number; however since CES requires that all job numbers be unique it should be overwritten. If you are creating multiple estimate scenarios for the same project, use the naming convention of “NJDOT UPC # + ALT1” for the first estimate scenario, “NJDOT UPC# + ALT2” for the second estimate scenario and so on, e.g. 048061A, 048061B, etc.

  As a time-saving resource, users may wish to create template jobs from which to copy or import information. In this case, name the job ‘TEMPLXXXX##,’ where ‘XXXX’ is the code for your consulting firm, as used in the ‘CONSULTANT Firm’ field on Page 2, and ‘##’ is a unique identifying number. (NJDOT users creating a template should use the code for their name in the “Reviewed by” field on Page 1 for ‘XXXX.’)
Creating a New Job Estimate
AASHTOWare Project Cost Estimation System (CES) Manual

Observing this naming convention will make the job recognizable as a template by NJDOT reviewers and System Managers.

**New Job Description** The description for the new job. Changing the information listed in this field is optional.

Click the OK button to confirm your entries, or click CANCEL to cancel the action.

If you click OK, CES will list the new job just created in the Jobs list window. This job will contain all the original job’s tabbed folder information with the exception of the job number and possibly the job description.

To add or edit the information for the new job, select the job in the Jobs list window and choose **Change** from the **Edit** or right mouse button menu. The Job tabbed folder window will display in a mode in which to change the information shown. For more information about completing the tabs, see Chapter 4 – Adding Job Estimate Details for Long Range Estimates or Chapter 5 – Adding Job Estimate Details for Detailed Estimates.

Make sure you save your work frequently by selecting **Save** from the **File** menu or the Button Bar. You can only save your work after required information is entered.
4. Building a Long-Range (Preliminary) Estimate

Once the initial job header information has been entered, additional details are needed to create the long-range cost estimate. This chapter describes how to create a long-range estimate by adding cost group information to the job.

4.1 Long-Range (Preliminary) Estimation Methodology

Long-range or preliminary estimates are developed at the planning stage of a project when specific construction details have yet to be determined. Only limited information (e.g. the type of work, location, or number of lanes) is available to form the basis of the estimate. Long-range estimation is also referred to as parametric estimation. For example, a long-range estimate might be based simply on the average cost per lane mile for a given type of work in the northern region of the state.

Highway construction jobs employing similar work (e.g. resurfacing) share common major cost drivers or cost groups. If we know the general makeup or profile of the job in terms of major cost groups, we can use this information to develop a preliminary estimate. For example, if we know from past experience that 70 percent of the total cost of a typical resurfacing job is for asphalt, milling, and pavement marking, we can create an initial estimate for a resurfacing job based on the estimated cost for the asphalt, milling, and pavement marking components, plus another 30 percent for other as yet unspecified work, provided we can develop a reasonable estimate for the asphalt, milling, and pavement marking cost groups. Thus, by estimating the major cost groups of the job, we can derive a better long-range estimate.

In CES, the long-range estimate is the sum of the estimated costs for the active cost groups included in the job. Later, item level information can be added to the job to replace the cost groups and begin developing the detailed estimate.

4.2 Cost Groups

Standard cost groups utilizing different pricing methodology have been defined for use in CES and added to the Cost Group List.

Cost groups using bid-based pricing have been developed for NJDOT by grouping appropriate line items. Each item is assigned a conversion factor to translate its unit quantity to a common unit of measure for the cost group.

Because the cost groups are based on items, NJDOT’s historical bid data can be used to determine historical quantities and costs for the cost groups. CES uses this historical data to calculate bid-based prices for the cost group quantities that you enter in a job estimate. Cost Group Bid History Library data will be updated regularly by NJDOT.

Cost groups using percentages are available in the Cost Group List for item groups such as mobilization (MOBL) and training (TRAN), for which direct bid-based pricing would not be appropriate. Another percentage-based cost group is Constructability Factors (CONS), which suggests factors (variables) that may affect the cost of the job, and requires users to fill in percentages as needed.

User-defined or generic cost groups have been set up to allow users to apply their own prices, formulas, or percentages, by entering quantity and price and/or adding variables to the cost group after adding it to the job estimate. There is a user-defined cost group, for each type of calculation rule: normal (UNOR), percent of (UPTO), and percent on top (UPTT) (see Section 4.2.1).
A list of the standard cost groups in the NJDOT CES Cost Group List is attached in Section 4.11.

4.2.1 Calculation Rules

Cost groups in CES can be divided into three types, *normal* (NORM), *percent on top* (PCTT), and *percent of* (PCTO), based on their *Calculation Rule*. The calculation rule specifies how the extended amount for a given cost group is determined.

For a *normal* cost group, the extended amount is the quantity entered for the cost group multiplied by the unit price. The unit price can be derived from historical bid data (by referencing a cost group bid history library), entered directly, or calculated using a user-defined formula or expression.

For a *percent on top* cost group, the extended amount is calculated as a percentage of the total cost of all the active *normal* cost groups in the job. You enter the percentage in the unit price field and the quantity is automatically set to 1 percent of the sum of the extended amounts for all active normal cost groups, giving an extended amount equal to a percentage of the total cost for all the active normal cost groups in the job. Thus, the cost for a *percent on top* cost group is an additional percentage on top of the total cost for the active normal cost groups. Note, you can have multiple percent on top cost groups in a job. If so, the cost for each percent on top cost group is a specified percentage of the total estimated cost for all the active normal cost groups.

For a *percent of* cost group, the extended amount is calculated as a percentage of the total cost of the job, taking into account all the active cost groups including all *normal*, all *percent on top* and all *percent of* cost groups in the job. You enter the percentage in the unit price field and the quantity is automatically set to 1 percent of the total cost for the job (i.e. the sum of the extended amounts for all active cost groups including this percent of cost group), giving an extended amount equal to a percentage of the total cost for all the active cost groups in the job. Thus, the cost for a percent of cost group is a percentage of the total cost of the job. Note, you can have multiple percent of cost groups in a job. If so, the cost for each percent of cost group is a specified percentage of the total estimated cost for the job.

There is also a selection in CES for calculation rule *Lane Miles (LANE)*, which should not be used at this time. This option may be available in the future, as Lane Mile data is populated in the system.

A list of the standard cost groups in the NJDOT CES Cost Group List follows.

<table>
<thead>
<tr>
<th>Cost Group ID</th>
<th>Cost Group Description</th>
<th>Unit of Measure</th>
<th>Calculation Rule</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASPH1</td>
<td>Asphalt items</td>
<td>T</td>
<td>NORM</td>
</tr>
<tr>
<td>ASPH2</td>
<td>Asphalt items</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>ASPH3</td>
<td>Asphalt items</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>ASPX1</td>
<td>Asphalt, other</td>
<td>SY</td>
<td>NORM</td>
</tr>
<tr>
<td>Cost Group ID</td>
<td>Cost Group Description</td>
<td>Unit of Measure</td>
<td>Calculation Rule</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------------------------------------------------------</td>
<td>-----------------</td>
<td>------------------</td>
</tr>
<tr>
<td>ASPX2</td>
<td>Asphalt, other</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>ASPX3</td>
<td>Asphalt, other</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>BASE1</td>
<td>Base, aggregate</td>
<td>CY</td>
<td>NORM</td>
</tr>
<tr>
<td>BASE2</td>
<td>Base, aggregate</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>BASE3</td>
<td>Base, aggregate</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>BRID1CY</td>
<td>Bridge, concrete (in CY)</td>
<td>CY</td>
<td>NORM</td>
</tr>
<tr>
<td>BRID1LB</td>
<td>Bridge, steel (in LB)</td>
<td>LB</td>
<td>NORM</td>
</tr>
<tr>
<td>BRID1LF</td>
<td>Bridge, concrete &amp; steel (in LF)</td>
<td>LF</td>
<td>NORM</td>
</tr>
<tr>
<td>BRID1SF</td>
<td>Bridge, sheeting/walls (in SF)</td>
<td>SF</td>
<td>NORM</td>
</tr>
<tr>
<td>BRID2</td>
<td>Bridge, incl concrete &amp; steel structures</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>BRID3</td>
<td>Bridge, incl concrete &amp; steel structures</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>BRPT1</td>
<td>Bridge painting</td>
<td>T</td>
<td>NORM</td>
</tr>
<tr>
<td>BRPT2</td>
<td>Bridge painting</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>BRPT3</td>
<td>Bridge painting</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>CLER1</td>
<td>Clearing &amp; prep site; bldg&amp; util removal</td>
<td>LS</td>
<td>NORM</td>
</tr>
<tr>
<td>CLER2</td>
<td>Clearing &amp; prep site; bldg&amp; util removal</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>CLER3</td>
<td>Clearing &amp; prep site; bldg&amp; util removal</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>CONC1</td>
<td>Concrete, paving (roadway, sidewalk, driveway)</td>
<td>CY</td>
<td>NORM</td>
</tr>
<tr>
<td>CONC2</td>
<td>Concrete, paving (roadway, sidewalk, driveway)</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>CONC3</td>
<td>Concrete, paving (roadway, sidewalk, driveway)</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>CONS3</td>
<td>Constructability factors – user-defined cost group</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>CURB1</td>
<td>Curbing</td>
<td>LF</td>
<td>NORM</td>
</tr>
<tr>
<td>Cost Group ID</td>
<td>Cost Group Description</td>
<td>Unit of Measure</td>
<td>Calculation Rule</td>
</tr>
<tr>
<td>---------------</td>
<td>----------------------------------------------------</td>
<td>-----------------</td>
<td>------------------</td>
</tr>
<tr>
<td>CURB2</td>
<td>Curbing</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>CURB3</td>
<td>Curbing</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>DRAN1CY</td>
<td>Drainage items, concrete (in CY)</td>
<td>CY</td>
<td>NORM</td>
</tr>
<tr>
<td>DRAN1LF</td>
<td>Drainage items (in LF)</td>
<td>LF</td>
<td>NORM</td>
</tr>
<tr>
<td>DRAN1U</td>
<td>Drainage items, inlets &amp; manholes (in U)</td>
<td>U</td>
<td>NORM</td>
</tr>
<tr>
<td>DRAN2</td>
<td>Drainage items</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>DRAN3</td>
<td>Drainage items</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>EART1</td>
<td>Earthwork items, excavation</td>
<td>CY</td>
<td>NORM</td>
</tr>
<tr>
<td>EART2</td>
<td>Earthwork items, excavation</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>EART3</td>
<td>Earthwork items, excavation</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>ELEC1LF</td>
<td>Electrical, conduit/service wire</td>
<td>LF</td>
<td>NORM</td>
</tr>
<tr>
<td>ELEC1U</td>
<td>Electrical, junction boxes/cabinets</td>
<td>U</td>
<td>NORM</td>
</tr>
<tr>
<td>ELEC2</td>
<td>Electrical items</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>ELEC3</td>
<td>Electrical items</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>EROC1</td>
<td>Erosion control</td>
<td>CY</td>
<td>NORM</td>
</tr>
<tr>
<td>EROC2</td>
<td>Erosion control</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>EROC3</td>
<td>Erosion control</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>ENVIR</td>
<td>Environmental</td>
<td>U</td>
<td>NORM</td>
</tr>
<tr>
<td>FENC1</td>
<td>Fences and gates</td>
<td>LF</td>
<td>NORM</td>
</tr>
<tr>
<td>FENC2</td>
<td>Fences and gates</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>FENC3</td>
<td>Fences and gates</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>GDRL1</td>
<td>Guardrail/Guiderail</td>
<td>LF</td>
<td>NORM</td>
</tr>
<tr>
<td>GDRL2</td>
<td>Guardrail/Guiderail</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>GDRL3</td>
<td>Guardrail/Guiderail</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>Cost Group ID</td>
<td>Cost Group Description</td>
<td>Unit of Measure</td>
<td>Calculation Rule</td>
</tr>
<tr>
<td>---------------</td>
<td>-------------------------------------------------------------</td>
<td>-----------------</td>
<td>------------------</td>
</tr>
<tr>
<td>GENR1</td>
<td>General, field office &amp; office equipment</td>
<td>U</td>
<td>NORM</td>
</tr>
<tr>
<td>GENR2</td>
<td>General, field office &amp; office equipment</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>GENR3</td>
<td>General, field office &amp; office equipment</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>ITS1</td>
<td>Intelligent transportation systems</td>
<td>U</td>
<td>NORM</td>
</tr>
<tr>
<td>ITS2</td>
<td>Intelligent transportation systems</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>ITS3</td>
<td>Intelligent transportation systems</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>LAND1</td>
<td>Landscape items (in SY)</td>
<td>SY</td>
<td>NORM</td>
</tr>
<tr>
<td>LAND1U</td>
<td>Landscape items (in U)</td>
<td>U</td>
<td>NORM</td>
</tr>
<tr>
<td>LAND2</td>
<td>Landscape items</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>LAND3</td>
<td>Landscape items</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>LTNG1</td>
<td>Lighting</td>
<td>U</td>
<td>NORM</td>
</tr>
<tr>
<td>LTNG2</td>
<td>Lighting</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>LTNG3</td>
<td>Lighting</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>MILL1</td>
<td>Milling and rumble strips</td>
<td>SY</td>
<td>NORM</td>
</tr>
<tr>
<td>MILL2</td>
<td>Milling and rumble strips</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>MILL3</td>
<td>Milling and rumble strips</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>MISC1</td>
<td>Miscellaneous, monuments</td>
<td>U</td>
<td>NORM</td>
</tr>
<tr>
<td>MISC2</td>
<td>Miscellaneous, monuments</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>MISC3</td>
<td>Miscellaneous, monuments</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>MNBR1</td>
<td>Bridge maint (bureau of maintenance)</td>
<td>MH</td>
<td>NORM</td>
</tr>
<tr>
<td>MNBR2</td>
<td>Bridge maint (bureau of maintenance)</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>MNBR3</td>
<td>Bridge maint (bureau of maintenance)</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>MNTC1</td>
<td>Maintenance of traffic, temporary</td>
<td>U</td>
<td>NORM</td>
</tr>
<tr>
<td>MNTC2</td>
<td>Maintenance of traffic, temporary</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>Cost Group ID</td>
<td>Cost Group Description</td>
<td>Unit of Measure</td>
<td>Calculation Rule</td>
</tr>
<tr>
<td>---------------</td>
<td>------------------------------------------------------------</td>
<td>-----------------</td>
<td>------------------</td>
</tr>
<tr>
<td>MNTC3</td>
<td>Maintenance of traffic, temporary</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>MOBL3</td>
<td>Mobilization</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>NOIS1</td>
<td>Noise abatement measures</td>
<td>SY</td>
<td>NORM</td>
</tr>
<tr>
<td>NOIS2</td>
<td>Noise abatement measures</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>NOIS3</td>
<td>Noise abatement measures</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>NONR1</td>
<td>Non-roadway, buildings, benches, bikeracks</td>
<td>U</td>
<td>NORM</td>
</tr>
<tr>
<td>NONR2</td>
<td>Non-roadway, buildings, benches, bikeracks</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>NONR3</td>
<td>Non-roadway, buildings, benches, bikeracks</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>OTHR1</td>
<td>Other - performance/payment bond, insurance</td>
<td>LS</td>
<td>NORM</td>
</tr>
<tr>
<td>OTHR2</td>
<td>Other, performance/payment bond, insurance</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>OTHR3</td>
<td>Other, performance/payment bond, insurance</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>PVMK1</td>
<td>Pavement marking, traffic stripes</td>
<td>LF</td>
<td>NORM</td>
</tr>
<tr>
<td>PVMK2</td>
<td>Pavement marking, traffic stripes</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>PVMK3</td>
<td>Pavement marking, traffic stripes</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>RMVA1</td>
<td>Removal of asphalt pavement</td>
<td>SY</td>
<td>NORM</td>
</tr>
<tr>
<td>RMVA2</td>
<td>Removal of asphalt pavement</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>RMVA3</td>
<td>Removal of asphalt pavement</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>RMVB1</td>
<td>Removal of bridge materials &amp; structures</td>
<td>LS</td>
<td>NORM</td>
</tr>
<tr>
<td>RMVB2</td>
<td>Removal of bridge materials &amp; structures</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>RMVB3</td>
<td>Removal of bridge materials &amp; structures</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>RMVC1</td>
<td>Removal of concrete pavement</td>
<td>SY</td>
<td>NORM</td>
</tr>
<tr>
<td>RMVC2</td>
<td>Removal of concrete pavement</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>Cost Group ID</td>
<td>Cost Group Description</td>
<td>Unit of Measure</td>
<td>Calculation Rule</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------------------------------------------</td>
<td>-----------------</td>
<td>------------------</td>
</tr>
<tr>
<td>RMVC3</td>
<td>Removal of concrete pavement</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>SCHD1</td>
<td>Project schedule</td>
<td>LS</td>
<td>NORM</td>
</tr>
<tr>
<td>SCHD2</td>
<td>Project schedule</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>SCHD3</td>
<td>Project schedule</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>SURV1</td>
<td>Survey and stakeout</td>
<td>LS</td>
<td>NORM</td>
</tr>
<tr>
<td>SURV2</td>
<td>Survey and stakeout</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>SURV3</td>
<td>Survey and stakeout</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>TRAN1</td>
<td>Trainees</td>
<td>LS</td>
<td>NORM</td>
</tr>
<tr>
<td>TRAN2</td>
<td>Trainees</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>TRAN3</td>
<td>Trainees</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>TRFP1</td>
<td>Traffic control &amp; signs, permanent</td>
<td>U</td>
<td>NORM</td>
</tr>
<tr>
<td>TRFP2</td>
<td>Traffic control &amp; signs, permanent</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>TRFP3</td>
<td>Traffic control &amp; signs, permanent</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>UTIL1</td>
<td>Utility items</td>
<td>LF</td>
<td>NORM</td>
</tr>
<tr>
<td>UTIL2</td>
<td>Utility items</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>UTIL3</td>
<td>Utility items</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
<tr>
<td>UDEF1</td>
<td>User-defined cost group – Normal calculation rule</td>
<td>U</td>
<td>NORM</td>
</tr>
<tr>
<td>UDEF2</td>
<td>User-defined cost group – Percent on Top</td>
<td>PCT</td>
<td>PCTT</td>
</tr>
<tr>
<td>UDEF3</td>
<td>User-defined cost group – Percent of calculation</td>
<td>PCT</td>
<td>PCTO</td>
</tr>
</tbody>
</table>

### 4.2.2 Example

The following example illustrates the application of cost group calculation rules in CES. The sample job contains a normal cost group for asphalt (ASPH), with a quantity of 18,509 and a unit price of $44.62, giving an extended amount of $825,871.58.

The milling cost group (MILP) is a percent on top cost group, at 10 percent. The 10 percent is entered in the unit price field and CES automatically sets the quantity to 1.
percent of the total cost for the *normal* cost groups. Thus, the extended amount for milling is still equal to the quantity ($8,258.716) multiplied by the price (10.00), giving $82,587.16, which is 10 percent of the total cost for the *normal* cost groups.

The mobilization cost group (MOBL) and the constructability factors cost group (CONS) are both *percent of cost groups*, at 5 percent and 3 percent each respectively, and together they make up 8 percent of the total cost for all active cost groups. This means that the non-*percent of cost groups* (ASPH, MILP and TRAN) correspond to the remaining 92 percent of the total cost, which is equal to $916,717.46.

Therefore, the total cost for the job is $996,432.02, i.e. ($916,717.46 x 100)/92, and 1 percent of the total cost is equal to $9,964.32. For the MOBL and CONS cost groups, the assigned percent is entered in the unit price field and CES automatically sets the quantity to 1 percent of the total cost for all active cost groups. Thus, the extended amount for mobilization is still equal to the quantity ($9,964.32) multiplied by the price (5.00), giving $49,821.60, which is 5 percent of the total cost for all the cost groups. Similarly, the extended amount for the constructability factors cost group is 3 percent of the total cost for all the cost groups.

![Figure 4-1. COST GROUPS Tab Showing Cost Calculations](image)

Note, you can enter cost groups in any order, regardless of cost group type. As you add cost groups, the quantities and extended amounts for *percent on top* and *percent of cost groups* will be automatically recalculated.

### 4.3 Select a Job for Long-Range (Preliminary) Estimation

When creating the long-range estimate, the existing job estimate record in CES should be used as the starting point. In most cases, the job record will have been entered by
the NJDOT lead engineer assigned to the project before it is assigned to a consulting firm for estimation.

Projects in the early stages of planning and development may have several alternatives. Each alternative will have its own job estimate record, which is named using the UPC# with an alternate identifier appended; for example: 048061ALT1, 048061ALT2, etc. Later, when the decision is made on which alternative to use, you can make a copy of that Job (Edit menu | Copy Special | All), assigning the UPC number alone as the Job/Project number; for example, 048061.

Begin by selecting the desired alternative from the Jobs list window. To access the Jobs list window, click the JOBS button on the toolbar, or select Open Job List from the File menu. The Jobs list window will display.

![Figure 4-2. Jobs List Window](image)

This window lists all the existing jobs in CES that match your user ID’s control group (i.e. security access), and through it you can change, delete, and view those jobs as well as add new ones. You can also view and create new job snapshots from the Jobs list window.

If the desired job is not shown on the Jobs list window, refer to Chapter 3 – Creating a New Job Estimate for information on how to create a new job record or on how to copy an existing job to a new job using the Copy Special option. To share a job estimate when more than one consulting firm is involved in its creation, refer to Appendix A: Procedures for Sub-Contracting an Estimate for details.

Select the desired job and then choose Change from the Edit or right mouse button menu. CES displays Page 1 of the GENERAL tab of the Job tabbed folder window.
Each field label in *italics* is a required field and must have data entered. NJDOT also requires data to be entered in certain other fields. Formulas can be used in numeric fields that have teal-colored labels.

To insert a formula into a formula-enabled field, either double-click in the field or select Formula and Expression Builder from the right mouse button menu to display the Formula and Expression Builder Window. To use the Formula and Expression Builder, locate and select a formula that you have already created or build a new formula. Click VALIDATE to confirm that the formula is a valid expression. Click OK to insert the formula, and CES evaluates the formula to derive a value for the field. Refer to *Chapter 11 – Formula and Formula Libraries* for further information on how to create and use formulas.

Some fields will already be populated. Enter or change information for any of the fields outlined in the table below, as needed. For example, you may need to enter or update the data in the Metrics fields.

<table>
<thead>
<tr>
<th>Change Job - Page 1</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>UPC/DP#</strong></td>
</tr>
<tr>
<td><strong>Spec Year</strong></td>
</tr>
<tr>
<td><strong>Unit System</strong></td>
</tr>
</tbody>
</table>
selecting the down arrow beside the field to display a drop-down list from which to select a unit system.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Project Name</strong></td>
<td>The name of the project.</td>
</tr>
<tr>
<td><strong>Route</strong></td>
<td>The primary route of the project.</td>
</tr>
<tr>
<td><strong>Description 1</strong></td>
<td>The primary description for the job. This should be a complete description, not a continuation of the Project Name.</td>
</tr>
<tr>
<td><strong>Description 2</strong></td>
<td>The primary description for the job. This should be a complete description, not a continuation of the Project Name.</td>
</tr>
<tr>
<td><strong>Classifications</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Work Type</strong></td>
<td>The primary type of work being performed for the job. A complete list of Work Types with descriptions may be found on pages 3-2 thru 3-4 of this guide. The work type code may be populated by selecting the down arrow beside the field to display a drop-down list from which to select a work type.</td>
</tr>
<tr>
<td><strong>Highway Type</strong></td>
<td>The primary type of highway for the job. Enter the highway code by selecting the down arrow beside the field to display a drop-down list from which to select a highway type. A complete description of each Highway Type may be found on page 3-5 of this guide.</td>
</tr>
<tr>
<td><strong>Job Type</strong></td>
<td>The type of job being estimated. Enter the job type code by selecting the down arrow beside the field to display a drop-down list from which to select a job type. A complete description of each job type may be found on pages 1-2 thru 1-5 of this guide.</td>
</tr>
<tr>
<td><strong>Location</strong></td>
<td></td>
</tr>
<tr>
<td><strong>County</strong></td>
<td>The county in which the <strong>majority</strong> of job work will be performed. Enter a county code by selecting the down arrow beside the field to display a drop-down list from which to select a county. Entering a primary county also fills in the District field, which is the region where the work will be performed. For Operations jobs that are region-wide the county of the regional office should be designated (i.e. Morris for North, Monmouth for Central and Camden for South). For jobs that are statewide, use Mercer county.</td>
</tr>
<tr>
<td><strong>Urban/Rural</strong></td>
<td>The primary type of worksite for the job. Enter the urban/rural code by selecting the down arrow beside the field to display a drop-down list from which to select an urban/rural code.</td>
</tr>
</tbody>
</table>
**District**
The New Jersey regional office in charge of the job. This field is automatically filled in when you enter a county code. Alternatively, enter a district code by selecting the down arrow beside the field to display a drop-down list showing the District Offices window from which to select a district office. For Statewide jobs, use the code for Headquarters.

**Begin Termini**
The termini at which the job begins (milepost).

**End Termini**
The termini at which the job ends (milepost).

### Metrics

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Depth (in/mm)</strong></td>
<td>The depth of the job being estimated. The value entered must be numeric. This is a formula-enabled field.</td>
</tr>
<tr>
<td><strong>Length (Mi/km)</strong></td>
<td>The length of the job being estimated. The value entered must be numeric. This is a formula-enabled field.</td>
</tr>
<tr>
<td><strong>Width (ft/m)</strong></td>
<td>The width of the job being estimated. The value entered must be numeric. This is a formula-enabled field.</td>
</tr>
<tr>
<td><strong>Lane (Mi/km)</strong></td>
<td>The total number of lane miles or kilometers involved in the job being estimated. This is a formula-enabled field. This field is required unless not relevant to the type of work being performed.</td>
</tr>
<tr>
<td></td>
<td>The metrics are not necessarily exact numbers but rather averages to be used for conceptual areas.</td>
</tr>
</tbody>
</table>

### Inflation

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Inflation (%)</strong></td>
<td>The anticipated percentage of inflation per year until work begins on the job. If this number is not known use the model inflation for bid-based inflation. If using model inflation, set this to zero. This is a formula-enabled field.</td>
</tr>
<tr>
<td><strong>Years Until Work</strong></td>
<td>The total number of years prior to the start of the project. This number is used with the Inflation % to annually inflate the total job estimate, before applying the contingency percent. This is a formula-enabled field.</td>
</tr>
<tr>
<td><strong>Base Date</strong></td>
<td>The date from which inflation is calculated for bid-based items, item tasks, or cost groups assessed using regression analysis. The entry should be the date construction is expected to start. This field defaults to the current date.</td>
</tr>
</tbody>
</table>

### Bid Histories

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Cost Group History</strong></td>
<td>The cost group library from which CES will draw when calculating bid-based prices for normal cost groups.</td>
</tr>
</tbody>
</table>
Enter a library name by selecting the down arrow beside the field to display the Cost Group Bid History Libraries window and select a cost group library. Used for long-range bid-based estimation only. This field is not required for the detailed estimate.

**Item History**

The item library from which CES will draw when calculating bid-based prices for items. Enter a library name by selecting the down arrow beside the field to display the Item Bid History Libraries window and select an item library. Used for detailed bid-based estimation only. *This field is not required for long-range estimation.*

**Bid-based Inflation**

The method of inflation calculation CES uses when determining the costs for bid-based items or cost groups assessed using regression analysis: model inflation or job inflation. Select **USE MODEL** if you want CES to use the inflation rate determined by the bid history model. Select **USE JOB** if you want to use the job inflation percentage assigned via the Inflation % field.

**Season**

The season in which the majority of job work will be performed. NJDOT jobs should use the value ‘ALL’ to indicate all seasons. The field value should already default to ‘ALL.’ If not, the value may be changed by selecting the down arrow beside the field to display a drop-down list from which to select it.

**Other Fields**

**Date Created**

The date the estimate was created. This field should not be changed.

**Last Updated**

The date the estimate was last updated. This field automatically displays the date that information for the job was last updated.

**Conceptual Estimate**

The speculated total cost for the job. Enter an amount in this field or double click in the field to use a formula that derives an amount.

**Contingency Percent**

The percentage of the job cost being set aside to cover expenses for unforeseen occurrences. This is a formula-enabled field.

Proceed to Page 2 of the GENERAL tab by clicking the PAGE 2 radio button in the upper left portion of the tab.
The majority of fields on this page are not currently being used by NJDOT. However, the following fields are required to be populated for long-range estimation:

**Change Job - Page 2**

**Latitude**  
The project’s midpoint latitude, entered in the form of degrees, minutes, and seconds (DDMMSS). This midpoint must fall within the county that is specified on Page 1.

**Longitude**  
The project’s midpoint longitude, entered in the form of degrees, minutes, and seconds (DDDMMSS). This midpoint must fall within the county that is specified on Page 1.

**Control Group**  
The access control value for the job estimate. This is a required field used for security purposes. Each user is assigned to a control group and can only access job estimates with matching control group values. The value defaults to the control group assigned to the user. Changing the control group value is used to pass responsibility for the job estimate to a user in a different control group.

**CONSULTANT Firm**  
The code for the name of the firm responsible for producing the long-range estimate. Enter the name by selecting the drop down menu to display the list of firms from which to select a name.

**CONSULTANT Consultant/PM**  
The individual who is responsible for producing the long range estimate once it is assigned. Enter the full name.
As always, save your work frequently! To do so, click the SAVE icon on the toolbar or select Save from the File menu. You can only save your work after required information is entered.

4.4 Adding and Changing Cost Group Information

To produce a long-range estimate, CES requires cost group information. You can add or change cost group information on the COST GROUPS tab of the Job tabbed folder window.

![Figure 4-5. Job Tabbed Folder Window-COST GROUPS Tab](image)

There are two data entry options for the COST GROUPS tab. You can enter information via the cost groups grid (as shown in Figure 4-5) or the cost groups detail area. CES defaults to the grid, but you can access the detail view by selecting Hide/Show Detail from the View menu. A detail area appears in the lower half of the COST GROUPS tab.
The detail area also includes an area in which you can enter variables for the cost group. For example, a cost group variable could be used in a formula to calculate the quantity for the cost group.

If there are no cost groups on the tab, your first step will always be to select Add from the Edit menu or to press SHIFT+INSERT. In the cost groups grid, CES adds a blank row ready to be filled with information about the cost group that you are defining. For each additional cost group added, you will also need to insert a blank row; otherwise, CES will overwrite the information in the currently selected cost group row.

To change an existing cost group, select the desired cost group and alter the fields in the cost group row as necessary.

The detail area of the COST GROUPS tab contains data entry fields that correspond with the columns available in the cost groups grid, and any variables associated with the selected cost group.

When the detail area is visible on the COST GROUPS tab (shown on the bottom left of the screen of Figure 4-6), you must use that area to add or change information. Although you are able to move from row to row within the grid portion of the tab, you will not be able to type information directly into the grid. To add or change information using the cost groups grid, you must switch back to the default grid view (Figure 4-5) by selecting Hide/Show Detail from the View menu.

As you enter cost group information in the detail area, the corresponding data entry row in the cost groups grid is filled in.

These are the fields that can be edited on the COST GROUPS tab:
| **Cost Group ID** | The identifier for the selected cost group. Click the down arrow found either in the lower left portion of the grid area or beside the Cost Group ID field in the detail area to display the Cost Groups window from which to select a cost group. |
| **Description** | A short description of the cost group. This field is automatically filled in when you select a cost group. Do not change this description. |
| **Quantity** | For *normal* cost groups, the total number of units of the cost group. Enter a number in this field, type in a formula name, or double-click in the field to insert a formula that derives the number. For information about using formulas, refer to *Chapter 11 – Formulas and Formula Libraries*.  
For *percent* cost groups, this field is automatically filled in with a cost amount when you enter a percent value in the price field. |
| **Price** | For *normal* cost groups, the price assigned to each unit of the cost group. You have several options for completing this field: you can choose to have CES automatically compute a price based on historical data (see Section 4.4.2), you can enter a price directly, you can type in a formula name, or you can double-click in the field to insert a formula that derives the amount.  
For information about using formulas, refer to *Chapter 11 – Formulas and Formula Libraries*.  
For *percent* cost groups, the percent value assigned to the cost group. You can enter a percent directly, you can type in a formula name, or you can double-click in the field to insert a formula that derives the percent value. |
| **Bid-based Comment** | A comment field that contains a comment generated by the system when using the automatically computed price based on historical data (see Section 4.4.2). |
However, this field is editable and can be used to store any textual information.

**Active**
Select this check box if the cost group is to be included in the cost calculations for the job. To exclude a cost group from the job estimate, deselect this check box. This allows you to retain cost group definitions in the job even though they are not included in the cost estimate for the job.

**Bid-based Library**
The cost group bid history library that CES uses to arrive at the bid-based price for normal cost groups. When this field is blank, CES uses the library specified in the Cost Group History field on the GENERAL tab. If there is another library from which the bid-based price should be drawn, enter that library’s name in this field or click the down arrow beside the field to display the Cost Group Bid History Libraries list window from which to select a library.

Click **SAVE** or select **Save** from the **File** menu to save your work.

As you enter quantities and prices for your cost groups, the extended amounts are automatically calculated and totaled. The total reflects only the cost for active cost groups. If you entered an Inflation % on the GENERAL tab of the Job tabbed folder window, the total extended amount displayed on the COST GROUPS tab may be greater than the sum of the individual cost group extended amounts. The difference is the inflation amount that was calculated for the job.

The Estimate and Total fields on the GENERAL tab of the Job tabbed folder window are also automatically updated to reflect the total cost for the active cost groups.

### 4.4.1 Using Variables in Your Cost Group

You can add variables to your cost group using the Cost Group Variables section of the detail window. These variables can then be used in formulas to calculate the quantity or price for your cost group. For information about using formulas, refer to Chapter 11 – Formulas and Formula Libraries.

Variables defined at the cost group level can only be used with that specific cost group. However, variables defined at the job level can be used with multiple cost groups. Refer to Chapter 5, Section 5.2 for information on how to define job variables.

To add a variable to your cost group, select the cost group and show the detail area. Select **Variables** from the **Edit** menu, and choose **Add**. CES displays a window that allows you to select whether your variable type is a number (N) or a string (S), and to name your variable.

![Add Variable Window](image_url)  
*Figure 4-7. Add Variable Window*
Choose the variable type and name the variable. Click OK. CES adds the variable to the cost group. If you select the variable type N, then CES allows you to edit the Value field for the variable, but not the String field. If you select the variable type S, then CES allows you to edit the String field, but not the Value field.

These fields can be edited for a cost group variable:

**Value**
Enter a value for the variable or double click in the field to display the Formula and Expression Builder window in which you can build a formula for the value. You can only edit this field if the variable type is N.

**String**
Enter a string for the variable. You can only edit this field if the variable type is S.

**Description**
A brief description of the variable.

To change an existing variable, select that variable in the cost group detail area and alter the fields in the variable row as necessary.

Any new or changed variable will not be available for use in the cost group until you save your work. Click SAVE or select Save from the File menu to save your work.

### 4.4.2 Computing Price for Quantity

For _normal_ cost groups, if you know a cost group’s quantity, you can choose to have CES compute a price for that cost group based on historical data. To perform the necessary
calculations, CES draws on the library designated in the Cost Group History field found on the GENERAL tab of the Job tabbed folder window. However, if the Bid-based Library field is filled in on the COST GROUPS tab, then that library is used.

To have CES automatically price a cost group, while in the COST GROUPS tab select the cost group (or multiple cost groups) to be priced, and choose Compute Price for Quantity from the Edit menu. To select more than one row at a time, hold down the CTRL key while selecting the rows. CES uses the job header information (work type, county, season, highway type, date) and the quantity you specify for the cost group to calculate or look up a price in the specified bid history library and fills in the Price and Extended Amount fields for each selected cost group. The price could be the result of a regression or average model and could have inflation calculated, depending on the values you entered in the job header fields. For each selected cost group that is active, the newly calculated extended amount is then included in the overall job estimate.

If there is a problem determining the bid-based price, the Bid-based Comment field is filled in with the appropriate information necessary to identify the problem. For example, the message in the Comment field can indicate that the selected cost group is not listed in the specified bid history library. One option would be to choose another library in which to search for price information.

If there is still insufficient bid-based information for CES to produce an estimate for the chosen cost group, you might want to consider other estimation options for this cost group, such as entering a price directly. If you enter the price directly, do not apply Compute Price for Quantity on this cost group or your price will be overwritten.

Click SAVE or select Save from the File menu to save your work.

4.4.3 View Bid-Based Information

When CES uses regression analysis to price a cost group, you can access a graphical view of the regression information by highlighting the cost group and choosing Bid-based Information from the View menu. CES displays a Bid History Analysis window with the REGRESSIONS tab displayed.
You can interactively display the exact price and quantity amounts for the entire regression. To do this, place your cursor in the regression area of the graphic, and then press and hold down the left mouse button while moving your cursor back and forth in the area. As you move your cursor, the information in the Price and Quantity fields to the right of the curve automatically adjusts to display the amounts that correspond to the location of your cursor in the regression curve.

Use the horizontal scroll bar at the bottom of the window to view specific information about the regression. Click PRINT to print the regression information, click the AVERAGES tab to view the averages information, or click OK or CANCEL to exit the graphic window.

If you have adjusted the Price and Quantity fields by clicking on the regression curve and you click OK to exit, the price of your cost group will be set to the adjusted price. The quantity for the cost group is not changed, but a comment with the adjusted quantity is added in the Bid-based Comment field to indicate that the cost group price is now based on a different quantity. To retain the original price for your cost group, be sure to click CANCEL to exit the graphic window.

The averages information for a cost group displays on the AVERAGES tab of the Bid History Analysis Window. Even if CES does not have the information necessary to perform a regression analysis for a cost group, it still attempts to produce a price for that cost group based on averages.
Similar to the REGRESSIONS tab, you can interactively display the exact price and quantity amounts for the averages graphic chart by pressing and holding down the left mouse button while moving your cursor back and forth in the graphic area. As you move your cursor, the information in the Price and Quantity fields to the right of the graphic automatically adjusts to display the amounts that correspond to the location of your cursor in the averages chart.

Use the horizontal scroll bar at the bottom of the window to view specific averages information. Click PRINT to print the averages information or click OK or CANCEL to exit the graphic window.

If you have adjusted the Price and Quantity fields by clicking on the averages chart and you click OK to exit, the price of your cost group will be set to the adjusted price. The quantity for the cost group is not changed, but a comment with the adjusted quantity is added in the Bid-based Comment field to indicate that the cost group price is now based on a different quantity. To retain the original price for your cost group, be sure to click CANCEL to exit the graphic window.

4.4.4 Recalculate Cost Groups

The Cost Group Bid History Libraries in CES will be routinely updated (e.g. quarterly) to include bid data for recent NJDOT contracts. CES allows you to quickly recalculate bid-based prices for the cost groups in a job using the updated libraries.

To have CES automatically recalculate prices for a cost group, while in the COST GROUPS tab select the cost group (or multiple cost groups) to be recalculated, and choose Compute Price for Quantity from the Edit menu. To select more than one row at a time, hold down the CTRL key while selecting the rows. CES will update the Price and Extended Amount fields for each selected cost group using the updated bid history.
information. For each selected cost group that is active, the newly calculated extended amount is then included in the overall job estimate.

Click SAVE or select Save from the File menu to save your work.

### 4.5 Deleting Cost Groups

To delete cost groups from the COST GROUPS tab of the Job tabbed folder window, begin by selecting the row or rows of cost group information to delete. To choose more than one row at a time, hold down the CTRL key while selecting the rows. To delete several rows that are adjacent to each other, select the first row, then hold down the SHIFT key as you select the last row. All the rows to be deleted are highlighted.

Once you have chosen the row(s) to delete, select Delete from the Edit menu or press SHIFT+DELETE. As shown in Figure 4-11, CES displays a Delete Rows window.

![Delete Rows Window](image)

Click YES to confirm the deletion, or NO to cancel the action. If you selected more than one row to delete, an additional Delete Rows window displays to give you an extra opportunity to cancel the process. Click YES to complete the deletion.

Click SAVE or select Save from the File menu to save your work.

### 4.6 Attachments

CES provides functionality for adding attachments to the estimate. All estimate-related documentation should be attached to the estimate in CES.

Per NJDOT policy, the consultant preparing the long-range estimate is required to attach the following estimate-related documentation, where applicable:

- Preliminary Plans
- Transmittal Letter with a date for completion review
- Estimation Checklist (Section 4.10)
- Utility Estimation Checklist

Refer to *Chapter 7 – Attachments* for specific information on how to add attachments to a job estimate in CES.

### 4.7 Snapshots

A snapshot is a complete picture of an estimate job at a given time. It is like freezing the information in an estimate job and keeping it available for use, even if the information in that job later changes. The snapshot process should be used for maintaining an audit trail of an estimate and not as a replacement for saving the job.

Reasons for creating a snapshot of the project for Long-Range Estimation include: change of scope, recalculation of bid-based pricing due to Bid History update, annual
review, turnover to Estimator, turnover to consultant from Estimator, before inactivating cost group pricing to prepare for detailed estimation.

Refer to Chapter 8 – Snapshots for specific information on how to create snapshots of a job estimate in CES.

4.8 Adding and Changing Program Associations

A program is a group of connected jobs. For example, the different alternatives for a given project could be grouped into a program.

In the Job tabbed folder window, you can associate the current job with one or more programs via the PROGRAMS tab.

![Figure 4-12. Add Job Tabbed Folder Window—PROGRAMS Tab](image)

The PROGRAMS tab is divided into two sections. The upper section lists the programs with which your job is associated. If your job is not associated with any programs, the top section will be empty (see Figure 4-12). The lower section of the tab is a master list of all the programs that are available for association.

Four options allow you to move the programs to and from the lower section of the tab. You can access these options via the Edit menu or the buttons near the center of the tab:

Add Selected (single up arrow)  Moves the selected programs from the lower portion of the tab to the upper portion, indicating those programs are now associated with the current job.

Add All (double up arrow)  Moves all the programs from the lower portion of the tab to the upper portion, indicating those programs are now associated with the current job.
Remove Selected (single down arrow) Moves the selected programs from the upper portion of the tab to the lower portion, indicating those programs are no longer associated with the current job.

Remove All (double down arrow) Moves all the programs from the upper portion of the tab to the lower portion, indicating those programs are no longer associated with the current job.

You can also associate or disassociate programs with the job by clicking and dragging the program to the desired location. Figure 4-13 shows an Add Job tabbed folder window with a program that is associated with the current job.

![Figure 4-13. PROGRAMS Tab With An Associated Program](image)

Click SAVE or select Save from the File menu to save your work.

### 4.9 Reports

CES provides several standard reports that can be used to list detailed information that has been entered. For example, the List Jobs process lists detailed information about the selected jobs, including header information, associated programs, and cost group details.

Refer to Chapter 9 – Generating Reports for specific information on how to generate reports in CES.

### 4.10 Long Range (Preliminary) Estimation Checklist

Prior to submitting a long range estimate, the estimator should verify that the following items were accounted for in the estimate. For any items marked “No” please provide a written explanation.
Table 4-2. NJDOT Estimation Checklist

<table>
<thead>
<tr>
<th>Items to be checked</th>
<th>YES</th>
<th>NO</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>1). Construction</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>a). Railroad coordination complete?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>b). Access issues resolved?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>c). Work hour / lane restrictions identified?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>d). Night work required?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>e). Full 8 hour work shifts to be utilized?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>f). Safety concerns addressed?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>g). Bonuses included?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>h). Liquidated Damages included?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>i). Permit/environmental approval conditions/restrictions</td>
<td></td>
<td></td>
</tr>
<tr>
<td>j). Staging / Storage area(s) identified?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>k). Site accessible to Contractor?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>l). Project Awarded at logical construction time of year?</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>2). Cost Estimate</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>a). Researched for labor intensive items with hidden costs?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>b). Environmental issues / costs researched?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>c). Archeological issues / costs researched?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>d). ROW researched, prices obtained?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>e). Utility cost estimate received from companies?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>f). Current Bid Prices used for estimate?</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>3). Plan Preparation</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>a). All features on plan verified with field trip?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>b). Utilities identified?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>c). Drainage report / plan prepared?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Items to be checked</td>
<td>YES</td>
<td>NO</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------------------</td>
<td>-----</td>
<td>----</td>
</tr>
<tr>
<td>d). Noise analysis performed?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>e). Typical section established?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>f). Geotechnical site conditions have been researched?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>g). Subsurface conditions verified?</td>
<td></td>
<td></td>
</tr>
<tr>
<td>h). Different retaining wall options / prices investigated?</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
5. Adding Job Estimate Details for Detailed (Final) Estimation

5.1 Adding Job Estimate Details for Detailed (Final) Estimation

When creating the detailed (final) estimate, the existing preliminary estimate in CES should be used as the starting point. This record may be modified by locating and selecting the estimate in the Job window and selecting **Change** from the right mouse button menu.

![Figure 5-1. Change Job Tabbed Folder Window—GENERAL Tab—Page 1](image)

Before beginning, it is important to ensure that the current estimate total on Page 1 of the GENERAL tab is zero ($0.00). If not, it will be necessary to mark all cost groups as inactive. This may be done in the COST GROUPS tab by selecting each cost group and using the right mouse button menu to select **Hide/Show Detail**. Once in the Detail View you can clear the Active box indicator as shown in Figure 5-2. This check box should be cleared for all cost group records before proceeding with the detailed estimate.
Figure 5-2. Cost Groups Tab – Detail View

After verifying the estimate total is zero, the necessary information to complete the estimate may be entered using the different tabs that are available in the Job tabbed folder window. Fields required by the system are in *italics*. Fields whose value can be calculated by a formula are in teal. Some fields will already be populated.

These fields that may be populated or updated on Page 1 of the GENERAL tab:

**Page 1**

**UPC/DP#**

The primary identifier for the estimate. For CPM jobs it is the UPC#. For Operations jobs it is the DP#. This field is not available for edit if you are changing the information for an existing job.

**Metrics:** *NJDOT* policy requires that all metric fields be populated for detailed estimation.

**Depth (in/mm)**

The depth of the job being estimated. The value entered must be numeric.

**Length (Mi/km)**

The length of the job being estimated. The value entered must be numeric.

**Width (ft/m)**

The width of the job being estimated. The value entered must be numeric.
Lane (Mi/km)  The total number of lane miles or kilometers involved in the job being estimated. This field is Required.

The metrics are not exact numbers but rather averages to be used for conceptual areas.

For detailed estimation, this field is required.

**Inflation: Update as necessary from previously entered figures.**

**Inflation (%)**  The anticipated percentage of inflation per year until work begins on the job. If this number is not known use the *model inflation* for bid-based inflation. If using *model inflation*, set this to zero. This is a formula-enabled field.

**Years Until Work**  The total number of years prior to the start of the project. This number is used with the Inflation % field to annually inflate the total job estimate, before applying the contingency percent. This is a formula-enabled field.

**Base Date**  The date from which inflation is calculated for bid-based items, item tasks, or cost groups assessed using regression analysis. The entry should be the date construction is expected to start. This field defaults to the current date.

**Cost Sheets: These fields are required if you do any cost-based estimation.**

**Davis-Bacon?**  Select this check box if the job is federally funded and has laborers who fall under the Davis-Bacon wage guidelines.

**Labor Cls:**  The rate classification code, used to determine which labor wages are brought in when labor is used in job item cost sheets. Enter the labor class by selecting the down arrow beside the field to display a drop-down list from which to select a labor class.

**Eqpmt Cls:**  The rate classification code, used to determine which equipment rates are brought in when equipment is used in job item cost sheets. Enter the equipment class code by selecting the down arrow beside the field to display a drop-down list from which to select an equipment class.

**Materials Cls:**  The materials classification code, used to determine which materials rates are brought in when materials are used in job item cost sheets. Enter the materials class by selecting the down arrow beside the field to display a drop-down list from which to select a materials class.

**Bid Histories**
**Cost Grp Hist:** This is for long range estimation only. Do not change it when doing the detailed estimate.

**Item History** Choose a bid history library from the drop down menu for item level bid history pricing. This field is required if you are doing bid-based item pricing.

**Bid-based inflation:** The method of inflation calculation CES uses when determining the costs for bid-based items or cost groups assessed using regression analysis: model inflation or job inflation. Select **USE MODEL** if you want CES to use the inflation rate determined by the bid history model Select **USE JOB** if you want to use the job inflation percentage assigned via the Inflation % field.

**Other Fields**

**Fed/State Project Num.** The federal/state project number assigned to the job. The value entered can be numeric, alphabetic, or alphanumeric. If this is a state job enter **STATE. THIS FIELD MUST BE FILLED IN!**

**C&E Percent** The amount of construction engineering work to be performed on the job expressed as a percentage of the total job amount. Unless it is referred to in a formula, this is not used in any calculations and so does not affect the total.

**Reviewed By** This field is to be used by NJDOT staff only for indicating the NJDOT estimator responsible for reviewing the estimate. The estimator reviewing the estimate may be specified by selecting the down arrow beside the field to display a drop-down list of values.

**Date Created** The date the estimate was created. This should not be changed.

**Last Updated** The date the estimate was last updated. When first entering a job, this field defaults to the current date. Once a job has been saved, this field automatically displays the date that information for the job was last updated.

**Conceptual Estimate** A formula enabled field that is the current evaluated value of the conceptual estimate expression. Unless it is referred to in a formula, this is not used in any calculations and so does not affect the total.

**Contingency Percent** The percentage of the job cost being set aside to cover the expenses for unforeseen occurrences. This field should default to 0.00. Typically this field is not filled in at this time but if the Designer sees the need, it may be populated.
Proceed to Page 2 of the GENERAL tab by clicking the PAGE 2 radio button in the upper left portion of the tab.

![Figure 5-3. Add Job Tabbed Folder Window-GENERAL Tab-Page 2](image)

The majority of fields on this page are not currently being used by NJDOT. However, the following fields are required to be populated:

**Page 2**

**Control Group**

Read this carefully before making changes! If the job estimate is being created by NJDOT staff, the appropriate control group associated with the consulting firm assigned to the estimate should be selected from the list of values.

If the job estimate is being created by a consultant, this field should already be populated with the correct value. Consultants should NOT change the default value unless passing the job to another consulting firm. Changing the default value will change the security for the job estimate and prevent you from accessing it the next time you log on to CES.

**CPM Firm**

Using the list of values in the drop down menu, populate this field with the name of the firm responsible for producing the detailed estimate.

**CPM Consultant**

The individual who is responsible for producing the detailed estimate, once it is assigned. Enter the full name.
As always save your work frequently! To do so click the SAVE icon on the toolbar or select Save from the File menu.

5.2 Adding Variables to a Job

The GENERAL tab of the Job Tabbed Folder window includes many different measurements for the job - for example, the depth and length of the job. However, there may be times when you will want to add a measurement that the job takes into account when the total of the job is estimated. The VARIABLES tab lets you enter that information.

You may find existing job variables that were created during the long range estimation phase. However, variables defined at the job level can be used throughout the job. For example, if the price of an item is affected by how long the project is in construction, you could create a numeric variable for number of months duration of work. You could create a formula in a reference price task of an item that uses the value you entered in that variable as a factor.

Variables are organized by groups and the variables that belong to each group. You may create as many groups as desired, but a variable can belong to only one group. A variable must belong to a group.

5.2.1 Adding Groups

If the VARIABLES tab is empty, your first step is to create a group.

Select Add from the Edit menu and choose Group. CES displays the VARIABLES tab with one group added.

You can also add a group to the VARIABLES tab by clicking in the grid area and pressing your right mouse button. Select Add from the right mouse button menu.

These fields can be edited for a group:

**Name**  
The designation that identifies the group. CES automatically enters a name for this field, but it can be edited. The name
must start with a letter and must not contain any spaces. The use of underscores is acceptable.

A name is assigned by highlighting the assigned name and typing the desired name over the existing text.

**Description**

A description of the variables contained in the group.

A description is assigned by highlighting the assigned description and typing the desired name over the existing text.

### 5.2.2 Adding Variables in a Group

Once you have a group created, you can add variables to that group. To add a variable to the group, highlight the group in the tree area. Select **Add** from the **Edit** menu and choose **Variable**. CES displays a window that allows you to select whether your variable type is a number (N) or a string (S), and to name your variable.

![Figure 5-5. Add Variable Window](image)

Choose the variable type and name the variable. Click **OK**. CES adds the variable to the group. If you select the variable type N, then CES allows you to edit the Value field for the variable, but not the String field. If you select the variable type S, then CES allows you to edit the String field, but not the Value field.

![Figure 5-6. Job Tabbed Folder Window-VARIABLE Tab with a Group and Variable](image)
These fields can be edited for a variable:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Description</strong></td>
<td>A description of the variable.</td>
</tr>
<tr>
<td><strong>Value</strong></td>
<td>The variable being defined. Enter a formula or double-click in the Value field to display the Formula and Expression Builder Window with which to build a formula (see Chapter 11 - Formulas and Formula Libraries for more information). This field is not available if the variable type is S.</td>
</tr>
<tr>
<td><strong>String</strong></td>
<td>The string being defined. Enter the string directly into the String field. This field is not available if the variable type is N. This field can be for information only, or the string can later be used as part of a formula.</td>
</tr>
</tbody>
</table>

To change an existing variable, select that variable and alter the fields in the variable row as necessary.

Any new or changed variable will not be usable in the CES job until you save your work. Click **Save** or select **Save** from the **File** menu.

### 5.3 Adding Categories

You can add category information on the **CATEGORIES** tab of the Job tabbed folder window. Categories in a job are groupings of items that allow job items to be related to each other for funding or other purposes.

![Figure 5-7. The CATEGORIES Tab](image)

The only fields that require information are the Category Number and Description fields. To add a new category, select **Add** from the **Edit** menu or press **SHIFT+INSERT** on the keyboard. CES displays a window for you to add the category number.
Enter a category number and click OK. CES adds a blank row ready to be filled with information about the category that you are defining. **Categories must be numbered consecutively, should be incremented by 1, and MUST use leading zeroes to create a four-digit number**. (e.g. 0001, 0002, 0003, etc.).

Enter the category number and press **TAB**. Enter a description for the category and either press **TAB** to fill in the remaining fields, or select **Save** from the **File** menu. If you prefer, you may enter data from the Category Detail window, by choosing **Hide/Show Detail** from the **View** menu or right-mouse button. For projects with more than one structure, a different category should be set up for each structure. Since the categories assigned on a job are specific only to that particular job this numbering will not carry over to other jobs.

These fields may be populated or edited for a Category:

**Category**

**Alternate Code**
Different categories can be alternates for each other, meaning that a bidder can choose to bid on either category, but not both. If you enter a number here, it indicates that this is an alternate category. NJDOT generally uses alternate items instead of alternate categories.

**Description**
For roadway items enter ROADWAY as the category description. For bridge items use BRIDGE as the category
description; or BRIDGE 1, BRIDGE 2, etc, for projects with multiple structures.

See below for categories in federally funded projects.

**Bridge ID**
- If this is a structures category, enter the Bridge ID number. This information is required for structures categories. **THIS IS A REQUIRED FIELD FOR PROJECTS WITH BRIDGES.**

**Bridge Length**
- If this is a structures category, enter the length of the bridge in this category, in feet. This is a formula-enabled field. **THIS IS A REQUIRED FIELD FOR PROJECTS WITH BRIDGES.**

**Bridge Width**
- If this is a structures category, enter the width of the bridge in this category, in feet. This is a formula-enabled field. **THIS IS A REQUIRED FIELD FOR PROJECTS WITH BRIDGES.**

**Num. of Spans**
- If this is a structures category, enter the number of spans in the bridge in this category. This is a formula-enabled field. **THIS IS A REQUIRED FIELD FOR PROJECTS WITH BRIDGES.**

**Bridge Type**
- If this is a structures category, click in the right side of the field to display a drop down list from which to select a Bridge Type code. **THIS IS A REQUIRED FIELD FOR PROJECTS WITH BRIDGES.**

### 5.3.1 Categories – NJDOT Policy

For Federal and State Projects, the following General Detail Categories should be used. Not all of the categories below may be required on every project; however, the order in which they are listed shall be followed. **Categories should be numbered sequentially.**

<table>
<thead>
<tr>
<th>Category</th>
<th>Category Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Roadway</strong></td>
<td>Category for roadway items not assigned in one of the other listed categories</td>
</tr>
</tbody>
</table>
| **Construction Engineering** | Curing & Storing Items  
Field Office Items  
Materials Lab Items  
Nuclear Density Gauge |
| Non-Participating (Roadway)          | Clean Existing Drainage Structure  
|                                   | Clean Existing Pipe                
|                                   | Railroad Protective Liability Insurance  
|                                   | Owner’s & Contractor’s Protective Liability Ins. Pollution Liability Insurance  
|                                   | Proprietary Items not approved by FHWA  
|                                   | Mowing                              
|                                   | Selective Trimming                  
|                                   | Selective Clearing                  
|                                   | Maintenance Items                   
| Erosion Control                  | Construction Driveway               
|                                   | Dewatering Basins                   
|                                   | Embankment, Temporary Erosion Control  
|                                   | Floating Turbidity Barrier          
|                                   | Geotextile                          
|                                   | Haybale Items                       
|                                   | Inlet Filters                       
|                                   | Inlet Sediment Traps                
|                                   | Roadway Excavation, Temporary Erosion Control  
|                                   | Silt Fence Items                    
|                                   | Temporary Riprap                    
|                                   | Temporary Slope Drain               
|                                   | Temporary Stone Check Dam           
|                                   | Temp. Stone Outlet Sediment Traps   
|                                   | Concrete Washout System             
|                                   | Oil Only Emergency Spill Kit        
|                                   | Type F Fertilizing & Seeding        
| General Landscape                 | Any non-Latin or Wildflower landscape item  
| Latin Landscape                   | Any landscape item with a Latin name  
| Wildflowers                       | Wildflower seeding                  |
Adding Job Estimate Details for Detailed (Final) Estimation

Third Party Participation
Separate category for each party

Utility Betterments (Roadway)
Separate category for each company

Bridge
Separate category for each structure

Non-Participating (Federal) Item Details
Owner’s & Contractor’s Protective Liability Insurance – 152004P
This is a DOLL Item. See the next section to calculate the cost.

Pollution Liability Insurance – 152015P
Use 5 percent of the cost of the cleanup items. Some of the cleanup items are as follows:

<table>
<thead>
<tr>
<th>Standard Pay Item No.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>201012P</td>
<td>Clearing Site, Tank Removal</td>
</tr>
<tr>
<td>201003M</td>
<td>Disposing of Contaminated Soil</td>
</tr>
<tr>
<td>201015M</td>
<td>Recycling of Contaminated Soil</td>
</tr>
<tr>
<td>201021M</td>
<td>Post Excavation Soil Sampling and Analyses</td>
</tr>
<tr>
<td>201024M</td>
<td>Composite Soil Sampling and Analyses</td>
</tr>
<tr>
<td>201027M</td>
<td>Ground Water Sampling and Analyses</td>
</tr>
<tr>
<td>201028M</td>
<td>Roadway Excavation, Regulated Waste</td>
</tr>
<tr>
<td>202028M</td>
<td>Off-Site Management of Regulated Waste</td>
</tr>
</tbody>
</table>

Also, refer to Appendix B: Federal Non-Participating Construction Cost Estimation Work Sheet for this category.

Approach slabs – 507051P with any of the following conditions:
- if one-way traffic loading is less than 500 80-kN equivalent single axle load applications per day;
- posted speed limit is less than 35 MPH;
- the abutments are not supported on pile foundations.

Maintenance Operations such as cleaning existing pipes, drainage structures, ditches, repairing impact attenuators, mowing etc. FHWA sometimes participates in this work. Contact the Project Manager for guidance. All projects that include cleaning of existing pipe shall utilize pay items for this work based on a range of pipe sizes. Cleaning of existing pipe will be measured and payment made by the linear foot or meter based on a range of 2 foot (600 mm) increments in diameter up to 8 feet (2 400 mm) and then on individual sizes beyond that. Some of the items to be used for this work are as follows:
Adding Job Estimate Details for Detailed (Final) Estimation

<table>
<thead>
<tr>
<th>Standard Pay Item No.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>601668M</td>
<td>Clean Existing Pipe, 10” diameter</td>
</tr>
<tr>
<td>601670M</td>
<td>Clean Existing Pipe, 12” to 24” diameter</td>
</tr>
<tr>
<td>601672M</td>
<td>Clean Existing Pipe, over 24” to 48” diameter</td>
</tr>
<tr>
<td>601674M</td>
<td>Clean Existing Pipe, over 48” to 72” diameter</td>
</tr>
<tr>
<td>601676M</td>
<td>Clean Existing Pipe, over 72” to 96” diameter</td>
</tr>
<tr>
<td>601678M</td>
<td>Clean Existing Pipe, 102” diameter</td>
</tr>
<tr>
<td>602216M</td>
<td>Cleaning Existing Drainage Structures</td>
</tr>
</tbody>
</table>

*White Concrete Curbing, Barrier Curb, and Island, but could be participating for 100 feet or less to match existing white material.*

BR/BH funds for **approach work** past the touchdown points for new / rehabilitated structures.

**Fishing piers** (or bridges) and pedestrian walkways for recreational access.

**Maintenance dredging** if the dredged material is not used as a fill. Items of work paid for by **other** agencies or private developers.

Type II Noise Barriers

**Waterway openings** and net fill requirements mandated by NJDEP when they differ from FHWA requirements.

**Structures** less than 20 feet in span if BR/BH funds are being utilized for the project.

Greater than 2:1 **mitigation** of wetland sites. FHWA **sometimes** participates in greater than 2:1 replacement if FHWA considers the impact significant. Contact the Project Manager for guidance.

**Sometimes** the use of **liners** for Wetland Mitigation Sites as they do not permit ground water recharge. Contact the Project Manager for guidance.

**Sidewalks** on bridges when there are no sidewalks on the approaches for pedestrians. Contact Project Manager for guidance.

**Sometimes** Memorial and/or Vanity **Plaques** on structures.

**Proprietary** items not approved by FHWA. Complete the “Request for Approval of Patented/Proprietary Items on Federally Funded Projects” form.

### 5.4 Deleting a Job

To delete an existing job, begin by selecting the job to be deleted from the Jobs list window. To select more than one job record at a time, hold down the **CTRL** key as you select the records. To select multiple records that are adjacent to each other, select the first record, then hold down the **SHIFT** key as you select the last record. To select all the records in the list window at once, choose **Select All** from the **Edit** menu.
Once the job(s) to be deleted is selected, choose **Delete** from the **Edit** or right mouse button menu, or press **SHIFT+DELETE**. A Delete window will display.

![Delete Window](image)

**Figure 5-10. Job Delete Window**

If you select **DELETE**, CES will erase the job(s), but will retain any snapshots for the job(s), including an automatic snapshot taken during the deletion process. **POWER DELETE** is a more thorough deletion option that not only erases a job, but also deletes any traces of a job’s existence including snapshots and other job information.

CES will display a series of Delete Warning windows listing the tables that will be affected by the deletion. This means you will need to confirm the deletion several times before CES will delete the data from the database. The window title bar lists the number of deletes required. An example of a Delete Warning window is shown in Figure 5-11.

![Delete Warning Window](image)

**Figure 5-11. Example of Delete Warning (1 of 3) Window**

If you click **YES** in each of the Delete Warning windows, CES will then display a final window to confirm the deletion (see Figure 5-12).

![Confirm Delete](image)
To delete the job currently listed, click YES. If you chose multiple jobs to delete at once, you can click YES TO ALL to delete them simultaneously, or you can click NO to cancel the deletion of the job currently listed and move on to the Confirm Delete window for the next job. Click CANCEL to cancel the deletion of the remaining selected jobs.

5.5 Viewing a Job

To access a job in a mode where you can view but not modify the job’s information, double-click on that job from the Jobs list window, or choose Job from the View or right mouse button menu. In the Job tabbed folder window that opens, you can view the information on the various tabs that are available, but you cannot edit any information on those tabs.

While in View mode, if you find information that needs to be edited, you can easily switch directly to Change mode by selecting Change from the Edit menu. You cannot, however, switch back to View mode directly from Change mode. If you switch to Change mode, you can edit the tabs as necessary to create the job estimate.

5.6 Changing the Spec Year for a Job

Occasionally you might enter a job, then discover the spec year must be changed. This could occur, for instance, when a job is estimated many years in advance of work being done. The job may require re-estimation as the time of the job draws nearer, and a new spec year may also be required.

When you change the spec year for a job, items that match exactly between the new and old spec years will automatically be changed. Items that are not found in the new spec year will be flagged. Items with matching codes but differing descriptions or units will be flagged as potentially different. You can then check the validity of the item codes, cost sheets, and so forth for the flagged items. CES will not automatically change item codes or convert between unit systems.

To change a job’s designated spec year, select the job to change from the Jobs list window, and choose Change Spec Year from the Edit menu. A Select Spec Year window will display with all the spec years listed, except the one currently assigned to the job (see Figure 5-13).
Select the desired spec year, and then click OK. The job will now be listed with the newly designated spec year. Note that this is not possible between 2001 and 2007 due to the nature of the items and how they are assigned.

5.7 Splitting a Job

You can split an existing job to incorporate all its item data into two or more new jobs. CES allows you to do this without affecting the original job from which the information is being drawn. Two requirements for splitting a job are that the jobs into which information is being passed cannot contain any items, and they must share the same spec year as the original job.

To split a job, select that job from the Jobs list window and choose Split Job from the Edit menu. If there are not at least two jobs that meet the requirements for job splitting, a blank Job for Spec Year With No Items window will appear.

If there are at least two appropriate jobs into which to split the chosen job, a window displays listing those jobs (see Figure 5-14).

Filter and sort the window as you would any other list window if necessary. Select the first job into which to place the split job’s information, press and hold down the CTRL key, select the other jobs in which the original job is to be split, and click OK. CES displays a list of the items in the job being split, and includes a column with the name of the jobs into which the information is being placed (see Figure 5-15).
To assign the original job’s items to the selected jobs, you can type quantity information directly in the editable fields, or you can double-click in a field to bring in the remaining quantity for an item.

Once you have assigned all the original job’s item quantities to the selected jobs, complete the split by selecting Close from the File menu. CES will display the Split Job Process window asking if you are sure you want to split the job.

Click YES to confirm the job split, NO to cancel the job split and return to the Jobs list window, or CANCEL to cancel the job split and return to the Split Job window.

If you click YES but have not yet assigned all the item quantities from the original job, CES will display an Unassigned quantity window (see Figure5-17).

Figure 5-15. Example of a Split Job Window

Figure 5-16. Split Job Process Window
Click OK and then assign all the remaining item quantities in the Split Job window before exiting the window and confirming the job split.

Once all the item quantity assignments are in place and you have confirmed the job split, CES will split the job and return to the Jobs list window. The original job from which the item information was taken remains intact, and the jobs into which the item information was placed now reflect that added information.

At this point you might choose to delete the job that was split since its information is now stored in other jobs. As an additional safeguard, a snapshot is automatically created when a job is split, so the original job’s information is stored in snapshot form, as well.
6. Adding and Pricing Items for Detailed (Final) Estimation

Once job estimate details have been added to the project, item and pricing information may be added for detailed estimation. This chapter describes adding and pricing estimate items.

6.1 NJDOT Policies and Procedures

When adding items to the detailed estimate, NJDOT policies and procedures noted below should be followed.

The best use of the Bid Price Report is to find projects listed in the Report which are similar in work type, location and quantities to the project being estimated. If such projects are found, the prices for these projects will be indicators of what to use in the estimate. When “not too similar” projects are the best that can be found in the Report, the prices for those projects can still be utilized if the following “rules of thumb” are taken into account:

Quantity – the larger the quantity the lower the cost except very large quantities may not cost less. Very small quantities are usually disproportionately expensive.

Restrictions on the Contractor:

Working hours – most construction workers get paid for an 8-hour day even if they work less. Therefore, costs will be more on a project that requires the work to be carried out in less than 8-hour shifts.

Access to the work site – the more access is restricted, the higher the cost of doing the work.

Stage Construction – the more complicated the construction staging the higher the cost.

Maintenance of Traffic – working in close proximity to traffic costs more. The closer the proximity and the higher the traffic volume, the higher the cost.

Night Work – work done at night usually costs about 30% more than the same work done during the day.

Completion Date.

Costs will be higher if a contractor must work overtime in order to meet the completion date. Work done on overtime costs about 30% extra. In lieu of overtime a contractor may increase his prices to cover anticipated liquidated damages.

Some materials require significant lead times for fabrication or manufacture. Costs will be higher if the completion date does not allow sufficient lead time for such items since the contractor will have to pay a premium for getting early delivery or may increase his prices to cover anticipated liquidated damages.

Availability of some materials is seasonal and requiring work to be done “out of season” will significantly increase the cost. For example, hot mix asphalt is not readily available in the winter because most plants are shut down.

Location – work in urban areas costs more than work in rural areas.

When adding items to the detailed estimate, NJDOT policies and procedures noted below should be followed along with those mentioned in the Cost Estimation Guidelines by the PMO.
6.1.1 Line Item Numbering

NJDOT policy is that line items be numbered in increments of one. Items that need to be inserted into the estimate should be added using the next incremental line number in the estimate and assigned to the appropriate item category. (See ‘No Item’ below.)

Starting in September 2006, NJDOT policy mandates the use of the Standard Item Number in the “bubbles” on the plan sheets to identify items instead of the Pay Item Number. The “Pay Item Number” column formerly on the EQDQ sheet will be changed to “Sequence Number.” Line numbers in CES do have to match Sequence Numbers.

6.1.2 ‘No Item’ Item

With the implementation of CES, the item 99Z99 – ‘No Item’ will no longer be used. Items that need to be inserted into the estimate should be added using the next incremental line number in the estimate and assigned to the appropriate item category. Items may then be viewed by category by sorting on the category column in the ITEMS tab of the Job window.

6.1.3 Alternate Items

Different items can be alternates for each other and a bidder can choose to bid on either item but not both. Numbering of alternates will be the same as in the past, the alternate must contain 2 letter and 1 number. For further explanation, from the Alt. Code column header, choose Field Help from the right-mouse menu.

Alternate Groups of Items are groups of items that are bid together (regardless of how many are in each group). These groups will carry the SAME first two letters for the entire group with one number while the second group of items will carry the SAME two letters as the first group with a different number. As an example, if group number 1 has 6 items they will all carry the designation AA1, and the second group of items that is an alternate to bidding the first group actually has 7 items it will carry the designation AA2 (even though the number of items to be bid is different, the entire group of items must be bid so the same letter designation will force the system to choose all of the items).

6.1.4 Fixed Price Items

Fuel Price Adjustment http://www.state.nj.us/transportation/eng/CCEPM/ section 160.03.01 and Asphalt Price Adjustment http://www.state.nj.us/transportation/eng/CCEPM/ section 160.03.02 are not negotiated items and should be marked as “Fixed Price” (i.e. Carry Items) by clicking in the box marked “Fixed” for that item in the CES Job ITEMS tab.

6.1.5 Newly Assigned Standard Items

Every item, including non-standard items, requires a unique Item Number on the plans and on the Construction Cost Estimate. Newly Assigned Standard Items are now included in the Master Item List. If an Item Number for a Newly Assigned Standard Item is not on the Master Item list, complete the New Item Number Request Form (Appendix C) and submit it to the Trans*port Team at Trnsport.Support@dot.nj.gov along with the required specification and, if needed, a detail.

For Newly Assigned Standard Pay Items, the Estimator should contact suppliers, manufacturers and other agencies that may have used the item or similar items. Include all backup information on how the price was calculated with the submission. If an in-
place cost is not available, develop it assuming that the in-place cost is comprised of 30% labor, 20% equipment, 25% materials and 25% overhead and profit.

6.1.6 Lump Sum/DOLL Items

Lump Sum/DOLL items including Performance and Payment Bond, Final Cleanup, Construction Layout, Owner’s and Contractor’s Protective Liability Insurance, Progress Schedule, and Clearing Site may be priced according to the ranges shown in the Tables below and in the charts of Attachment 1 to the Cost Estimating Guideline by PMO. Charts will be updated by NJDOT on a regular basis. If the consultant determines that special project needs require adjustment to the suggested amount, they may price accordingly, with an explanation attached to the job in CES. Mobilization must be calculated using the percentages between 8-14% of the subtotal. A lower percentage should be used for smaller jobs of minimal scope i.e. resurfacing. For bridge projects and more complicated scope use up to 14%.

Table 6-1. Performance and Payment Bond - 151003M

<table>
<thead>
<tr>
<th>Project Costs (Mil.)</th>
<th>Class 1, 2, 6</th>
<th>Class 3, 4, 7</th>
<th>Class 5</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>North</td>
<td>South</td>
<td>North</td>
</tr>
<tr>
<td>Less Than 1.0</td>
<td>8000</td>
<td>7,000</td>
<td>10,000</td>
</tr>
<tr>
<td>1.0 to 5.0</td>
<td>30,000</td>
<td>25,000</td>
<td>25,000</td>
</tr>
<tr>
<td>5.0 to 10.0</td>
<td>55,000</td>
<td>50,000</td>
<td>45,000</td>
</tr>
<tr>
<td>10.0 to 20.0</td>
<td>110,000</td>
<td>80,000</td>
<td>75,000</td>
</tr>
<tr>
<td>20.0 to 30.0</td>
<td>160,000</td>
<td>125,000</td>
<td>200,000</td>
</tr>
<tr>
<td>30.0 to 40.0</td>
<td>200,000</td>
<td>200,000</td>
<td>300,000</td>
</tr>
<tr>
<td>40.0+</td>
<td>500,000</td>
<td>400,000</td>
<td>275,000</td>
</tr>
</tbody>
</table>
### Table 6-2. Final Cleanup - 161003P

<table>
<thead>
<tr>
<th>Project Costs (Mil.)</th>
<th>Class 1, 2, 6</th>
<th>Class 3, 4, 7</th>
<th>Class 5</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>North</td>
<td>South</td>
<td>North</td>
</tr>
<tr>
<td>Less Than 1.0</td>
<td>5,000</td>
<td>5,000</td>
<td>5,000</td>
</tr>
<tr>
<td>1.0 to 5.0</td>
<td>8,000</td>
<td>8,000</td>
<td>7,500</td>
</tr>
<tr>
<td>5.0 to 10.0</td>
<td>15,000</td>
<td>15,000</td>
<td>12,000</td>
</tr>
<tr>
<td>10.0 to 20.0</td>
<td>20,000</td>
<td>20,000</td>
<td>15,000</td>
</tr>
<tr>
<td>20.0 to 30.0</td>
<td>25,000</td>
<td>25,000</td>
<td>18,000</td>
</tr>
<tr>
<td>30.0 to 40.0</td>
<td>27,000</td>
<td>27,000</td>
<td>20,000</td>
</tr>
<tr>
<td>40.0+</td>
<td>50,000</td>
<td>50,000</td>
<td>30,000</td>
</tr>
</tbody>
</table>

### Table 6-3. Owner's & Contractor's Protective Liability Insurance - 152003P

<table>
<thead>
<tr>
<th>Project Costs (Mil.)</th>
<th>Class 1, 2, 6</th>
<th>Class 3, 4, 7</th>
<th>Class 5</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>North</td>
<td>South</td>
<td>North</td>
</tr>
<tr>
<td>Less Than 1.0</td>
<td>5,000</td>
<td>5,000</td>
<td>5,000</td>
</tr>
<tr>
<td>1.0 to 5.0</td>
<td>10,000</td>
<td>9,000</td>
<td>6,000</td>
</tr>
<tr>
<td>5.0 to 10.0</td>
<td>17,500</td>
<td>13,500</td>
<td>10,000</td>
</tr>
<tr>
<td>10.0 to 20.0</td>
<td>30,000</td>
<td>20,000</td>
<td>15,000</td>
</tr>
<tr>
<td>20.0 to 30.0</td>
<td>50,000</td>
<td>30,000</td>
<td>40,000</td>
</tr>
<tr>
<td>30.0 to 40.0</td>
<td>55,000</td>
<td>35,000</td>
<td>50,000</td>
</tr>
<tr>
<td>40.0+</td>
<td>100,000</td>
<td>70,000</td>
<td>60,000</td>
</tr>
</tbody>
</table>
The following items should be calculated with the following information in mind:

Field Office-Add 1 month to project duration. If project cost is over $25 million add 2 months to duration.

Field Office Maintenance-Add 3 months to project duration per 2007 Standard Specifications for Road and Bridge Construction, Section 155.03.03.

Materials Field Laboratory-Add 1 month to project duration. Curing and Storage facility-Add 1 month to project duration. Trainees-1000 hours/$1 million at a rate of $1.00/hr.

Railroad Protective Liability Insurance-Use only if specified by the Special Provisions, per section 152.03.02 of the 2007 Standard Specifications for Road and Bridge Construction. Use one-half of one percent of the total project cost and paid as a DOLL Item. It should also be assigned to the Non-Participating category.

Pollution Liability Insurance-This is required for ALL projects as specified under section 152.03.03 of the 2007 Standard Specifications for Road and Bridge Construction.

6.1.7 Maintenance and Operations Only Items

Certain items are designated for use by Maintenance and Operations only. This includes all item numbers beginning with “MM;” for example, MME001M.

These items will not be in the spec book, but are considered to be standard items. They require specifications in the bid proposal, but do not require an entry in the Item Supplemental Description field.

6.2 Adding Items

In the Job tabbed folder window, you can add items using either the grid view or the tree view of the ITEMS tab.

6.2.1 Adding Items Using the Grid View

The ITEMS tab of the Job tabbed folder window defaults to a grid view that displays information for all the items associated with the current job.
If there are no items on the tab, your first step will always be to select Add from the Edit menu or to press SHIFT+INSERT from your keyboard. CES adds a blank row ready to be filled with information about the item that you are defining.

For each additional item added, you will also need to add a blank row. These are the fields that can be edited on the ITEMS tab:
<table>
<thead>
<tr>
<th><strong>Line Number</strong></th>
<th>The line number of the item. This field will auto populate as items are added to the estimate</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Alt. Code</strong></td>
<td>Different items can be alternates for each other, meaning that a bidder can choose to bid on either item, but not both. The code you enter here indicates that this is an alternate item. The first two characters specify the alternate group, and the third character the alternate number. For example, if you wanted to define two items as alternates for each other, you could enter AA1 as the alternate code for one item, and AA2 for the other. The fact that both items are alternate group AA tells AASHTOWare Project that a bidder should choose among them. The different alternate numbers tell AASHTOWare Project that the bidder can choose the first item or the second. Complex alternate schemes can be entered as well. For example, suppose that you have five items. The first should be bid no matter what. In addition, a bidder should bid on the second item, or the third and fourth items together, or the fifth item. The first item should have a blank alternate code, the second could have code XY1, the third and fourth could each have code XY2, and the fifth could have code XY3. When a group of items must be bid (regardless of how many items are in each group) they will all carry the same first 2 letters and the same number for the entire group of items (i.e. AA1). The second group of items to be bid will then carry the same 2 letters as the first but a different number (i.e. AA2). This will ensure that all items of the specific group will be bid.</td>
</tr>
<tr>
<td><strong>Item</strong></td>
<td>The number that identifies the item. Click the down arrow at the bottom left of the tab screen to display the Items window from which to select an item. You can select multiple items to add from the Items window by holding down the CTRL key. (If you fill in the category Number on the Items window, it will fill in the category for those items.) CES places the first selected item in the currently selected row, and then it creates new rows to accommodate the additional items. Item numbers beginning with &quot;MM&quot; are for use by Maintenance and Operations only.</td>
</tr>
<tr>
<td><strong>Quantity</strong></td>
<td>The total quantity of the item. The quantity for Lump Sum items must always be 1.</td>
</tr>
<tr>
<td><strong>Unit Price</strong></td>
<td>Although this field is generally calculated from the item tasks, you can add an ad hoc unit price for the item. If you use an ad hoc price, it makes all active tasks for the item inactive. The unit price can be added to the grid view by inserting it or to the tree view by selecting Add from the right mouse button menu and choosing Reference Price, and then selecting New Price.</td>
</tr>
<tr>
<td><strong>Comment</strong></td>
<td>A brief comment about the item.</td>
</tr>
</tbody>
</table>
Supplemental Description 1 | The primary supplemental description for the item. This is **required** for a Non-Standard Item and demo parcels, but may be used to supply additional information for any item. It will be included on the Bid Proposal file in Expedite for contractors.

Supplemental Description 2 | The secondary supplemental description for the item. It provides space for a continuation from Supplemental Description 2 if needed.

Category | The category with which the item is associated. Select the down arrow beside this field to display a drop-down list from which to select a category, or type in the number. Categories available are based on categories that were defined previously in the CATEGORY tab in the Job window.

Fixed Price | Select this check box if the item is a fixed price, meaning the price will be displayed on the Bid Document and the contractor may not change it.

State Furnished | Select this check box if the item is acquired from the state (i.e. non-bid item). If this is checked, the item will not be included on the Bid Proposal.

Funding Code | This field will not be used in CES.

Code 1 | This field is not currently being used by NJDOT.

Click **SAVE** or select **Save** from the **File** menu to save your work.

**6.2.2 Adding Items Using the Tree View**

The **ITEMS** tab of the Job tabbed folder window defaults to a grid view that displays information for all the items associated with the current job; however, if you prefer you can use the tree view to add and change item information. This view also shows any variables used to determine a field value. To access the tree view of the **ITEMS** tab, select **Tree View** from the **View** menu.
You can also add variable information to your items when you are in the detail area.

**Note:** To switch back to the grid view, you would select **Grid View** from the **View** menu.

In the tree view, a job's items are displayed in the left pane of the ITEMS tab in a tree-like, hierarchical manner, and the information in the right pane corresponds with the currently chosen item in the left pane. If there are no items on the tab, your first step will always be to select **Add** from the **Edit** menu, and then choose **Item**. CES adds an item in the left pane and a data entry area ready to be filled with information about that item in the right pane.
Edit the item data fields in the tree view in the same way as you would in the grid view. Click SAVE or select Save from the File menu to save your work.

6.3 Adding Item Variables

You can add variables to your item using the Item Variables section of the detail window. Variables allow you to add any extra information to your item to include in the final estimate of the job.

To add a variable to your item, make sure you are in the tree view and select Variables from the Edit menu, and choose Add. CES displays a window that allows you to select whether your variable type is a number (N) or a string (S), and to name your variable.

Choose the variable type and name the variable. Click OK. CES adds the variable to the item. If you select the variable type N, then CES allows you to edit the Value field for the variable, but not the String field. If you select the variable type S, then CES allows you to edit the String field, but not the Value field. CES inserts the new variable in the Items Variables section of the detail window.
6.4 Adding Item Tasks

To enter a job’s item tasks, you must be in the ITEMS tab of the Job tabbed folder window with the tree view displayed. There are several different types of tasks that you can add to an item, including bid-based prices, cost sheets, and reference prices. You can also organize CES tasks by grouping them together within task groups.

6.4.1 Adding and Changing Bid-based Prices

A bid-based price is the unit price for a work item that is derived in CES using one of two bid history estimation methods, which, listed in order of priority, are regression and averages. To work with bid-based prices for items, you must first fill in the Item History field found on the GENERAL tab of the Job tabbed folder window. CES draws information from the library listed in this field when calculating bid-based prices.

To add or change a bid-based price for an item, while in the ITEMS tab of the Job tabbed folder window, access the tree view by selecting Tree View from the View menu. In the left pane of the tree view, select the item to edit.

To add a bid-based price to the selected item, choose Add from the Edit menu, and then select Bid-based Price. The left pane of the ITEMS tab alters to display the new bid-based price at the end of the list of tasks for the selected item. (To place the bid-based price elsewhere in the list, highlight the task above which to place the bid-based price, and select Insert instead of Add.) The right pane displays a data entry area for the bid-based price.
These fields can be edited in the data entry area:

**Task ID**
An identifier for the bid-based price task. This identifier must differ from any other task IDs for the selected item.

**Comment**
An automatically generated comment providing information about the bid-based price, which may be appended or overwritten by the user.

**Item Code**
The item on which the bid-based price is founded. When this field is blank, the price is based on the item selected in the left pane of the ITEMS tab. If there is another item on which the bid-based price should hinge, enter that item’s number in this field or click the down arrow beside the field to display the Items list window from which to select an item.

**Library Name**
The item bid history library that CES uses to arrive at the bid-based price. When this field is blank, CES uses the library specified in the Item History field on the GENERAL tab. If there is another library on which the bid-based price should hinge, enter that library’s name in this field or click the down arrow beside the field to display the Item Bid History Libraries list window from which to select a library.

If CES is missing any data needed to derive the item’s bid-based price (such as an item quantity or a bid history library name), a message displays in the Comment field specifying the data that is missing (see Figure 6-7). Once you have added the missing information, CES will recalculate the tasks for the selected item taking the newly added information into account.
If CES does have sufficient information to produce a bid-based price for an item, that price displays in the Price field, and CES multiplies the amount in the Price field by the item’s quantity. The resulting amount is then added to the item’s extended amount, which in turn is reflected in the job’s overall estimated cost.

Once you’ve entered the bid-based price, save your work. If the Urban/Rural, Highway Type, or Season fields on the GENERAL tab have not yet been completed, an error message appears.

![Error Message](image)

**Figure 6-8. Error Message for Bid-Based Price**

Return to the GENERAL tab and fill in the required fields, then resave your work.

### 6.4.2 View Bid-Based Information

When CES uses regression analysis to price an item, you can access a graphical view of the regression information by highlighting the item bid-based task from the Tree View and choosing **Bid-based Information** from the View menu. CES displays a Bid History Analysis window with the REGRESSIONS tab displayed.

![Bid History Analysis Window](image)

**Figure 6-9. Bid History Analysis Window-REGRESSIONS Tab**
You can interactively display the exact price and quantity amounts for the entire regression. To do this, place your cursor in the regression area of the graphic, and then press and hold down the left mouse button while moving your cursor back and forth in the area. As you move your cursor, the information in the Price and Quantity fields to the right of the curve automatically adjusts to display the amounts that correspond to the location of your cursor in the regression curve.

Use the horizontal scroll bar at the bottom of the window to view specific information about the regression. Click PRINT to print the regression information, click the AVERAGES tab to view the averages information, or click OK or CANCEL to exit the graphic window.

If you have adjusted the Price and Quantity fields by clicking on the regression curve and you click OK to exit, the price of your item task will be set to the adjusted price. The quantity for the item is not changed, but a comment with the adjusted quantity is added in the Bid-based Comment field to indicate that the item task price is now based on a different quantity. To retain the original price for your item task, click CANCEL to exit the graphic window.

The averages information for an item task displays on the AVERAGES tab of the Bid History Analysis Window. Even if CES does not have the information necessary to perform a regression analysis for an item task, it still attempts to produce a price for that item based on averages.

Similar to the REGRESSIONS tab, you can interactively display the exact price and quantity amounts for the averages graphic chart by pressing and holding down the left mouse button while moving your cursor back and forth in the graphic area. As you move your cursor, the information in the Price and Quantity fields to the right of the graphic
automatically adjusts to display the amounts that correspond to the location of your cursor in the averages chart.

Use the horizontal scroll bar at the bottom of the window to view specific averages information. Click PRINT to print the averages information or click OK or CANCEL to exit the graphic window.

If you have adjusted the Price and Quantity fields by clicking on the averages chart and you click OK to exit, the price of your item task will be set to the adjusted price. The quantity for the item is not changed, but a comment with the adjusted quantity is added in the Bid-based Comment field to indicate that the item task price is now based on a different quantity. To retain the original price for your item task, click CANCEL to exit the graphic window.

6.4.3 Adding and Changing Cost Sheets

A cost sheet is a CES utility for tallying the costs of the labor, equipment and material(s) needed to complete a job task.

The AASHTOWare Project Team will populate reference tables containing Labor, Equipment and Material rates with data from RS Means, which will be updated periodically.

To add or change a cost sheet for an item, while in the ITEMS tab of the Job tabbed folder window, access the tree view by selecting Tree View from the View menu. In the left pane of the tree view, select the item to edit. There are five different ways to add a cost sheet. You can:

1. Add a new cost sheet “from scratch.”
2. Add a standard CES cost sheet from the Cost Sheet List. (Users may add their own standard cost sheets to the Cost Sheet List.).
3. Add another item’s default cost sheet (this option may not be available for NJ).
4. Add one of this particular standard item’s default cost sheets (this option may not be available for NJ).
5. Add a cost sheet attached to an item in another job.

For any of these options, you need to begin by selecting Add from the Edit menu, and choosing Cost Sheet. From the Cost Sheet submenu, select the appropriate option. Once you’ve selected which way your cost sheet will be added, a window displays from which to select the desired cost sheet.

Figure 6-11. Example of Cost Sheet Selection Window
Select the appropriate cost sheet and click OK. Once you click OK, or if you earlier chose the New Cost Sheet option, CES alters the left pane of the ITEMS tab to display the new cost sheet at the end of the list of tasks for the selected item. (To place the cost sheet elsewhere in the list, highlight the task above which to place the cost sheet, and select Insert instead of Add.) The right pane displays a data entry area for the cost sheet.

**General Section**

Click on the GENERAL radio button to display the General section of the cost sheet (see Figure 6-12). These fields can be edited in the General section:

- **Task ID**
  An identifier for the cost sheet task which is automatically populated but may be edited. This identifier must differ from any other task IDs for the selected item.

- **Cost Sheet ID**
  An identifier for the CES standard cost sheet or item default cost sheet from which the current cost sheet's information is drawn, if applicable.

- **Description**
  A short description of the cost sheet.

- **Hours Per Day**
  The number of hours per day that the crew is expected to work. This number is used to determine the labor and equipment costs as well as the unit price for the task.
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overtime Per Day</td>
<td>The number of overtime hours per day that the crew is expected to work. This number is used to determine the labor and equipment costs as well as the unit price for the task.</td>
</tr>
<tr>
<td>Unit</td>
<td>The unit by which the selected cost sheet is measured. Enter a unit or click the down arrow beside the field to display a drop-down list from which to select a unit.</td>
</tr>
<tr>
<td>Labor Overhead Percentage</td>
<td>The percentage of the labor expenses for the task that is being set aside to cover unforeseen occurrences. This number is used to determine the labor costs as well as the unit price for the task.</td>
</tr>
<tr>
<td>Equipment Overhead Percentage</td>
<td>The percentage of the equipment expenses for the task that is being set aside to cover unforeseen occurrences. This number is used to determine the equipment costs as well as the unit price for the task.</td>
</tr>
<tr>
<td>Materials Overhead Percentage</td>
<td>The percentage of the material expenses for the task that is being set aside to cover unforeseen occurrences. This number is used to determine the material costs as well as the unit price for the task.</td>
</tr>
<tr>
<td>Production Rate</td>
<td>The rate of production for the selected cost sheet per day; i.e., the number of units of the item that can be produced by the specified labor and equipment in the day defined (hours plus overtime). This number is used to determine the unit price for the task.</td>
</tr>
<tr>
<td>Markup Percentage</td>
<td>The percentage of the total expenses for the task that is being set aside to cover unforeseen occurrences. This number is used to determine the unit price for the task.</td>
</tr>
<tr>
<td>Quantity Per Item Unit</td>
<td>The amount of cost sheet unit that is necessary to produce one unit of the item to which the cost sheet is attached. For example, if the cost sheet employs a different unit of measure than the item, a conversion factor can be entered here.</td>
</tr>
</tbody>
</table>

The fields in the General section of the cost sheet data entry area that cannot be edited are filled by CES when it has sufficient information from the other three sections: Labor, Material, and Equipment. The Cost Sheet Unit Subtotal field is filled as the cost sheet unit price before the Markup Percentage. It is comprised of the labor and equipment rate divided by the production rate, plus the material rate. When CES has enough data to compute a Cost Sheet Unit Price, it multiplies that unit price by the quantity entered in the Quantity per Item Unit field, which results in an Item Unit Price.

**Labor Section**
Click on the LABOR radio button to display the Labor section of the cost sheet.

**Figure 6-13. Cost Sheet Entry Area—Labor Section**

**Adding Laborers**

If there are no laborers currently listed in the Labor section of the cost sheet (see Figure 6-13), you need to begin either by adding a row in which to enter a single laborer or by adding a predefined work crew. To add a single laborer, select Add from the Edit menu, and then choose Laborer. A row appears in the Labor section.
Figure 6-14. Cost Sheet Entry Area—Labor Section with a Blank Row

For each additional laborer added, you also need to insert a blank row; otherwise, CES overwrites the information in the currently selected row. When you insert a row by choosing Add from the Edit menu, the row is placed beneath all the other existing rows. To place the row elsewhere in the list, highlight the row above which to place the new row, and select Insert instead of Add.

These fields can be edited in the data entry area:

**Laborer ID**  
An identifier for the laborer. Enter a laborer ID, or click the down arrow at the bottom of the Labor section to display the Labor window from which to select a laborer.

**Description**  
A short description of the laborer. This information is automatically brought in if you add a laborer using the Labor window.

**Quantity**  
The number of persons expected to work in the capacity of the selected laborer.

**Rate**  
The rate of pay per hour for the selected laborer.

**Overtime Rate**  
The overtime rate of pay per hour for the selected laborer.

Unlike adding an individual laborer, if you want to add a predefined work crew in the Labor section, it is not necessary to insert a blank row beforehand. When you add a labor crew in CES, the information for that crew is automatically placed beneath the last row in the list. If no rows exist, CES simply makes some to accommodate all the necessary information.

To insert a labor crew, select Add from the Edit menu, and then choose Crews. A Select Crews window displays.

Figure 6-15. Select Crews Window
Select the crew or crews to insert. To choose more than one crew at a time, hold down the CTRL key while selecting the crews. To select several crews that are adjacent to each other, select the first crew and then hold down the SHIFT key as you select the last crew to be chosen. All the crews to be inserted are highlighted.

Once you have chosen the crew(s) to insert, click OK or click CANCEL to cancel the action. If you click OK, the selected crew(s) displays in the Labor section of the cost sheet.

![Figure 6-16. Cost Sheet Entry Area-Labor Section With a Labor Crew](image)

The Crew ID field identifies the crew ID for laborers who are inserted as part of a crew. You can edit the inserted crew rows just as you would any other rows.

**Deleting Laborers**

To delete laborers from the Labor section, begin by selecting the row or rows of labor information to delete. To choose more than one row at a time, hold down the CTRL key while selecting the rows. To delete several rows that are adjacent to each other, select the first row and then hold down the SHIFT key as you select the last row to be deleted. All the rows to be deleted are highlighted.

Once you have chosen the row(s) to delete, select **Delete** from the **Edit** menu, and then choose **Laborer**. As shown in Figure 6-17, CES displays a Delete Highlighted Rows window.

![Figure 6-17. Delete Highlighted Rows Window](image)
Click YES to confirm the deletion or NO to cancel the action. If you selected more than one row to delete, an additional Delete Highlighted Rows window displays to give you an extra opportunity to cancel the process. Click YES to complete the deletion.

**Material Section**

Click on the MATERIAL radio button to display the Material section of the cost sheet.

---

**Adding Materials**

If there are no materials currently listed in the Material section of the cost sheet (see Figure 6-18), you need to begin by adding a row in which to enter material information. To do this, select Add from the Edit menu, and then choose Material. A row appears in the Material section.

---

**Figure 6-18. Cost Sheet Entry Area-Material Section**

**Figure 6-19. Cost Sheet Entry Area-Material Section With a Blank Row**
For each additional material added, you will also need to insert a blank row; otherwise, CES overwrites the information in the currently selected row. When you insert a row by choosing Add from the Edit menu, the row is placed beneath all the other existing rows. To place the row elsewhere in the list, highlight the row above which to place the new row, and select **Insert** instead of Add.

These fields can be edited in the data entry area:

**Material Number**
A unique number or alphanumeric that identifies the material. Enter a material number, or click the down arrow at the bottom of the Material section to display the Materials window from which to select a material.

**Description**
A short description of the material. This information is automatically brought in if you add a material using the Materials window.

**Quantity**
The total amount of material (total number of material units) for the cost sheet task.

**Price**
The cost of one unit of the material.

**Deleting Materials**
To delete materials from the Material section, begin by selecting the row or rows of material information to delete. To choose more than one row at a time, hold down the **CTRL** key while selecting the rows. To delete several rows that are adjacent to each other, select the first row and then hold down the **SHIFT** key as you select the last row to be deleted. All the rows to be deleted are highlighted.

Once you have chosen the row(s) to delete, select **Delete** from the **Edit** menu, and then choose **Material**. As shown in Figure 6-17, CES displays a Delete Highlighted Rows window. Click **YES** to confirm the deletion or **NO** to cancel the action. If you selected more than one row to delete, an additional Delete Highlighted Rows window displays to give you an extra opportunity to cancel the process. Click **YES** to complete the deletion.

**Equipment Section**
Click on the **EQUIPMENT** radio button to display the Equipment section of the cost sheet.
Adding Equipment

If there is no equipment currently listed in the Equipment section of the cost sheet (see Figure 6-20), you will need to begin either by adding a row in which to enter a single piece of equipment or by adding the equipment that is associated with a predefined work crew. To add a single piece of equipment, select Add from the Edit menu, and then choose Equipment. A row appears in the Equipment section.

For each additional piece of equipment added, you will also need to insert a blank row; otherwise, CES overwrites the information in the currently selected row.

When you insert a row by choosing Add from the Edit menu, the row is placed beneath all the other existing rows. To place the row elsewhere in the list, highlight the row above which to place the new row, and select Insert instead of Add.
These fields can be edited in the data entry area:

**Equipment ID**
An identifier for the equipment. Enter an equipment ID, or click the down arrow at the bottom of the Equipment section to display the Equipment window from which to select a piece of equipment.

**Description**
A short description of the equipment. This information is automatically brought in if you add a piece of equipment using the Equipment window.

**Quantity**
The total amount (number of pieces) of equipment for the cost sheet task.

**Rate**
The cost per hour for the selected equipment.

Unlike adding an individual piece of equipment, if you want to add the equipment associated with a predefined work crew, it is not necessary to insert a blank row beforehand. When you add a work crew in CES, the equipment information for that crew is automatically placed beneath the last row in the Equipment section. If no rows exist, CES simply makes some to accommodate all the necessary information.

To insert a work crew, select **Add** from the **Edit** menu, and then choose **Crews**. A Select Crews window displays.

![Select Crews Window](image)

Select the crew or crews to insert. To choose more than one crew at a time, hold down the **CTRL** key while selecting the crews. To select several crews that are adjacent to each other, select the first crew and then hold down the **SHIFT** key as you select the last crew to be chosen. All the crews to be inserted are highlighted.

Once you have chosen the crew(s) to insert, click **OK** or click **CANCEL** to cancel the action. If you click **OK**, the equipment information for the selected crew(s) displays in the Equipment section of the cost sheet.
The Crew ID field identifies the crew ID for the equipment that is inserted as part of a crew. You can edit the inserted equipment crew rows just as you would any other rows.

### 6.4.4 Copying Cost Sheets

One of the handiest features of cost sheets is that you can easily copy and adapt them (or portions of them) to meet the needs of a wide variety of items and item tasks. To copy all or a portion of a cost sheet, you must be in the tree view on the ITEMS tab of the Job tabbed folder window. To access the tree view, select Tree View from the View menu. In the left pane of the tree view, select the item or item task to edit.

#### Copying Standard and Item Cost Sheets

When you add new cost sheets in CES, you can use existing standard cost sheets as templates. There are other times when you can use those standard cost sheets, however. For instance, if you have begun to enter a cost sheet and then realize that it would have been easier to start from an existing standard cost sheet, you can copy information into your current cost sheet without having to start the cost sheet process again. To do this, make sure that the desired cost sheet is selected in the left pane of the ITEMS tab, choose Copy from the Edit menu, and then choose the standard cost sheet type. In the cost sheet selection window that displays, choose a cost sheet and click OK. The information from the chosen cost sheet is copied to your current cost sheet.

#### Copying Blocks of Laborers, Materials, and Equipment

Another way to copy cost sheet information is to copy blocks of laborers, materials, or equipment from one cost sheet to another. To do this, access the section of the cost sheet from which you want to copy information. Select the row or rows of data to copy. Choose Copy from the Edit menu and then select the Block of ... menu option. Access the section of the cost sheet into which to insert the block of elements. Select Paste from the Edit menu, and then choose the Block of ... menu option again.
You can repeat the Paste action as many times as necessary, and into as many cost sheets as you like. CES continues to paste the originally selected set of elements until you copy over them with a new set of the same type elements. CES can simultaneously maintain a copy set for each type of element—laborers, materials, and equipment—so that, for example, you can easily switch from copying and pasting laborers to copying and pasting equipment without losing a copy set as you go.

Click **Save** or select **Save** from the **File** menu to save your work.

### 6.4.5 Cost Sheet List and Labor, Equipment, Materials, and Crews Lists

NJDOT will populate the reference tables containing Labor, Equipment, and Material rates with data from RS Means, which will be updated periodically. Users may add their own Labor, Equipment, Materials, and Crews to the **Labor, Equipment, Materials**, and **Crews Lists**. These lists may be accessed by selecting **Reference Tables** from the **File** Menu and moving the mouse to the right to highlight the selected list. It is NJDOT policy that users may not change or delete Labor, Equipment and Material rates in the list that were created by other users, since any changes will impact all users.

Users may also add their own standard cost sheets to the **Cost Sheet List**. The **Cost Sheet List** may be accessed by selecting it from the **File** menu. Cost sheets added to the **Cost Sheet List** are accessible to all users of CES. It is NJDOT policy that users may not change or delete cost sheets in the list that were created by other users, since any changes will impact all users. Since the system does not control user ownership of cost sheets, any cost sheets selected from the list should be reviewed when using them in an estimate. Standard cost sheets may be modified in an estimate.

**Tip:** Users who do not wish to share their cost sheets may store them in a template job, and copy and paste them into their estimates as needed.

### 6.4.6 Adding and Changing Reference Prices

A **reference price** is a price used as the basis for estimating an item’s cost. Reference prices can be stipulated directly or they can be derived from formulas. There are two types of reference prices that can be added: **new prices** and **historical prices**. Historical reference prices will not be used for NJDOT.

To add or change a reference price for an item, you must be in the tree view on the **ITEMS** tab of the Job tabbed folder window. To access the tree view, select **Tree View** from the **View** menu. In the left pane of the tree view, select the item to edit.

**Adding and Changing a New Reference Price**

To add a new reference price for an item, select **Add** from the **Edit** menu, choose **Reference Price**, and then select **New Price**. The left pane of the **ITEMS** tab alters to display the new reference price at the end of the list of tasks for the selected item. (To place the reference price elsewhere in the list, highlight the task above which to place the reference price, and select **Insert** instead of Add.) The right pane displays a data entry area for the reference price.
Complete these fields to define the reference price being added:

**Task ID**
An identifier for the reference price task. This identifier must differ from any other task IDs for the selected item. This is populated by the system by default but may be changed by the user.

**Comment**
A brief comment about the reference price.

**Calculation Rule**
The way of computing the price for the item; it can either be *Normal*, or *Percent on Top* (a percentage of the total cost of the non-percent-on-top items).

**Price**
The price for the task. Enter an amount in this field, type in a formula name, or use the Formula and Expression Builder to calculate the amount (see *Chapter 11 - Formulas and Formula Libraries*). This field is available only if the Normal calculation rule is selected.

**Percent**
The percentage that the percent on top is assigned.

Enter an amount in this field, type in a formula name, or use the Formula and Expression Builder to calculate the amount (see *Chapter 11 - Formulas and Formula Libraries*). This field is only available if the Percent on Top calculation rule is selected.

Once you have completed the Price or Percent field, CES multiplies the amount in that field by the item’s quantity. The resulting amount is then added to the item’s extended amount, which in turn is reflected in the job’s overall estimated cost.
To change an existing reference price that you created, select that reference price in the left pane of the ITEMS tab and alter the fields in the right pane as necessary.

Click SAVE or select Save from the File menu to save your work.

6.4.7 Adding Task Groups

In CES, a task group is used to group together an item’s related job tasks. A task group can be a part of an item or another task group. To add or change a task group, while in the ITEMS tab of the Job tabbed folder window, access the tree view by selecting Tree View from the View menu. In the left pane of the tree view, select the item or existing task group to edit.

To add a new task group to the selected item or task group, choose Add from the Edit menu, and then select Task Group. The left pane of the ITEMS tab alters to display the new task group at the end of the list of tasks for the selected item or task group. (To place the task group elsewhere in the list, highlight the task above which to place the task group, and select Insert instead of Add.) The right pane displays a data entry area for the new task group.

These fields can be edited in the data entry area:

**Task ID**
An identifier for the task group. This identifier must differ from any other task group IDs for the selected item. This is populated by the system by default but can be edited by the user.

**Group Name**
A descriptive designation for the task group.

In addition to entering data in the two fields that are available, you can also type an extensive statement about the task group in the large text entry area in the right pane.
You can add and change tasks in a task group the same as you would the tasks that fall directly under an item. To copy an existing task to a task group, simply hold down control then click on and drag the chosen task to the task group.

Click SAVE or select Save from the File menu to save your work.

6.5 Deleting Item Tasks

You must be in the tree view of the ITEMS tab to delete item tasks. To access the tree view of the ITEMS tab, select Tree View from the View menu.

6.5.1 Deleting Bid-based Prices

To delete a bid-based price, select that bid-based price in the left pane of the ITEMS tab. Choose Delete from the Edit menu, and then select Bid-based Price. A Delete window displays (see Figure 6-26).

![Delete Window](image)

**Figure 6-26. Delete Window**

Click YES to confirm the deletion or NO to cancel the action. If you click YES, CES deletes the chosen task.

Click SAVE or select Save from the File menu to save your work.

6.5.2 Deleting Cost Sheets

To delete a cost sheet, select that cost sheet in the left pane of the ITEMS tab. Choose Delete from the Edit menu, and then select Cost Sheet. A Delete window displays (see Figure 6-26). Click YES to confirm the deletion or NO to cancel the action. If you click YES, CES deletes the chosen task.

Click SAVE or select Save from the File menu to save your work.

6.5.3 Deleting Reference Prices

To delete a reference price, select that reference price in the left pane of the ITEMS tab. Choose Delete from the Edit menu, and then select Reference Price. A Delete window displays (see Figure 6-26). Click YES to confirm the deletion or NO to cancel the action. If you click YES, CES deletes the chosen task.

Click SAVE or select Save from the File menu to save your work.

6.5.4 Deleting Task Groups

To delete a task group, select that task group in the left pane of the ITEMS tab. Choose Delete from the Edit menu, and then select Task Group. A Delete window displays (see Figure 6-26). Click YES to confirm the deletion or NO to cancel the action. If you click YES, CES deletes the chosen task.

Click SAVE or select Save from the File menu to save your work.
6.6 Identifying Item Tasks as Active or Inactive

When item tasks are added to a job in AASHTOWare Project CES, those tasks are included, or active, in the cost estimation for the job. If you determine that an item task is not necessary for the job being estimated, however, you can easily eliminate that task from CES’s calculations by marking it as inactive. To do this, you must be in the tree view of the ITEMS tab. To access the tree view of the ITEMS tab, select Tree View from the View menu.

To change an active task’s status to inactive, select that task in the left pane of the ITEMS tab and choose Toggle Active/Inactive from the Edit menu. An X displays over the selected item task indicating that it is now inactive and the costs for the task are not included in CES’s calculations for the current job.

When you mark a task group as inactive, all of its contents are also marked as inactive at the same time. If all tasks for an item are marked inactive, then the extended amount for the task group is blank.

To make an inactive task or task group active again, select that task or task group and choose Toggle Active/Inactive from the Edit menu. The selected element no longer displays an X and will once again be included in CES’s estimate calculations.

Click SAVE or select Save from the File menu to save your work.

6.6.1 Deleting Inactive Tasks

Tasks that are inactive may be kept in the job without affecting the total cost of the job. However, you do have the option of deleting the inactive tasks.

To delete an inactive task, select that task in the left pane of the ITEMS tab. Choose Delete from the Edit menu, and then select the task. A Delete window displays (see Figure 6-26). Click YES to confirm the deletion or NO to cancel the action. If you click YES, CES deletes the chosen inactive task.
You can also use the Delete Inactive Tasks command to delete all inactive tasks in the job. Select **Delete Inactive Tasks** from the **Edit** menu. A Delete Inactive Tasks window displays.

![Delete Inactive Tasks](image)

**Figure 6-28. Delete Inactive Tasks**

Click **YES** to delete all inactive tasks for the job, or **NO** to leave the current inactive tasks intact. Click **CANCEL** to cancel the operation and return to the **ITEM** tab.

If you click **YES**, then CES deletes all inactive tasks for the items in the job. Click **SAVE** or select **Save** from the **File** menu to save your work.

### 6.7 Using the Tree View’s Special Features

The **ITEMS** tab of the Job tabbed folder window defaults to a grid view that displays information for all the items associated with the current job; however, if you prefer you can switch from the grid view to the tree view to access some special features that make it very easy to manipulate items, tasks, folders, and so forth. To access the tree view of the **ITEMS** tab, select **Tree View** from the **View** menu.

![Tree View of the ITEMS Tab](image)

**Figure 6-29. Tree View of the ITEMS Tab**
6.7.1 Recognizing Identifiers

In the tree view, a job’s items are displayed in the left pane of the ITEMS tab in a tree-like, hierarchical manner, and the information in the right pane corresponds with the currently chosen item in the left pane.

In the left pane, job elements and information can be identified by icons or letters as follows:

- **Multi-folder Icon (Items for Job)**: Always present at the top of the pane, this icon contains all the item and item-related elements for the job.
- **The Letter “I”**: Represents a job item.
- **The Letter “B”**: Represents a bid-based price.
- **The Letter “C”**: Represents a cost sheet.
- **The Letter “R”**: Represents a reference price.
- **Single-folder Icon**: Represents a task group.
- **Exclamation Point in yellow square**: Indicates that a price or quantity is missing (blank).

A plus symbol next to an icon or item indicates that other elements fall underneath that icon or item. To view the underlying elements, single-click on the plus symbol or double-click on the icon or item. A minus symbol then displays where the plus symbol had been, indicating that the underlying elements for the icon or item are displayed. To fold the elements back up under their icon or item once again, single-click on the minus symbol or double-click on the icon or item.

6.7.2 Manipulating Tasks

One particularly useful feature of the tree view is that you can copy and paste tasks from one item or task group to another item or task group with the click of your mouse. For instance, you can copy and paste an entire cost sheet from one item to the next. When you copy a task in this way, all of its information is copied to the new location.

To copy and paste a task from one item or task group to another, start by selecting the task to copy. Hold down the left mouse button as you drag the selected task until it is directly on top of the desired item or task group. When you release the left mouse button, the task appears not only where it was first located, but also under the item or task group to which it was dragged. To move a task completely, or in other words, to remove it from one item or task group and place it in another, simply follow the same procedure as you would to copy the task, but hold down the CTRL key as you release the left mouse button.

You can use these same copy and paste/movement methods to copy or move an item or task group’s entire contents to another item or task group. To do this, click and drag the item or task group itself rather than an individual task.

Click **SAVE** or select **Save** from the **File** menu to save your work.
6.8 Using the Suspend/Resume Button

Because of the time the recalculation takes on larger jobs, CES has the ability to suspend the full job recalculation while on the ITEMS tab of the job folder window. When the job is in Suspend mode, you do not have to wait for the entire job to recalculate every time a change is made on the ITEMS tab, allowing for quick entry of item price and quantity information. Once your work is finished, you can resume the recalculations.

Figure 6-30. The SUSPEND Button in the Grid View

When you click SUSPEND, CES suspends the recalculations to the job. When you click RESUME, the changes are recalculated and the new item extended amount displays.
When you are in Suspend mode (when the RESUME button displays), you cannot see the job estimate total at the bottom of the screen. The recalculation does not update the total job cost until you click RESUME. When you save the job file, the Resume mode is automatically activated and the job is recalculated. The Resume mode is also automatically activated when you leave the ITEMS tab.

When you are in Resume mode (when the SUSPEND button displays), changing an item cost or price causes CES to recalculate the Extended Price for the item and the total job price.

The SUSPEND/RESUME button is also available in the tree view.

6.9 Recalculating Values for Items

CES does not automatically recalculate all the costs for a job each time a change is made to that job. Instead, it recalculates only the job element that changed and its associated higher-level entities. For instance, if you add a quantity to an item after you add a bid-based price, CES recalculates the cost for that item along with the cost for the associated job. In this case, CES looks to the Bid History Library selected on the GENERAL tab to find what the current value is.

CES offers a menu option that recalculates all the costs related to an item. This menu item is available from either the grid view or the tree view of the ITEMS tab.

To recalculate the costs related to an item, begin by selecting the row or rows of item information to include. To choose more than one row at a time, hold down the CTRL key while selecting the rows. To include several rows that are adjacent to each other, select the first item and then hold down the SHIFT key as you select the last item row to be included. All the items to be included are highlighted.

Once you have chosen the row(s) to include, select Recalculate Values from the
**Edit** menu. CES recalculates the costs for the highlighted items. Click **SAVE** or select **Save** from the **File** menu to save your work.

### 6.10 Refreshing Time-based Values for Items

Periodically, time-based values such as wages and rates are updated in the AASHTOWare Project database to reflect current market conditions. CES offers an option that applies these updated values to existing job items. To use this option, you must be in the grid view of the **ITEMS** tab.

The rates for labor, equipment, and materials on a cost sheet can be refreshed. Once you’ve added a cost sheet, you have to make sure that Labor, Equipment, and Materials Classes have all been selected on the **GENERAL** tab, or else nothing happens when you refresh your values.

To refresh time-based (also known as time-dependent) values for an item, begin by selecting the row or rows of item information to include. To choose more than one row at a time, hold down the **CTRL** key while selecting the rows. To include several rows that are adjacent to each other, select the first item and then hold down the **SHIFT** key as you select the last item to be included. All the items to be included are highlighted.

Once you have chosen the row(s) to include, select **Refresh Time-based Values** from the **Edit** menu. CES inserts updated time-dependent data for the selected item(s), and then it recalculates the costs for the highlighted items.

Click **SAVE** or select **Save** from the **File** menu to save your work.
7. Attachments

CES provides functionality for adding attachments to the estimate. This chapter describes how to add attachments in CES and NJDOT’s policies related to attachments.

7.1 NJDOT Policy

With attachments, it is no longer necessary to provide a diskette or CD of the estimate. This section details the required attachments based on NJDOT policy.

7.1.1 Consultant Requirements – Long Range (Preliminary) Estimate

All estimate related documentation should be attached to the estimate in CES. If applicable, the consultant preparing the long range estimate is required to attach the following:

- Preliminary Plans
- Transmittal Letter with a date for completion review
- Estimation Checklist (pages 4-27 and 4-28)
- Utility Estimation Checklist

7.1.2 Consultant Requirements – Detailed Estimate

All estimate related documentation should be attached to the estimate in CES. If applicable, the consultant preparing the detailed estimate is required to attach the following:

- Design Plans
- Progress Schedule
- Transmittal Letter with schedule for the project
- Specifications for non-standard items
- Breakdown for lump sum or other items with prices calculated outside of CES

7.2 Attachments

Several AASHTOWare Project CES tabbed folder windows have an Attachments tab in the rightmost position. This tab allows you to integrate OLE-compatible documents (for example, Microsoft® Word documents or Excel spreadsheets), Web pages, and plug-in applications into CES while continuing to access all the data related to a CES entity (for example, a job, an item, or a cost group). You can also integrate any attachment into multiple entities of the same type.

The Attachments tab contains a grid that lists all the attachments associated with the entity that is open in the tabbed folder window. The grid also contains attachments that are associated with all entities of the current type. Information displayed about each attachment includes the name, attachment type, and a short description.
To open an attachment, click on the attachment record to select it and choose Open from the Edit menu or the right mouse button menu. Double-clicking on a row in the grid also opens an attachment. To open more than one attachment at a time, hold down CTRL and click on each attachment you want to open, then choose Open from the Edit menu.

You can open any number of attachments simultaneously, but only one instance of each attachment.

**7.2.1 Adding an Attachment**

To add a new attachment, open a tabbed folder add or change window for a AASHTOWare ProjectCES entity and access the ATTACHMENTS tab. Select Add from the Edit menu or the right mouse button menu and choose the type of attachment to add: an OLE object, a Web page (URL), or a plug-in.
Adding an OLE Object Attachment

When you select OLE Object from the menu, CES displays the Insert Object window.

![Insert Object Window]

**Figure 7-3. Insert Object Window**

To create a new attachment, select the type of object you want to create from the list on the CREATE NEW tab. To attach an existing file, click the CREATE FROM FILE tab and then click the BROWSE button to locate the file.

![CREATE FROM FILE Tab]

**Figure 7-4. CREATE FROM FILE Tab**

You can choose to link the object by clicking the Link check box. By linking the object, AASHTOWare ProjectCES will not store the document itself in the CES database, but instead store a reference to the document. Linking an object allows you to modify the
object without being logged on to CES; however, if you link to an object, the object must be stored in a location accessible to all other AASHTOWare Project users who have access to the particular entity to which the object is being linked. Otherwise, other AASHTOWare Project users will not be able to access the linked object.

After you have selected the object type from the Insert Object tab window, click OK. AASHTOWare Project displays the Add OLE Attachment window.

![Add OLE Attachment Window](image)

Click the radio button either to add the attachment to the current entity or to add to all entities. (Note: NJDOT policy is that only System Administrators should use the ‘Add to All’ feature.)

When you have finished entering information for the attachment, click the **ADD** button to add the attachment, or **CANCEL** to exit the window without adding the attachment. If you click **ADD**, CES adds a new row containing information about the new attachment to the grid on the ATTACHMENTS tab.

**Note:** After making changes to an OLE embedded document via the ATTACHMENTS tab, be sure to click the **SAVE** button or choose **Save** from the **File** menu. Otherwise, CES does not retain the changes made.

**Adding a Web Page Attachment**

When you select Add from the Edit menu and choose **URL**, CES displays the Add Web Attachment window.

![Add Web Attachment Window](image)
Enter the URL for the Web page in the text box or click CHOOSE FILE to browse for the file name.

Click the radio button to either add the attachment to the current entity or to add to all entities. (Note: NJDOT policy is that only System Administrators should use the ‘Add to All’ feature.)

When you have finished entering information for the attachment, click the ADD button to add the attachment, or CANCEL to exit the window without adding the attachment. If you click ADD, CES adds a new row containing information about the new attachment to the grid on the ATTACHMENTS tab.

Adding a Plug-In Attachment

When you select Plug-in from the menu, CES displays the Add Plug-in Attachment window.

![Figure 7-7. Add Plug-In Attachment Window](image)

You can type the command line into the text box, or click the BUILD COMMAND button to open the Build Command Line window.

![Figure 7-8. Build Command Line Window](image)
To build your command line in the Build Command Line window, first enter an executable file name by typing it into the text box, or clicking the SELECT FILE button to browse. Enter field variables into the command line by selecting from the Field Variables list and clicking the ADD button beneath the list. You can also enter any other required parameters by typing them into the Other text box and clicking the corresponding ADD button. To clear the command line at any time, click the CLEAR button.

When you have finished entering information into the command line, click OK. CES returns to the Add Plug-in Attachment window.

Click the radio button to either add the attachment to the current entity or to add to all entities. (Note: NJDOT policy is that only System Administrators should use the ‘Add to All’ feature.)

When you have finished entering information for the attachment, click the ADD button to add the attachment, or CANCEL to exit the window without adding the attachment. If you click ADD, CES adds a new row containing information about the new attachment to the grid on the ATTACHMENTS tab.

### 7.2.2 Changing an Attachment

To change the properties of an attachment, select the attachment record on the ATTACHMENTS tab and choose Change from the Edit menu or the right mouse button menu. AASHTOWare ProjectCES displays a Change Attachment window. This window contains all the information entered previously for the attachment. Enter the changes and click OK to save your changes or CANCEL to return to the ATTACHMENTS tab without saving.

### 7.2.3 Deleting an Attachment

To delete an attachment, select the attachment record on the ATTACHMENTS tab and choose Delete from the Edit menu or the right mouse button menu. AASHTOWare ProjectCES displays a Confirm Delete window. Click YES to complete the deletion or NO to return to the ATTACHMENTS tab without deleting the attachment.
8. Snapshots

A snapshot is a complete picture of an estimate job at a given time. It is like freezing the information in an estimate job and keeping it available for use, even if the information in that job later changes. The snapshot process should be used for maintaining an audit trail of an estimate and not as a replacement for saving the job.

Reasons for creating a snapshot of the project for Long Range Estimation include: change of scope, recalculation of bid-based pricing due to Bid History update, annual review, turnover to Division of Project Management, turnover to consultant from Division of Project Management, before inactivating cost group pricing to prepare for detailed estimation.

Reasons for creating a snapshot of the project for Detailed Estimation include: change of scope, recalculation of bid-based pricing due to Bid History update, refresh of cost-based pricing due to Labor, Equipment, or Material price updates, exporting a copy of the job to AASHTOWare Project Preconstruction.

Snapshots are automatically taken by the system when: Checking in to AASHTOWare Project Preconstruction, Deleting a Job, Importing Job Items from another CES job, Repricing current item tasks with default tasks, Splitting a Job. (If a job is deleted using Power Delete, no snapshot is created.)

This chapter describes how to create snapshots. Snapshots DO NOT include any attachments to the job.

After running List Job Snapshots (see Section 8.1.5), the snapshot report can be saved as text or rich text (recommended) to your local computer for your own use and record.

8.1 Maintaining Snapshots for a Job

Looking at a job’s snapshot is similar to being in View mode, but without the option of switching to Change mode. You can choose to add a snapshot, and snapshots also occur automatically at prescribed times (for instance, when you split a job or when a job is being exported to or imported from AASHTOWare Project Preconstruction).

To work with snapshots, select the appropriate job from the Jobs list window and choose Snapshots from the View or right mouse button menu. CES displays the Snapshot List window.
This window lists all the snapshots that currently exist for the selected job, if any, along with information about each snapshot such as the creator of the snapshot, the snapshot ID number, and the description of the snapshot.

**8.1.1 Adding a Snapshot**

To add a snapshot, while in the Snapshot List window, select **Add** from the **Edit** menu or the right mouse button menu. As shown in Figure 8-2, a Snapshot Description window displays.

![Figure 8-2. Snapshot Description Window](image)

Enter a description of the snapshot in the window and then click **OK** or click **CANCEL** to cancel the action.

If you click **OK**, CES once again displays the Snapshot List window, which now includes the newly added snapshot.
8.1.2 Deleting a Snapshot

To delete a snapshot, begin by selecting the snapshot from the Snapshot List window. To select more than one snapshot at a time, hold down the CTRL key as you select the snapshots. To select multiple snapshots that are adjacent to each other, select the first snapshot, then hold down the SHIFT key as you select the last snapshot. To select all the snapshots in the list window at once, choose Select All from the Edit menu.

Once the snapshot(s) to be deleted is selected, choose Delete from the Edit or right mouse button menu, or press SHIFT+DELETE. A series of Delete Warning windows will display listing the tables that will be affected by the deletion. This means you will need to confirm the deletion several times before CES will delete the data from the database. The window title bar lists the number of deletes required. An example of a Delete Warning window is shown in Figure 8-3.

![Figure 8-3. Example of Delete Warning (1 of 2) Window](Image)

If you click YES in each of the Delete Warning windows, CES will then display a final window to confirm the deletion (see Figure 8-4).

![Figure 8-4. Confirm Delete Window](Image)

To delete the snapshot currently listed, click YES. If you chose multiple snapshots to delete at once, you can click YES TO ALL to delete them simultaneously, or you can click NO to cancel the deletion of the snapshot currently listed and move on to the Confirm Delete window for the next snapshot. Click CANCEL to cancel the deletion of the remaining selected snapshots.

8.1.3 Sorting Snapshots

You can sort a snapshot by any of the column titles. To sort the snapshots, choose the column by which you want to sort, and double click the column title. The snapshots will sort in ascending order.
8.1.4 Viewing a Snapshot

To view a snapshot, select it from the Snapshot List window and double-click on it or select **Snapshot** from the **View** or the right mouse button menu. CES displays a tabbed folder window in which you can view but not modify the snapshot's information (see Figure 8-5).

![Figure 8-5. Job Snapshot Window](image)

The **GENERAL** tab of the Job Snapshot window displays the same information about the snapshot as the Snapshot List window. The other tabs that are available correspond with tabs found in the Job tabbed folder window.

8.1.5 Listing Snapshots

To produce a listing of snapshot information, begin by selecting the snapshot or snapshots for which to produce a listing in the Snapshot List window. Select **Run Process** from the **File** or right mouse button menu, and CES displays a Processes window. Select **List Job Snapshots** and click **OK** to submit a batch process to print the listing.

For information on running and viewing reports, see Chapter 9, Generating Reports.
9. Generating Reports

There are several standard reports in CES that may be found useful. This chapter describes how to generate these reports.

9.1 Generating Standard Reports

You can produce listings of information from most list windows in CES that may be printed. To do this, begin by selecting the record or records in the list window. You may choose more than one record at a time by holding down the CTRL key while selecting the records with the mouse. (This works fine for listings; however, some processes such as imports and exports can only be run for one record at a time.) To select all the records in a list window, choose Select All from the Edit menu or press CTRL+A.

Choose Run Process from the File or right mouse button menu. CES displays a Processes window with a list of processes available from the list window.

![Processes Window](image)

**Figure 9-1. Processes Window**

The list of available processes is context sensitive and is determined by the active list window. Select a process and then click **OK**. For some processes, CES will then display a window containing process options in which you enter the necessary information for the process. When you finish selecting options, click **SUBMIT** to run the process, **PARAMETERS** to change process submission parameters, or **CANCEL** to return to the list window without running the process.

If the process did not have options, CES would display this window.

![Confirm Process Submission](image)

**Figure 9-2. Confirm Process Submission Window**

You can click **SUBMIT** to run the process, **PARAMETERS** to specify process submission parameters, or **CANCEL** to return to the list window without running the process.
9.1.2 Specifying Process Submission Parameters

If you click the PARAMETERS button in the Confirm Process Submission window, CES displays a Process Submission Parameters window.

Important: Most NJDOT and consultant users should never have to change any Process Submission Parameters.

Many fields in this window have default values that specify printer destination, queues, and so forth. At a minimum, these fields must have a value:

**Process Name**
- Defaults to the process name and a character that CES appends to tell processes apart.

**Priority**
- You may choose high, medium, or low priority. There will not usually be enough jobs running at the same time for this to have any impact.

**Schedule**
- Allows you to set the frequency and time for the process to run.

**RTF Library**
- Defaults to the value set for individual users. Do not change this unless you know what you are doing.

**Produce RTF Log**
- If you want the RTF log to be produced, select this check box.

**Print Output**
- Please do not use this option unless directed by the CES.

**Files**
- System Manager. Use the default “Keep Process Files” and print after viewing the resulting output. (See Section 9.3.)

If directed to use this option, click in the Print Output Files check box. Specify the printer name, the number of copies, the paper orientation, and whether you want the printout to be in
duplex form (two-sided). If you check the Print Output Files box, your output will print on the specified network printer.

**Keep Process Files**
If you want the output held so you can view it online or print it later to a different printer, you can click in the Keep Process Files check box. This is the preferred option for NJDOT and consultants, and is the system default.

**E-Mail Output To**
This feature is not enabled for NJDOT.

**Mode**
Defaults to Production. Do not use Debug unless the CES System Manager tells you to. This mode generates a detailed log of the batch program for problem determination.

When you finish entering information in the fields, click **OK** to return to the Confirm Process Submission window or click **CANCEL** to return to the list window without running the process.

### 9.1.2 Running the Process
If you click **SUBMIT** in the Confirm Process Submission window, AASHTOWare Project CES runs the process. If AASHTOWare Project CES encounters a problem when running the process, it displays an error message. You will have to fix the problem before you can run the process successfully.

When the application server finishes executing a process, it will send a message to the computer from which you ran the process that indicates the success or failure of the process. A message box will display this information.

The CES Process Status List displays a list of all processes you run. You will not be able to view other user’s output (see Section 9.3).

### 9.2 List Reports
CES provides the following list reports that may be generated. The security associated with your CES user ID determines which reports you can run.

#### 9.2.1 Job Detail Estimate
The Job Detail Estimate process lists detailed information about the selected jobs and estimate-related information, including header information, associated cost groups, funding packages, items, and detailed item task information.

#### 9.2.2 List Jobs
The List Jobs process lists detailed information about the selected jobs, including header information, associated programs, cost groups, items, variables, and funding packages.

#### 9.2.3 List Job Snapshots
The List Job Snapshots process lists detailed information about the snapshots for the selected jobs, including header information, associated cost groups, items, item task information, variables, and funding packages.

#### 9.2.4 List Labor
The List Labor process lists detailed information about the selected laborers, including header information and associated wage rates.
9.2.5 List Equipment
The List Equipment process lists detailed information about the selected equipment, including header information and associated rates.

9.2.6 List Materials
The List Materials process lists detailed information about the selected materials, including header information and associated prices.

9.2.7 List Cost Sheets
The List Cost Sheets process lists detailed information about the selected cost sheets, including header information, associated laborers, associated materials, and associated equipment.

9.2.8 List Crews
The List Crews process lists detailed information about the selected crews, including header information, associated laborers, and associated equipment.

9.2.9 List Formula Libraries
The List Formula Libraries process lists detailed information about the selected formula libraries, including header information and associated formulas.

9.2.10 List Programs
The List Programs process lists detailed information about the selected programs, including header information, associated jobs, and the program total.

9.2.11 List Cost Groups
The List Cost Groups process lists detailed information about the selected cost groups, including header information, associated variables, and associated items.

9.3 Process Status
To view the status of processes you run, select Process Status from the File menu. AASHTOWare Project CES displays a Process Status List window. This window contains a list that includes all the processes you have submitted that are currently running (which only users with security tokens to do so can delete), queued for processing (the system still has to run the processes but you can delete them), and completed (waiting for you to view, print, save, or delete the output).
If you double-click on a process that has completed, CES displays a list of files the process generated. You can choose to print individual files on a local printer, view the files on screen, store the files so you can process them later, or delete the files.

It is a good practice to limit the number of jobs you keep on your Process Status List. You may save the output (see Section 9.3.4) to your computer and then delete the job from the window by highlighting the job and choosing **Delete** from the right mouse button. Click **YES** to confirm the delete.

The Process Status window contains a grid, which functions just like grids in tabbed folder windows. You can resize columns by dragging the column border, and re-order columns by selecting the header and dragging the entire column. You can also sort the rows in the grid quickly by double-clicking on any column header.

### 9.3.1 Working with Process Output Files

You can view and print any file that is generated by a process, including reports, error reports, or process logs. You can also save output files (except PDF files) in either text or rich text format.

### 9.3.2 Viewing Process Output Files

Follow these steps to view an output file:

1. Select **Process Status** from the **File** menu to open the Process Status List window.
2. Select the process name from the list and choose **Process Files** from the right mouse button menu. AASHTOWare Project displays a window listing all the files generated for the process.
3. Select the output file you want to view and choose **View File** from the right mouse button menu. AASHTOWare Project displays a window containing the formatted output.

**Note**: To view PDF files, a version of Adobe Acrobat Reader must be installed. Otherwise, a message will appear warning that the file cannot be viewed.

---

![Figure 9-5. Files for Process Window](image)

**Figure 9-5. Files for Process Window**

![Figure 9-6. Viewing Output Files](image)

**Figure 9-6. Viewing Output Files**
9.3.3 Printing Process Output Files

You can print an output file (except those in PDF format) from the File Viewer window by clicking the PRINT button, or from the Process Output list window by choosing Print from the right mouse button menu. AASHTOWare Project displays a Print option window.

![Print Option Window](image)

**Figure 9-7. Print Option Window**

Click PRINT to print the output file on the current printer, PRINTER SETUP to change your printing options, or CANCEL to return to the File Viewer window without printing.

You must print PDF files through the Adobe Acrobat Reader. Clicking Print in the File Viewer window will produce the following message.

![Information Window](image)

**Figure 9-8. Information Window**

9.3.4 Saving Process Output Files

You can save process output to a text file (.txt) or, if you want to save the attribute codes with the text, you can save the output to a rich text file (.rtf). The rich text file can be opened and edited in Microsoft Word.

From the Files for Process list window, you can save an output file to your computer by selecting the file and choosing Save As from the right mouse button menu.

From the File Viewer window, you can save an output file to your computer by clicking the SAVE AS TEXT button or the SAVE AS RICH TEXT button.
10. Maintaining CES Lists and Reference Tables

In this chapter you will learn how to maintain AASHTOWare Project CES lists and reference tables. The security role associated with your CES user ID will determine which lists you may access. There may be lists or tables that are unavailable because you do not have security privileges to view them, or you may have view-only access.

It is NJDOT policy that consultants and NJDOT users should never change or delete any standard Cost Sheets or Labor, Equipment, and Material data entered by another user. You may apply any standard Cost Sheets or Labor, Equipment, and Material data from the lists to a job estimate, and change them in the individual job.

Tip: Users not wishing to share their Cost Sheets with other users may set up a template job, add new cost sheets to items, and copy the cost sheets into new jobs from the template job.

10.1 Lists

This section focuses on the Cost Sheet List.

To view this list, select Cost Sheet List from the File menu.

![Figure 10-1. AASHTOWare Project CES File Menu](image)

10.1.1 Cost Sheet List

When you are working on the ITEMS tab of the Job tabbed folder window using the tree view, an option is available from the Edit menu to add a standard (or default) cost sheet to the current job from CES’s list of standard cost sheets. To maintain this standard cost sheets list, choose Cost Sheet List from the File menu, and CES displays the Cost Sheet List window.
Adding and Changing Default Cost Sheets

To add a cost sheet to the Cost Sheet List, select Add from the Edit or right mouse button menu, or press the INSERT key. CES displays the Select Spec Year window.

Select the appropriate spec year for the cost sheet and click OK, or click CANCEL to cancel the action.

If you click OK, CES displays the GENERAL tab of the Add Cost Sheet window.
The fields displayed in teal mean that the value for the field can be determined using a formula. Double click in the field to bring up the Formula and Expression Builder window. To create a complete record, enter information in these fields on the GENERAL tab:

- **Cost Sheet ID** An identifier for the cost sheet.
- **Description** A short description of the cost sheet.
- **Production Rate** The rate of production for the selected item per day. (The selected item refers to the item chosen when the standard cost sheet being defined is copied to the Job tabbed folder Items window.) This number is used to determine the unit price for the task.
   
   This field may be left blank and entered when the cost sheet is attached to an item in a Job, since production rate will generally vary according to the job specifications. Or it may be entered in the standard cost sheet and edited at the Job level.

- **Hours Per Day** The number of hours per day that the crew is expected to work. This number is used to determine the labor and equipment costs as well as the unit price for the task. Tip: Workers may have to be paid for eight hours per day even though their actual access to the job site may be limited to fewer.

- **Overtime Hours Per Day** The number of overtime hours per day that the crew is expected to work. This number is used to determine the labor and equipment costs as well as the unit price for the task.
| **Unit** | The unit by which the selected cost sheet is measured. Enter a unit or click the down arrow beside the field to display a drop-down list from which to select a unit. |
| **Markup Percentage** | The percentage of the total expenses for the cost sheet task that is being set aside to cover unforeseen occurrences. This number is used to determine the unit price for the task. |
| **Labor Overhead Percentage** | The percentage of the labor expenses for the cost sheet task that is being set aside to cover unforeseen occurrences. This number is used to determine the labor costs as well as the unit price for the task. |
| **Equipment Overhead Percentage** | The percentage of the equipment expenses for the cost sheet task that is being set aside to cover unforeseen occurrences. This number is used to determine the equipment costs as well as the unit price for the task. |
| **Materials Overhead Percentage** | The percentage of the material expenses for the cost sheet task that is being set aside to cover unforeseen occurrences. This number is used to determine the material costs as well as the unit price for the task. |

**Labor Tab**

To enter labor information for the cost sheet being added, click the **LAbOR** tab. A column with a white heading means that the value for the field can be determined using the Formula and Expression Builder window (see Chapter 11).

![Figure 10-5. Add Cost Sheet Window—LAbOR Tab](image-url)
Adding Laborers to the Cost Sheet

When there are no laborers currently listed on the LABOR tab (see Figure 10-5), you will need to begin either by adding a row in which to enter a single laborer or by adding a predefined work crew. To add a single laborer, select Add from the Edit or right mouse button menu to display a row in which to add labor information.

![Figure 10-6. Add Cost Sheet Window-LABOR Tab With a Blank Data Entry Row](image)

For each additional laborer added, you will also need to insert a blank row; otherwise, CES will overwrite the information in the currently selected row. When you insert a row by choosing Add from the Edit or right mouse button menu, the row will be placed beneath all the other existing rows. To place the row elsewhere in the list, highlight the row above which to place the pricing row, and select Insert instead of Add. These fields can be edited in the data entry grid:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Laborer ID</td>
<td>An identifier for the laborer. Enter a laborer ID, or click the down arrow at the bottom of the tab to display the Labor window from which to select a laborer.</td>
</tr>
<tr>
<td>Description</td>
<td>A short description of the laborer. This information is automatically brought in if you add a laborer using the Labor window.</td>
</tr>
<tr>
<td>Quantity</td>
<td>The number of persons expected to work in the capacity of the selected laborer.</td>
</tr>
</tbody>
</table>

The Crew ID field is used when a predefined work crew is added to the LABOR tab. Unlike adding an individual laborer, if you want to add a predefined work crew, it is not necessary to insert a blank row beforehand. When you add a labor crew in CES, the information for that crew is automatically placed beneath the last row in the list. If no rows exist, CES simply makes some to accommodate all the necessary information.
To insert a labor crew, select **Insert Crews** from the **Edit** or right mouse button menu. A Select Crews window will display.

![Select Crews Window](image)

**Figure 10-7. Select Crews Window**

Select the crew or crews to insert. To choose more than one crew at a time, hold down the **CTRL** key while selecting the crews. To select several crews that are adjacent to each other, select the first crew and then hold down the **SHIFT** key as you select the last crew to be chosen. All the crews to be inserted will be highlighted.

Once you have chosen the crew(s) to insert, click **OK** or click **CANCEL** to cancel the action. If you click **OK**, the selected crew(s) will display on the **LABOR** tab.

![Add Cost Sheet Window-LABOR Tab With a Labor Crew](image)

**Figure 10-8. Add Cost Sheet Window-LABOR Tab With a Labor Crew**

The Crew ID field identifies the crew ID for laborers who are inserted as part of a crew. You can edit the inserted crew rows just as you would any other rows.
**Material Tab**

To enter material information for the cost sheet being added, click the `MATERIAL` tab. A column with a white heading means that the value for the field can be determined using the Formula and Expression Builder window.

![Figure 10-9. Add Cost Sheet Window—MATERIAL Tab](image)

**Adding Materials to the Cost Sheet**

When there are no materials currently listed on the `MATERIAL` tab (see Figure 10-9), you will need to begin by adding a row in which to enter material information. To do this, select **Add** from the **Edit** or right mouse button menu to display a row in which to add material information.

![Figure 10-10. Add Cost Sheet Window—MATERIAL Tab With a Blank Data Entry Row](image)
For each additional material added, you will also need to insert a blank row; otherwise, CES will overwrite the information in the currently selected row. When you insert a row by choosing Add from the Edit or right mouse button menu, the row will be placed beneath all the other existing rows. To place the row elsewhere in the list, highlight the row above which to place the pricing row, and select **Insert** instead of Add. These fields can be edited in the data entry grid:

- **Material Number**
  A unique number or alphanumeric that identifies the material. Enter a material number, or click the down arrow at the bottom of the tab to display the Materials window from which to select a material.

- **Description**
  A short description of the material. This information is automatically brought in if you add a material using the Materials window.

- **Quantity**
  The total amount of material (total number of material units) for the cost sheet task.

**Equipment Tab**

To enter equipment information for the cost sheet being added, click the EQUIPMENT tab. A column with a white heading means that the value for the field can be determined using the Formula and Expression Builder window.

![Figure 10-11. Add Cost Sheet Window—EQUIPMENT Tab](image)

**Adding Equipment to the Cost Sheet**

When there is no equipment currently listed on the EQUIPMENT tab (see Figure 10-11), you will need to begin either by adding a row in which to enter a single piece of equipment or by adding the equipment that is associated with a predefined work crew.
To add a single piece of equipment, select **Add** from the **Edit** or right mouse button menu to display a row in which to add equipment information.

For each additional piece of equipment added, you will also need to insert a blank row; otherwise, CES will overwrite the information in the currently selected row. When you insert a row by choosing Add from the Edit or right mouse button menu, the row will be placed beneath all the other existing rows. To place the row elsewhere in the list, highlight the row above which to place the pricing row, and select **Insert** instead of Add. These fields can be edited in the data entry grid:

- **Equipment ID**: An identifier for the equipment. Enter an equipment ID, or click the down arrow at the bottom of the tab to display the Equipment window from which to select a piece of equipment.

- **Description**: A short description of the equipment. This information is automatically brought in if you add a piece of equipment using the Equipment window.

- **Quantity**: The total amount (number of pieces) of equipment for the cost sheet task.

Unlike adding an individual piece of equipment, if you want to add the equipment associated with a predefined work crew on the EQUIPMENT tab, it is not necessary to insert a blank row beforehand. When you add a work crew in CES, the equipment information for that crew is automatically placed beneath the last row on the EQUIPMENT tab. If no rows exist, CES simply makes some to accommodate all the necessary information.

To insert a work crew, select **Insert Crews** from the **Edit** or right mouse button menu. A Select Crews window will display (see Figure 10-7). Select the crew or crews to insert. To choose more than one crew at a time, hold down the **CTRL** key while selecting the crews. To select several crews that are adjacent to each other, select the first crew and then...
hold down the SHIFT key as you select the last crew to be chosen. All the crews to be inserted will be highlighted.

Once you have chosen the crew(s) to insert, click OK or click CANCEL to cancel the action. If you click OK, the equipment information for the selected crew(s) will display on the EQUIPMENT tab.

Figure 10-13. Add Cost Sheet Window—EQUIPMENT Tab With Work Crew Equipment

The Crew ID field identifies the crew ID for the equipment that is inserted as part of a crew. You can edit the inserted equipment crew rows just as you would any other rows.

**Listing Default Cost Sheets**

To produce a listing of default cost sheets, select the cost sheet or cost sheets for which you want to produce a listing and choose Run Process from the File or right mouse button menu. CES displays a Processes window. Select List Cost Sheets and click OK to submit a batch process to print the listing. See Chapter 9 for more information.

**10.2 Reference Tables**

In this section you will learn how to maintain the AASHTOWare Project reference tables that CES uses during processing. To view a list of these tables, select Reference Tables from the File menu.
10.2.1 Materials List

If you choose Material List from the Reference Tables submenu, CES displays the Materials list window.
Adding and Changing Materials

To add information about a material to the Material List reference table, select Tabbed Folder Add from the Edit or right mouse button menu, or press the INSERT key. CES displays the GENERAL tab of the Add Material tabbed folder window.

![Add Material Window-GENERAL Tab](image)

Figure 10-16. Add Material Window-GENERAL Tab

To create a complete record, enter information in these fields on the GENERAL tab:

- **Material Number**: A unique number or alphanumeric that identifies the material.
- **Spec Year**: The specification year for the material.
- **Description**: A short description of the material.
- **Unit of Material**: The unit of measurement for the material. Enter a unit or click the down arrow beside the field to display a drop-down list from which to select a unit.
- **Material Kind**: The kind of material. Enter a material kind or click the down arrow beside the field to display a drop-down list from which to select a material kind.

To enter pricing information about the material being added, click the PRICES tab.
Figure 10-17. Add Material Window–PRICES Tab

On this tab you can assign different prices for the material based on the rate class that is selected.

When there are no prices currently listed on the PRICES tab (see Figure 10-17), you will need to begin by choosing Add from the Edit or right mouse button menu to display a row in which to add pricing information.

Figure 10-18. Add Material Window–PRICES Tab With a Blank Data Entry Row

For each additional price added, you will also need to insert a blank row. When you insert a row by choosing Add from the Edit or right mouse button menu, the row will be placed beneath all the other existing rows. To place the row elsewhere in the list, highlight the
row above which to place the row, and select **Insert** instead of Add. Enter information in these two fields to complete the **PRICES** tab:

**Rate Class**
The rate class for the material. Enter a rate class or click the down arrow beside the field to display a drop-down list from which to select a rate class.

**Unit Price**
The unit price for the material at the selected rate class.

Click **SAVE** or select **Save** from the **File** menu to save your work.

To change an existing material in the Material List reference table, select that material from the Materials list window and choose **Tabbed Folder Change** from the **Edit** or right mouse button menu. CES displays the Material window. You can add information to or change any field except Material Number and Spec Year.

Reminder: It is NJDOT policy that consultants and NJDOT users should never change or delete any standard Cost Sheets or Labor, Equipment and Material data entered by another user.

**Listing Materials**
To produce a listing of material information, begin by selecting the material or materials for which to produce a listing in the Materials list window. Select **Run Process** from the **File** or right mouse button menu, and CES displays a Processes window. Select **List Materials** and click **OK** to submit a batch process to print the listing. See Chapter 9 for more information.

**10.2.2 Labor List**
If you choose **Labor List** from the **Reference Tables** submenu, CES displays the Labor List window.

![Figure 10-19. Labor List Window](image-url)
**Adding and Changing Laborers**

To add information about a laborer to the Labor List reference table, select **Add** from the **Edit** or right mouse button menu, or press the **INSERT** key. CES displays the **GENERAL** tab of the Add Laborer window.

![Figure 10-20. Add Laborer Window—GENERAL Tab](image)

To create a complete record, enter information in these fields on the **GENERAL** tab:

- **Laborer ID** — A unique number or alphanumeric that identifies the laborer.
- **Description** — A short description of the laborer.

To enter wage information about the laborer being added, click the **WAGES** tab.

![Figure 10-21. Add Laborer Window—WAGES Tab](image)
On this tab you can assign different wages for the laborer based on the rate class that is selected.

When there are no wages currently listed on the WAGES tab (see Figure 10-21), you will need to begin by choosing Add from the Edit or right mouse button menu to display a row in which to add wage information.

![Figure 10-22. Add Laborer Window—WAGES Tab With a Blank Data Entry Row](image)

For each additional wage added, you will also need to insert a blank row. When you insert a row by choosing Add from the Edit or right mouse button menu, the row will be placed beneath all the other existing rows. To place the row elsewhere in the list, highlight the row above which to place the row, and select Insert instead of Add. Enter information in these fields (as applicable) to complete the WAGES tab:

- **Rate Class**: The rate class for the laborer. Enter a rate class or click the down arrow beside the field to display a drop-down list from which to select a rate class.
- **Davis-Bacon Rate**: The hourly Davis-Bacon rate of pay for the laborer.
- **Davis-Bacon Overtime Rate**: The hourly Davis-Bacon overtime rate of pay for the laborer.
- **Non Davis-Bacon Rate**: The hourly non-Davis-Bacon rate of pay for the laborer.
- **Non-Davis-Bacon Overtime Rate**: The hourly non-Davis-Bacon overtime rate of pay for the laborer.

To change an existing laborer in the Labor List reference table, select that laborer from the Labor List window and choose Change from the Edit or right mouse button menu.
Maintaining CES Lists and Reference Tables

10.1 CES displays the Laborer window. You can add information to or change any field except Laborer ID.

Reminder: It is NJDOT policy that consultants and NJDOT users should never change or delete any standard Cost Sheets or Labor, Equipment and Material data entered by another user.

Click save or select Save from the File menu to save your work.

Listing Laborers

To produce a listing of laborer information, begin by selecting the laborer or laborers for which to produce a listing in the Labor List window. Select Run Process from the File or right mouse button menu, and CES displays a Processes window. Select List Labor and click OK to submit a batch process to print the listing.

10.2.3 Equipment List

If you choose Equipment List from the Reference Tables submenu, CES displays the Equipment List window.

Adding and Changing Equipment

To add information about equipment to the Equipment List reference table, select Add from the Edit or right mouse button menu, or press the INSERT key. CES displays the GENERAL tab of the Add Equipment window.
To create a complete record, enter information in these fields on the GENERAL tab:

**Equipment ID**  
A unique number or alphanumeric that identifies the equipment.

**Description**  
A short description of the equipment.

To enter rate information about the equipment being added, click the RATES tab.

On this tab you can assign different rates for the equipment based on the rate class that is selected.
When there are no rates currently listed on the RATES tab (see Figure 10-25), you will need to begin by choosing Add from the Edit or right mouse button menu to display a row in which to add rate information.

For each additional rate added, you will also need to insert a blank row. When you insert a row by choosing Add from the Edit or right mouse button menu, the row will be placed beneath all the other existing rows. To place the row elsewhere in the list, highlight the row above which to place the row, and select Insert instead of Add. Enter information in these two fields to complete the RATES tab:

**Rate Class**  
The rate class for the equipment. Enter a rate class or click the down arrow beside the field to display a drop-down list from which to select a rate class.

**Equipment Rate**  
The hourly rate for use of the equipment.

To change an existing piece of equipment in the Equipment List reference table, select that piece of equipment from the Equipment List window and choose Change from the Edit or right mouse button menu. CES displays the Equipment window. You can add information to or change any field except Equipment ID. Reminder: It is NJDOT policy that consultants and NJDOT users should never change or delete any standard Cost Sheets or Labor, Equipment, and Material data entered by another user.

Click SAVE or select Save from the File menu to save your work.

**Listing Equipment**

To produce a listing of equipment information, begin by selecting the equipment for which to produce a listing in the Equipment List window. Select Run Process from the File or right mouse button menu, and CES displays a Processes window. Select List Equipment and click OK to submit a batch process to print the listing. See Chapter 9 for more information.
10.2.4 Crew List

If you choose **Crew List** from the **Reference Tables** submenu, CES displays the Crew List window.

![Figure 10-27. Crew List Window](image)

**Adding and Changing Crews**

To add information about a crew to the Crew List reference table, select **Add** from the **Edit** or right mouse button menu, or press the **INSERT** key. CES displays the **GENERAL** tab of the Add Crew window.

![Figure 10-28. Add Crew Window-GENERAL Tab](image)
To create a complete record, enter information in these fields on the GENERAL tab:

**Crew ID**
A unique number or alphanumeric that identifies the crew.

**Description**
A short description of the crew.

To enter labor information about the crew being added, click the LABOR tab.

On this tab you can assign different laborers in various quantities to the crew.

When there are no laborers currently listed on the LABOR tab (see Figure 10-29), you will need to begin by choosing Add from the Edit or right mouse button menu to display a row in which to add labor information.
For each additional laborer added, you will also need to insert a blank row. When you insert a row by choosing Add from the Edit or right mouse button menu, the row will be placed beneath all the other existing rows. To place the row elsewhere in the list, highlight the row above which to place the row, and select Insert instead of Add.

Enter information in these two fields to complete the LABOR tab (the description field is automatically filled in once the Laborer ID is chosen):

**Laborer ID**  
A unique number or alphanumeric that identifies the laborer. Enter a laborer ID or click the down arrow at the bottom of the tab to display the Labor window from which to select a laborer.

**Quantity**  
The total number of persons expected to work in the capacity of the selected laborer.

To enter equipment information about the crew being added, click the EQUIPMENT tab.

Figure 10-30. Add Crew Window-LABOR Tab With a Blank Data Entry Row
On this tab you can assign different pieces of equipment in various quantities to the crew.

When there is no equipment currently listed on the EQUIPMENT tab (see Figure 10-31), you will need to begin by choosing Add from the Edit or right mouse button menu to display a row in which to add equipment information.

For each additional piece of equipment added, you will also need to insert a blank row. When you insert a row by choosing Add from the Edit or right mouse button menu, the
row will be placed beneath all the other existing rows. To place the row elsewhere in the list, highlight the row above which to place the row, and select Insert instead of Add.

Enter information in these two fields to complete the EQUIPMENT tab (the description field is automatically filled in once the Equipment ID is chosen):

**Equipment ID**
A unique number or alphanumeric that identifies the piece of equipment. Enter an equipment ID or click the down arrow at the bottom of the tab to display the Equipment window from which to select a piece of equipment.

**Quantity**
The total amount (number of pieces) of equipment for the crew.

To change an existing crew in the Crew List reference table, select that crew from the Crew List window and choose Change from the Edit or right mouse button menu. CES displays the Crew window. You can add information to or change any field except Crew ID.

Reminder: It is NJDOT policy that consultants and NJDOT users should never change or delete any standard Cost Sheets or Labor, Equipment, and Material data entered by another user.

Click SAVE or select Save from the File menu to save your work.

**Listing Crews**
To produce a listing offcrew information, begin by selecting the crew or crews for which to produce a listing in the Crew List window. Select Run Process from the File or right mouse button menu, and CES displays a Processes window. Select List Crews and click OK to submit a batch process to print the listing. See Chapter 9 for more information.
11. Formulas and Formula Libraries

In CES, a field label with teal lettering or a column title with white lettering may be populated using a formula. For example, on a Long-Range estimate, the quantity in tons of asphalt could be calculated using a formula based on road length, width, depth and the specific gravity of the asphalt. For detailed estimation, the price for a lump sum item, or a price adjustment based on length of the job could be calculated using formulas. This chapter describes how to create formulas.

11.1 Creating Formulas in a Job

For help in creating a formula you may use the Formula and Expression Builder. It may be accessed by double-clicking on any of the formula-enabled fields in the job, or by right clicking in the field and selecting Formula and Expression Builder from the menu. CES displays the Formula and Expression Builder Window.

In the Formula and Expression Builder window, only the Description and Expression fields accept user input. You can create a formula or variable for the library using the Formula Library List available from the File menu. You can also create a variable using the VARIABLES tab on the Job tabbed folder window. The other fields are filled in by CES.

The field, tables, and buttons are described as follows:

**Description** (Expression)  A description of the expression or formula being built.

![Figure 11-1. Formula and Expression Builder Window](image-url)
Result
Used with the VALIDATE button, the Result field displays the result of the valid expression. If an expression is invalid, the Result field remains blank.

Expression
The formula being built. The expression can use the Columns/Functions list to help build the equation, previously created expressions from the Formula Library List, or values can be entered manually. The result of the evaluated field appears in the field for which the expression is being built.

Library
The Library field corresponds to the Formula Library List. If you choose a library from the drop down list, then the formulas in that library display in the table. If you double click on a formula or variable in the table, the formula appears in the Expression field.

Columns/Functions
The Columns/Functions field offers an extensive listing of common formula-building functions and expressions columns or functions related to the category selected from the drop down list. For example, if you select Conditional from the drop down list, then you can choose to use equations like if-then- else or other conditional statements. If you select Job Columns from the drop down list, then you can choose the value of fields listed on the GENERAL tab of the Job tabbed folder window to include in your expression. If you select Job Variables, then any variables that were created on the VARIABLES tab for the job appear.

Status
A list of eight errors, one of which displays if the expression fails validation. If the expression is valid, then the status is *OK.

Description (Status)
A brief description of the message in the Status field.

Message
A longer description of the message in the Status field.

Validate Button
When you click the VALIDATE button, CES validates the formula in the Expression field to ensure the syntax is correct and it will return a value. Results of the validation appear in the Status field.

OK Button
If the expression is valid, when you click OK, the value of the expression appears in the field for which the expression was built.

CANCEL Button
When you click CANCEL, CES returns to the previously active window.

11.1.1 Formula Example
As an example of a CES formula in action, consider that NJDOT’s database contains a primary county named “Monmouth” and that the code for Monmouth County is “C017.” If
you wanted to produce a formula that would check to see if the county for the job is Monmouth, and if it were, the conceptual estimate for the job would be set at 350000 instead of 330000, your formula would look like this:

\[
\text{if(PRI\text{M}ARYCOUNTY='C017',350000,330000)}
\]

CES interprets this formula (roughly speaking) as follows:

If the primary county for the job is C017 (which is Monmouth), then the value in this field (the Conceptual Estimate field) will be 350000; else the value in this field will be 330000.

### 11.2 Using Formulas

To insert a formula into a formula-enabled field either double-click in the field or select Formula and Expression Builder from the right mouse button menu to display the Formula and Expression Builder Window. To use the Formula and Expression Builder, locate and select a formula that you have already created from the Library or build a new formula. Click OK to insert the formula, and CES evaluates the formula to derive a value for the field.

If you prefer, you may simply type a formula into the field. Or you may copy and paste an existing formula that you have stored in a text file outside of CES. Hold down the Control key and press c to copy, then hold down the Control key and press v to paste the formula in the field. You can check the formula by double-clicking on the field, and then clicking on VALIDATE.

As a time-saver, you may also use formula-enabled fields to do simple math calculations. For example, if you type 4*2 in the field, then tab out of the field, CES will do the multiplication and return a value of 8.

### 11.2.1 Formula Library List

Commonly used formulas may be pre-defined in the Formula Library List and then selected in the Expression Builder window when creating an estimate.

Formulas added to the Formula Library List are accessible to all users of CES. It is NJDOT policy that users may not change or delete formulas in the library that were created by other users, since any change will impact all users. Since the system does not control user ownership of formulas, any formulas selected from the library should be reviewed for accuracy when using them in an estimate.

Formulas may be modified in an estimate.

Tip: Users who do not wish to share their formulas may store them in a text file on their computers, and copy and paste them into their estimates as needed. Note you may experience difficulty if you store your formulas in a word-processing document or other format that may add hidden code.

To access the Formula Library List window select Formula Library List from the File menu. CES displays the Formula Library List window.
Adding and Changing Default Formula Libraries

To add a default formula library to the Formula Library List, select Add from the Edit or right mouse button menu, or press the INSERT key. CES displays the GENERAL tab of the Add Formula Library window.

General Tab

To create a complete record, enter information in these fields on the GENERAL tab:
**Library Name**
A unique descriptive identifier of the formula library.

**Description**
A short (40 characters) description of the formula library. This may identify the functions of the formulas, the type of items or data they apply to, or the user or firm that created them.

**Formulas Tab**
To add formulas to the new formula library, click the FORMULAS tab.

![Figure 11-4. Add Formula Library Window-FORMULAS Tab](image)

On this tab you can assign different formulas to the formula library. When there are no formulas currently listed on the FORMULAS tab (see Figure 11-4), you will need to begin by choosing **Add** from the **Edit** or right mouse button menu to display a row in which to add formula information.
Figure 11-5. Add Formula Library Window—FORMULAS Tab With a Blank Data Entry Row

For each additional formula added, you will also need to insert a blank row; otherwise, CES will overwrite the information in the currently selected row. When you insert a row by choosing Add from the Edit or right mouse button menu, the row will be placed beneath all the other existing rows. To place the row elsewhere in the list, highlight the row above which to place the pricing row, and select **Insert** instead of Add. These fields can be edited in the data entry grid:

- **Name**
  The designation that identifies the formula or expression. The value entered must begin with a letter, cannot contain any spaces, and can consist of letters, numbers, and underscores (_).

- **Expression**
  The actual formula or expression being added to the formula library.

- **Description**
  A short description of the formula or expression.

To change an existing standard formula library, select that library from the Formula Library List window and choose **Change** from the Edit or right mouse button menu. CES displays the Formula Library window in which you can alter any of the fields except Library Name. Any formula entered will not be accessible until you save your work.

**Reminder:** It is NJDOT policy that users may not change or delete formulas in the library that were created by other users.

Click **SAVE** or select **Save** from the **File** menu.
12. Passing Final CES Estimate to AASHTOWare Project Preconstruction

Once the final estimate has gone through all last-minute changes and is ready for advertisement, it must be passed to AASHTOWare Project Preconstruction by NJDOT staff. This chapter describes the steps necessary to export a job from CES and import it into AASHTOWare Project Preconstruction.

12.1 Export Final CES Estimate to AASHTOWare Project Preconstruction

Export CES Job to Precon

- Highlight job.
- Right Click the mouse button.
- Select Run Process....
- Select Export Job to web Trns.port Project, click ok.
- Your web Trns.port User ID should be NJDOT\TPE***.
- Your web Trns.port Password is what you log into WebT with.
- Ensure that your CES job is the one shown, then change the web Trns.port Project ID to the DP #.
- Leave the Update Behavior options as they are.
- Select Submit.

YOUR JOB HAS NOW BEEN MOVED INTO WEB-PRECON PROJECT.

12.2 Verify That All Necessary Data Fields Have Been Filled In

There are some important data fields that may not be passed in the export/import process, or may not have been populated in the CES Job, or may have changed since the CES job was created.

Click Project under Project Overview, find your Project, click on it and under Project Summary lease check that all Project fields are correctly populated, especially those indicated in italics in the charts below.

The tabs contain general information fields used for identifying the project on this page. To update a complete record, enter information in these fields:

**GENERAL**

**UPC Number**

Not required on Maintenance projects.

**Federal/State Project Number**

Maintenance and CPM should enter STATE if the project is 100 percent state funded. However, if there is federal funding and a Federal Project Number, it should be entered.

**Spec Year**

Select Spec year from drop-down menu.

**Project Description**

This description should match the name of the project as listed on the plans, key sheet, and advertising memo. ASHTOWare Project prints on most project reports. (maximum 120 characters).
**Unit System**
This field will default to E (English).

**Road Name**
The name of the primary road on which project work is being performed. If the work is being performed on various roads or Statewide enter Various or Statewide.

**Project Work Type**
Select work type from the drop-down menu. Pages 3-2 thru 3-4 identify and define work types.

**Project Item Total**
This field will carry over from CES.

**Reviewed By**
Select reviewer or estimator’s name from the drop-down menu.

**Date of Estimate**
Enter today’s date. Date can be entered using the calendar or by manually entering it.

**Revised by**
If revisions have been made, enter the name of the person making the revisions.

**Controlling Project**
This field should be unchecked.

**Urban/Rural Class**
Select Urban or Rural. This is a required field.

**COUNTY**

**County or Cong. Dist. Code**
A code value indicating that the project will perform work in that county. Choose a code from the drop-down menu.

**County Name**
This will be automatically populated when you select the county code.

**Percent of Project Length**
The approximate percentage of the length of the project that lies within this county. If the project is checked out to CES, the county with the highest percentage will be used for estimation. The latitude and longitude of the project midpoint should fall within the county with the highest percentage.

**DISTRICT**

**District**
Select the District ID where a project or contract is located (maintenance/4 or construction/1) from the drop-down menu. (N1 – N4 / C1 – C4) this is what is used in the search filed. “Primary” should be set checked.

**POINTS**

**Longitude of Midpoint**
The longitude of the midpoint of construction. For Statewide projects use 0743842. For regional projects use the following: North, 0743758; South, 0750245; Central,
0741533; and HQ, 0744828. If the project is not Statewide or Regional use the actual midpoint longitude of construction. The coordinate entered MUST be within the first county selected in the COUNTY tab.

**Latitude of Midpoint**

The latitude of the midpoint of construction. For Statewide projects use 401101. For regional projects use the following: North, 405402; South, 395533; Central, 401423; and HQ, 401530. If the project is not Statewide or Regional use the actual midpoint latitude of construction. The coordinate entered MUST be within the first county selected in the COUNTY tab.

**ROAD SECTIONS**

**Beginning Station**

Description must be “Primary”

This field lets you define more precisely where the work for this project is taking place. This data is passed to BAMS/DSS for pinpointing the projects on maps.

**Ending Station**

This field lets you define more precisely where the work for this project is taking place.

Click on “Categories and Items” You are now on the PROJECT CATEGORY AND ITEM SUMMARY PAGE

Please check that all Category fields are correctly populated

**GENERAL**

The information here is the same general information as under “Project Summary”.

**CATEGORIES**

**Category Number**

A four digit unique identifier for a project category. Start with 0001 and number consecutively by ones.

**Category Description**

Roadway or Bridge, etc. This is a required field.

**Combine with Like Categories**

Once all the fields have been checked you can then notify Federal Aid for Federal or State funding. Once all this has been completed, click on the Action tab in the Project overview and under Task select “Validate Project”. This will tell you if you are missing information.
Please refer to the “(?). Show Help” for further information on creating a Project.

**AT THIS POINT A REPORT CAN BE PRINTED TO SEND ALONG WITH YOUR ESBE AND TRAINEE REQUESTS** PLEASE USE THE CRYSTAL REPORTS ON BUSINESS OBJECTS AT:

http://crysrtsevertest.sa.state.nj.us/businessobjects/Enterprise115/admin/en/admin.cwr

After Federal Aid has been notified to apply funding to your project, and you have been notified that it has been done the following report MUST be printed and attached to your PS&E package:

- Open Precon, click on Projects.
- Search for your project by DP#.
- Select the Actions button within the project description on the right.
- Under Reports, select Preliminary Project Detail Estimate.
- Check or uncheck what you need in your report and select Execute.

**You must save or print your report.** Once you have exited out of this report the system will not save it. You will need to re-run the report again if not saved. This is true for all reports. All reports are viewed as PDF files.

**Create a Proposal**

1. Click Project and under Project Overview find your project.
   - Select the Actions button within the project description on the right.
   - Under Tasks click Create Proposal from Project.
   - Ensure that the following fields are populated and are correct:
     - Proposal ID
     - Proposal Description
     - Proposal Long Description (What is on the Adv. Memo)
     - Federal and State Project Number
     - Primary County must be filled
     - Primary District must be filled
     - Save
     - After the save you will then be at Proposal Summary

**General**

The information here is the same general information as above.

**Projects**

The project should already be associated with the proposal.

**Time**

- Ensure that the following fields are populated and are correct:
  - Click New
  - Time ID: 00
  - Time Description: ENTIRE SITE
  - Time Type: DT
Create Sections and Items

- Click the action button next to the save button.
- Under Tasks click Auto Generate Sections. The sections are now created.

Once this is done you can now validate the proposal.

- Click on Overview
- Type in the DP# for the project and click enter.
- Click on the action button in the project description to the right.
- Under Tasks click Validate Proposal, this will tell you if your proposal is valid or if you are missing information needed to make the proposal valid.

Generate the Bid Tab Analysis Report

- Search for your proposal by DP# Under Proposal Overview.
- Select the Actions button within the project description on the right.
- Under Reports, select Bid Tab Analysis.
- Check or uncheck what you need in your report and select Execute.

You must save or print your report. Once you have exited out of this report the system will not save it. You will need to re-run the report again if not saved. This is true for all reports. All reports are viewed as PDF files.
Appendix A: Procedures for Sub-Contracting an Estimate
Procedures for Sub-Contracting an Estimate

Sometimes consulting firms will sub-contract part of an estimate to another consulting firm. Because of how security works in CES, a consulting firm cannot see the job estimates of other consulting firms. This appendix outlines the procedures for sharing a job estimate when more than one consulting firm is involved in its creation.

Step 1: Prime Makes a Copy of “Prime” Estimate for Sub-contracting Firm

1. In the Job list window highlight the job to be copied.
2. Select Copy Special from the Edit menu and choose All.
3. Specify a new project name. The recommended format is <Current Job Number>-SUB. For example, project 12345 would be named 12345-SUB when copied.
4. The copied job is the “sub” estimate. The original job is the “prime” estimate.

Step 2: Prime Assigns “Sub” Estimate to Sub-contracting Firm

1. Right-click on the copied job and select Change from the menu.
2. Navigate to Page 2 of the GENERAL tab of the Job window.
3. Use the drop-down list in the Control Group field to select the sub-contracting firm that will be working on the estimate.
4. Save the change.
5. Notify the Sub-contracting firm that the “sub” estimate is now assigned to their firm in CES. The Prime consulting firm may still work on its part of the estimate using the “prime” estimate.

Step 3: Sub-contracting Firm Creates Estimate

1. Based on the procedures outline in this manual, the sub-contracting firm should create an estimate as it normally would using the “sub” estimate assigned by the prime firm.
2. Once the sub-contracting firm completes the “sub” estimate, it should be assigned back to the prime consulting firm.

Step 4: Sub-contracting Firm Assigns Completed “Sub” Estimate to Prime

1. In the Job list window, select the “sub” estimate.
2. Right-click on the job and select Change from the menu.
3. Navigate to Page 2 of the GENERAL tab of the Job window.
4. Use the drop-down list in the Control Group field to select the prime contracting firm.
5. Save the change.
6. Notify the prime contracting firm that the “sub” estimate is now assigned to their firm in CES.

Step 5: Prime Imports Items from “Sub” Estimate to “Prime” Estimate

Note: Only items will be imported by this process – categories or other changes will not be imported.

1. In the Job list window, select the “prime” estimate.
2. Select Import from the File menu and choose Job Items from CES Job.
3. Select the “sub” estimate from the list.
4. Click ok.
5. For the Combine Jobs Option select “Do Not Combine Item Quantities.”
6. Receive message that “Import Completed Successfully.”

**Note:** A snapshot of the “prime” job was automatically created before the import.

7. Open the job estimate and verify the items imported as expected.
8. Make adjustments as needed.
9. Do not delete the “sub” estimate. It should be retained as a point of reference.
Appendix B: Federal Non-Participating Construction Cost Estimation Work Sheet
Federal Non-Participating Construction Cost Estimation Work Sheet

<table>
<thead>
<tr>
<th>Items of Work</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Approach slabs with any of the following conditions:</td>
<td></td>
</tr>
<tr>
<td>(a) if one-way traffic loading is less than 500 80-kN equivalent single axle load applications per day;</td>
<td></td>
</tr>
<tr>
<td>(b) posted speed limit is less than 35 m.p.h.;</td>
<td></td>
</tr>
<tr>
<td>(c) the abutments are not supported on pile foundations.</td>
<td></td>
</tr>
<tr>
<td>Fishing piers (or bridges) and pedestrian walkways for recreational access.</td>
<td></td>
</tr>
<tr>
<td>Greater than a 2 to 1 ratio of mitigation for wetland sites. FHWA sometimes participates in greater than 2 to 1 replacement if the impact is significant. Contact Project Manager for guidance.</td>
<td></td>
</tr>
<tr>
<td>Sometimes the use of liners for Wetland Mitigation Sites as they do not permit ground water recharge. Contact Project Manager for guidance.</td>
<td></td>
</tr>
<tr>
<td>Waterway openings and net fill requirements mandated by NJDEP when they differ from FHWA requirements.</td>
<td></td>
</tr>
<tr>
<td>Structures less than 20 feet in span if BR/BH funds are being utilized for the project.</td>
<td></td>
</tr>
<tr>
<td>Sidewalks on bridges when there are no sidewalks on the approaches for pedestrians. Contact Project Manager for guidance.</td>
<td></td>
</tr>
<tr>
<td>Maintenance dredging if the dredged material is not used as a fill.</td>
<td></td>
</tr>
<tr>
<td>Maintenance operations such as cleaning existing pipes, drainage structures, ditches, repairing impact attenuators, mowing etc. FHWA sometimes participates in this work. Contact Project Manager for guidance.</td>
<td></td>
</tr>
<tr>
<td>Items of work paid for by other agencies or private developers.</td>
<td></td>
</tr>
<tr>
<td>Sometimes Memorial and/or Vanity Plaques on structures.</td>
<td></td>
</tr>
<tr>
<td>Type II Noise Barriers</td>
<td></td>
</tr>
<tr>
<td>BR/BH funds for approach work past the touchdown points for new / rehabilitated structures.</td>
<td></td>
</tr>
<tr>
<td>Proprietary items without proper justification. Contact Project Manager for guidance.</td>
<td></td>
</tr>
<tr>
<td>Additional items not listed above. (see next page)</td>
<td></td>
</tr>
</tbody>
</table>


Total Federal Non-Participating Items
Appendix C: NJDOT New Item Number Request Form
**Return completed request to TRNSPORT.SUPPORT@DOT.NJ.GOV with supporting documentation**